summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2011-01-13 17:00:47 +0000
committerDoug Goldstein <cardoe@gentoo.org>2011-01-13 17:00:47 +0000
commit94d32ff75cdc78ec268f95b529d6665f89841ede (patch)
treebcfc4da5a05ff2adac29b6d188edb96ceeefce23 /app-emulation/virtinst
parentMarking Net-DNS-0.66-r1 ~ppc for bug 341865 (diff)
downloadgentoo-2-94d32ff75cdc78ec268f95b529d6665f89841ede.tar.gz
gentoo-2-94d32ff75cdc78ec268f95b529d6665f89841ede.tar.bz2
gentoo-2-94d32ff75cdc78ec268f95b529d6665f89841ede.zip
Add ebuild for live hg checkouts
(Portage version: 2.1.9.30/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/virtinst')
-rw-r--r--app-emulation/virtinst/ChangeLog9
-rw-r--r--app-emulation/virtinst/virtinst-9999.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/app-emulation/virtinst/ChangeLog b/app-emulation/virtinst/ChangeLog
index 115e7b7904ce..0a7c4984fd10 100644
--- a/app-emulation/virtinst/ChangeLog
+++ b/app-emulation/virtinst/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/virtinst
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.19 2010/09/02 19:12:36 cardoe Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.20 2011/01/13 17:00:47 cardoe Exp $
+
+*virtinst-9999 (13 Jan 2011)
+
+ 13 Jan 2011; Doug Goldstein <cardoe@gentoo.org> +virtinst-9999.ebuild:
+ Add ebuild for live hg checkouts
*virtinst-0.500.4 (02 Sep 2010)
diff --git a/app-emulation/virtinst/virtinst-9999.ebuild b/app-emulation/virtinst/virtinst-9999.ebuild
new file mode 100644
index 000000000000..5986712e39a1
--- /dev/null
+++ b/app-emulation/virtinst/virtinst-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-9999.ebuild,v 1.1 2011/01/13 17:00:47 cardoe Exp $
+
+#BACKPORTS=1
+
+EAPI=2
+
+if [[ ${PV} = *9999* ]]; then
+ EHG_REPO_URI="http://hg.fedorahosted.org/hg/python-virtinst"
+ HG_ECLASS="mercurial autotools"
+fi
+
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils ${HG_ECLASS}
+
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://virt-manager.et.redhat.com/download/sources/${PN}/${P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${P}-backports-${BACKPORTS}.tar.bz2}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+
+DESCRIPTION="Python modules for starting virtualized guest installations"
+HOMEPAGE="http://virt-manager.et.redhat.com/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND=">=app-emulation/libvirt-0.7.0[python]
+ dev-python/urlgrabber"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="virtconv virtinst"
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ distutils_src_prepare
+}