summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-04-28 21:33:45 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-04-28 21:33:45 +0000
commit3401faf90f0f98b5e3b604b98d98377d89d97357 (patch)
tree687168ab6c6f466a839b02776839471aea063b07 /app-emulation/virtinst
parentVersion bump. (diff)
downloadgentoo-2-3401faf90f0f98b5e3b604b98d98377d89d97357.tar.gz
gentoo-2-3401faf90f0f98b5e3b604b98d98377d89d97357.tar.bz2
gentoo-2-3401faf90f0f98b5e3b604b98d98377d89d97357.zip
bump version (bug #312731) and fix bug #311193. Remove older version with a bunch of known bugs we don't want to support since they're fixed in newer versions
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/virtinst')
-rw-r--r--app-emulation/virtinst/ChangeLog11
-rw-r--r--app-emulation/virtinst/files/virtinst-0.400.3-kvm-img.patch21
-rw-r--r--app-emulation/virtinst/virtinst-0.500.3.ebuild (renamed from app-emulation/virtinst/virtinst-0.500.1.ebuild)12
3 files changed, 19 insertions, 25 deletions
diff --git a/app-emulation/virtinst/ChangeLog b/app-emulation/virtinst/ChangeLog
index f300acb9eb2e..7c7c4b09bd4e 100644
--- a/app-emulation/virtinst/ChangeLog
+++ b/app-emulation/virtinst/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-emulation/virtinst
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.17 2010/02/09 17:04:02 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.18 2010/04/28 21:33:45 cardoe Exp $
+
+*virtinst-0.500.3 (28 Apr 2010)
+
+ 28 Apr 2010; Doug Goldstein <cardoe@gentoo.org>
+ -files/virtinst-0.400.3-kvm-img.patch, -virtinst-0.500.1.ebuild,
+ +virtinst-0.500.3.ebuild:
+ bump version (bug #312731) and fix bug #311193. Remove older version with
+ a bunch of known bugs we don't want to support since they're fixed in
+ newer versions
*virtinst-0.500.2 (09 Feb 2010)
diff --git a/app-emulation/virtinst/files/virtinst-0.400.3-kvm-img.patch b/app-emulation/virtinst/files/virtinst-0.400.3-kvm-img.patch
deleted file mode 100644
index ad701d31e345..000000000000
--- a/app-emulation/virtinst/files/virtinst-0.400.3-kvm-img.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Nur virtinst-0.400.3/virtconv/diskcfg.py virtinst-0.400.3-kvm-img/virtconv/diskcfg.py
---- virtinst-0.400.3/virtconv/diskcfg.py 2009-03-09 22:32:15.000000000 -0500
-+++ virtinst-0.400.3-kvm-img/virtconv/diskcfg.py 2009-05-20 10:55:13.000000000 -0500
-@@ -151,12 +151,17 @@
- Use qemu-img to convert the given disk. Note that at least some
- version of qemu-img cannot handle multi-file VMDKs, so this can
- easily go wrong.
-+ Gentoo, Debian, and Ubuntu (potentially others) install kvm-img
-+ with kvm and qemu-img with qemu. Both would work.
- """
-
- self.clean += [ absout ]
-
- ret, ignore, stderr = run_cmd(["qemu-img", "convert", "-O",
- qemu_formats[out_format], absin, absout])
-+ if ret = 127:
-+ ret, ignore, stderr = run_cmd(["kvm-img", "convert", "-O",
-+ qemu_formats[out_format], absin, absout])
- if ret != 0:
- raise RuntimeError("Disk conversion failed with "
- "exit status %d: %s" % (ret, "".join(stderr)))
diff --git a/app-emulation/virtinst/virtinst-0.500.1.ebuild b/app-emulation/virtinst/virtinst-0.500.3.ebuild
index 4da24b647ae7..d70fe74488bf 100644
--- a/app-emulation/virtinst/virtinst-0.500.1.ebuild
+++ b/app-emulation/virtinst/virtinst-0.500.3.ebuild
@@ -1,10 +1,14 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.500.1.ebuild,v 1.1 2009/12/08 14:49:39 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.500.3.ebuild,v 1.1 2010/04/28 21:33:45 cardoe Exp $
EAPI=2
-inherit distutils eutils
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
DESCRIPTION="Python modules for starting virtualized guest installations"
HOMEPAGE="http://virt-manager.et.redhat.com/"
@@ -16,3 +20,5 @@ IUSE=""
RDEPEND=">=app-emulation/libvirt-0.2.1
dev-python/urlgrabber"
DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="virtconv virtinst"