summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-02-12 05:44:12 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-02-12 05:44:12 +0000
commit9758a18fdd6474dd49873acf0bd43100ea3965c9 (patch)
tree512f3ed8313675c1f9aef9763ef4c646ef21c11d /app-emulation/vice
parentInstall glxext.h, glxmd.h and glxproto.h to /usr/lib/opengl. Stop symlinking ... (diff)
downloadgentoo-2-9758a18fdd6474dd49873acf0bd43100ea3965c9.tar.gz
gentoo-2-9758a18fdd6474dd49873acf0bd43100ea3965c9.tar.bz2
gentoo-2-9758a18fdd6474dd49873acf0bd43100ea3965c9.zip
version bump (bug #67601) - use flag diff from Christian Harms
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/ChangeLog7
-rw-r--r--app-emulation/vice/Manifest6
-rw-r--r--app-emulation/vice/files/digest-vice-1.161
-rw-r--r--app-emulation/vice/vice-1.16.ebuild61
4 files changed, 72 insertions, 3 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index 7c8d7aff0a34..29b16d3f847c 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/vice
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.20 2005/01/23 00:05:47 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.21 2005/02/12 05:44:12 mr_bones_ Exp $
+
+*vice-1.16 (12 Feb 2005)
+
+ 12 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org> +vice-1.16.ebuild:
+ version bump (bug #67601) - use flag diff from Christian Harms
22 Jan 2005; Chris Gianelloni <wolf31o2@gentoo.org> vice-1.14-r1.ebuild:
Changed use_with gnome to use_enable gnome and closing bug #77836.
diff --git a/app-emulation/vice/Manifest b/app-emulation/vice/Manifest
index 7138a727173a..fce036d7d345 100644
--- a/app-emulation/vice/Manifest
+++ b/app-emulation/vice/Manifest
@@ -1,6 +1,8 @@
-MD5 818191dd26c378e6d35b529adde42ac6 vice-1.14-r1.ebuild 1432
MD5 9157b08838537030a9390882efe5d677 ChangeLog 2492
+MD5 8f88d6feda047ae0e68e3c56da44a7e9 vice-1.16.ebuild 1292
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 818191dd26c378e6d35b529adde42ac6 vice-1.14-r1.ebuild 1432
+MD5 5467080b8555dc1bad201449fbdaf87e files/1.14-console-security.patch 3709
MD5 eca7586b8ef1c0d8665368c0328f9250 files/digest-vice-1.14-r1 62
+MD5 fd15ab780139d6d1ff8ed8c0d5d85f90 files/digest-vice-1.16 62
MD5 962c8cfd8a9a308b180e1a26c4973625 files/1.14-po-Makefile.patch 560
-MD5 5467080b8555dc1bad201449fbdaf87e files/1.14-console-security.patch 3709
diff --git a/app-emulation/vice/files/digest-vice-1.16 b/app-emulation/vice/files/digest-vice-1.16
new file mode 100644
index 000000000000..177cda862ec7
--- /dev/null
+++ b/app-emulation/vice/files/digest-vice-1.16
@@ -0,0 +1 @@
+MD5 23848e7fe588b32549a5ce4ccf056207 vice-1.16.tar.gz 3940579
diff --git a/app-emulation/vice/vice-1.16.ebuild b/app-emulation/vice/vice-1.16.ebuild
new file mode 100644
index 000000000000..a7ac92360738
--- /dev/null
+++ b/app-emulation/vice/vice-1.16.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.16.ebuild,v 1.1 2005/02/12 05:44:12 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="The Versatile Commodore 8-bit Emulator"
+HOMEPAGE="http://www.viceteam.org/"
+SRC_URI="ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/VICE/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="arts gnome nls sdl X Xaw3d"
+
+# FIXME: esound is required until configure.in is patched.
+DEPEND="virtual/libc
+ media-sound/esound
+ media-libs/libpng
+ sys-libs/zlib
+ arts? ( kde-base/arts )
+ ffmpeg? ( media-video/ffmpeg )
+ gnome? ( gnome-base/libgnomeui )
+ readline? ( sys-libs/readline )
+ sdl? ( media-libs/libsdl )
+ X? ( virtual/x11 )
+ Xaw3d? ( x11-libs/Xaw3d )"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --enable-fullscreen \
+ --enable-textfield \
+ --enable-ethernet \
+ --enable-realdevice \
+ --with-resid \
+ --without-midas \
+ $(use_enable ffmpeg) \
+ $(use_enable gnome gnomeui) \
+ $(use_enable nls) \
+ $(use_with X x) \
+ $(use_with Xaw3d xaw3d) \
+ $(use_with arts) \
+ $(use_with readline) \
+ $(use_with sdl) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ local docdir="${D}${GAMES_LIBDIR}/${PN}/doc"
+
+ make DESTDIR="${D}" install || die "make install failed"
+ dohtml "${docdir}/"* || die "dohtml failed"
+ dodoc \
+ AUTHORS ChangeLog FEEDBACK README \
+ "${docdir}/"{BUGS,NEWS,PETdoc.txt,TODO} \
+ "${docdir}/"{cbm_basic_tokens.txt,drive_info.txt,mon.txt,serial.txt}
+ rm -rf "${docdir}"
+ prepgamesdirs
+}