summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2009-11-22 09:30:42 +0000
committerMichael Januszewski <spock@gentoo.org>2009-11-22 09:30:42 +0000
commitcffbdd85dc4d59945c0ae22943686c7aecbc0d0a (patch)
treec6361f25f010b5d5fa86f263b1d68d94bda51e52 /app-emulation/uade
parentFix bug #293405 so that fts3 support compiles when tcl is not installed. The ... (diff)
downloadgentoo-2-cffbdd85dc4d59945c0ae22943686c7aecbc0d0a.tar.gz
gentoo-2-cffbdd85dc4d59945c0ae22943686c7aecbc0d0a.tar.bz2
gentoo-2-cffbdd85dc4d59945c0ae22943686c7aecbc0d0a.zip
Version bump.
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/uade')
-rw-r--r--app-emulation/uade/ChangeLog9
-rw-r--r--app-emulation/uade/uade-2.13.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/app-emulation/uade/ChangeLog b/app-emulation/uade/ChangeLog
index 2ea10714c574..381e3fcc5004 100644
--- a/app-emulation/uade/ChangeLog
+++ b/app-emulation/uade/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/uade
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.53 2008/11/30 19:32:10 spock Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.54 2009/11/22 09:30:42 spock Exp $
+
+*uade-2.13 (22 Nov 2009)
+
+ 22 Nov 2009; Michał Januszewski <spock@gentoo.org> +uade-2.13.ebuild:
+ Version bump.
30 Nov 2008; Michał Januszewski <spock@gentoo.org>
+files/uade-2.12-asneeded.patch, -uade-2.02.ebuild, -uade-2.03.ebuild,
diff --git a/app-emulation/uade/uade-2.13.ebuild b/app-emulation/uade/uade-2.13.ebuild
new file mode 100644
index 000000000000..080cf471c184
--- /dev/null
+++ b/app-emulation/uade/uade-2.13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-2.13.ebuild,v 1.1 2009/11/22 09:30:42 spock Exp $
+
+inherit eutils
+
+DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation"
+HOMEPAGE="http://zakalwe.fi/uade"
+SRC_URI="http://zakalwe.fi/uade/uade2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="audacious"
+
+RDEPEND="media-libs/libao
+ audacious? ( <=media-sound/audacious-2.1 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --package-prefix="${D}" \
+ $(use_with audacious) \
+ --with-uade123 \
+ --with-text-scope \
+ --without-xmms \
+ || die "configure failed"
+ emake || die 'emake failed'
+}
+
+src_install() {
+ make install || die 'make install failed'
+ dodoc AUTHORS ChangeLog doc/BUGS doc/PLANS
+ doman doc/uade123.1
+}