summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-01-03 18:12:12 +0000
committerMichael Januszewski <spock@gentoo.org>2008-01-03 18:12:12 +0000
commit42166547f7848fc7d0412c0e47936222f26b2c18 (patch)
treed09cdedfce6b87f21b9387a28c8b03c374479266 /app-emulation/uade
parentVersion bump. (diff)
downloadgentoo-2-42166547f7848fc7d0412c0e47936222f26b2c18.tar.gz
gentoo-2-42166547f7848fc7d0412c0e47936222f26b2c18.tar.bz2
gentoo-2-42166547f7848fc7d0412c0e47936222f26b2c18.zip
Remove old ebuilds.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'app-emulation/uade')
-rw-r--r--app-emulation/uade/ChangeLog7
-rw-r--r--app-emulation/uade/files/digest-uade-2.053
-rw-r--r--app-emulation/uade/files/digest-uade-2.063
-rw-r--r--app-emulation/uade/files/uade-2.05-audacious-1.3api.patch165
-rw-r--r--app-emulation/uade/uade-2.05.ebuild44
-rw-r--r--app-emulation/uade/uade-2.06.ebuild36
6 files changed, 6 insertions, 252 deletions
diff --git a/app-emulation/uade/ChangeLog b/app-emulation/uade/ChangeLog
index 0f3c2b089ff8..970896f82587 100644
--- a/app-emulation/uade/ChangeLog
+++ b/app-emulation/uade/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/uade
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.47 2008/01/03 18:08:34 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.48 2008/01/03 18:12:11 spock Exp $
+
+ 03 Jan 2008; Michał Januszewski <spock@gentoo.org>
+ -files/uade-2.05-audacious-1.3api.patch, -uade-2.05.ebuild,
+ -uade-2.06.ebuild:
+ Remove old ebuilds.
*uade-2.09 (03 Jan 2008)
diff --git a/app-emulation/uade/files/digest-uade-2.05 b/app-emulation/uade/files/digest-uade-2.05
deleted file mode 100644
index aa226a269715..000000000000
--- a/app-emulation/uade/files/digest-uade-2.05
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 5a8304ce122c0aef853a60075a83a551 uade-2.05.tar.bz2 2506572
-RMD160 d84d78cfd0ff27b8daa9789109c1b5c955e9ba99 uade-2.05.tar.bz2 2506572
-SHA256 3c1f08d1eaa19d3381407994b5190bbd01ff97e9aaec992ddcbdfa245724eead uade-2.05.tar.bz2 2506572
diff --git a/app-emulation/uade/files/digest-uade-2.06 b/app-emulation/uade/files/digest-uade-2.06
deleted file mode 100644
index 278bc281b9d4..000000000000
--- a/app-emulation/uade/files/digest-uade-2.06
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 a19bb1014678b3f23926a4241c57e303 uade-2.06.tar.bz2 2563385
-RMD160 d74154dfd4ca549428caf1338acbc46f846320c7 uade-2.06.tar.bz2 2563385
-SHA256 4665fdddc4dc554d5ea65c505ce6f4438f5877be37289e9cba2f5914099bf050 uade-2.06.tar.bz2 2563385
diff --git a/app-emulation/uade/files/uade-2.05-audacious-1.3api.patch b/app-emulation/uade/files/uade-2.05-audacious-1.3api.patch
deleted file mode 100644
index e93c92c9e2ea..000000000000
--- a/app-emulation/uade/files/uade-2.05-audacious-1.3api.patch
+++ /dev/null
@@ -1,165 +0,0 @@
-diff -ruN uade.orig/src/frontends/audacious/plugin.c uade/src/frontends/audacious/plugin.c
---- uade.orig/src/frontends/audacious/plugin.c 2006-07-02 13:51:17.000000000 +0200
-+++ uade/src/frontends/audacious/plugin.c 2007-02-02 21:57:26.000000000 +0100
-@@ -45,13 +45,13 @@
- static void uade_cleanup(void);
- static void uade_file_info(char *filename);
- static void uade_get_song_info(char *filename, char **title, int *length);
--static int uade_get_time(void);
-+static int uade_get_time(InputPlayback *playback);
- static void uade_init(void);
- static int uade_is_our_file(char *filename);
--static void uade_pause(short paused);
--static void uade_play_file(char *filename);
--static void uade_seek(int time);
--static void uade_stop(void);
-+static void uade_pause(InputPlayback *playback, short paused);
-+static void uade_play_file(InputPlayback *playback);
-+static void uade_seek(InputPlayback *playback, int time);
-+static void uade_stop(InputPlayback *playback);
- static void uade_info_string(void);
-
-
-@@ -371,6 +371,8 @@
-
- static void *play_loop(void *arg)
- {
-+ InputPlayback *playback = arg;
-+
- enum uade_control_state state = UADE_S_STATE;
- int ret;
- int left = 0;
-@@ -402,13 +404,13 @@
- uade_lock();
- if (uade_seek_forward) {
- skip_bytes += uade_seek_forward * (UADE_BYTES_PER_FRAME * config.frequency);
-- uade_ip.output->flush(uade_ip.output->written_time() + uade_seek_forward * 1000);
-+ playback->output->flush(playback->output->written_time() + uade_seek_forward * 1000);
- uade_seek_forward = 0;
- }
- if (uade_select_sub != -1) {
- uadesong->cur_subsong = uade_select_sub;
- uade_change_subsong(uadesong->cur_subsong, &uadeipc);
-- uade_ip.output->flush(0);
-+ playback->output->flush(0);
- uade_select_sub = -1;
- subsong_end = 0;
- subsong_bytes = 0;
-@@ -425,9 +427,9 @@
- song_end_trigger = 1;
- } else {
- uade_change_subsong(uadesong->cur_subsong, &uadeipc);
-- while (uade_ip.output->buffer_playing())
-+ while (playback->output->buffer_playing())
- xmms_usleep(10000);
-- uade_ip.output->flush(0);
-+ playback->output->flush(0);
- subsong_end = 0;
- subsong_bytes = 0;
-
-@@ -444,7 +446,7 @@
- if (song_end_trigger) {
- /* We must drain the audio fast if abort_playing happens (e.g.
- the user changes song when we are here waiting the sound device) */
-- while (uade_ip.output->buffer_playing() && abort_playing == 0)
-+ while (playback->output->buffer_playing() && abort_playing == 0)
-
- xmms_usleep(10000);
- break;
-@@ -501,7 +503,7 @@
- }
-
- uade_effect_run(&effects, (int16_t *) um->data, play_bytes / framesize);
-- produce_audio(uade_ip.output->written_time(), sample_format, UADE_CHANNELS, play_bytes, um->data, &uade_thread_running);
-+ produce_audio(playback->output->written_time(), sample_format, UADE_CHANNELS, play_bytes, um->data, &uade_thread_running);
-
- if (config.timeout != -1 && config.use_timeouts) {
- if (song_end_trigger == 0) {
-@@ -675,8 +677,9 @@
- }
-
-
--static void uade_play_file(char *filename)
-+static void uade_play_file(InputPlayback *playback)
- {
-+ char *filename = playback->filename;
- char tempname[PATH_MAX];
- char *t;
-
-@@ -716,7 +719,7 @@
- uade_spawn(&uadeipc, &uadepid, UADE_CONFIG_UADE_CORE, configname);
- }
-
-- if (!uade_ip.output->open_audio(sample_format, config_backup.frequency, UADE_CHANNELS)) {
-+ if (!playback->output->open_audio(sample_format, config_backup.frequency, UADE_CHANNELS)) {
- abort_playing = 1;
- return;
- }
-@@ -748,7 +751,7 @@
- if (initialize_song(filename) == FALSE)
- goto err;
-
-- if (pthread_create(&decode_thread, NULL, play_loop, NULL)) {
-+ if (pthread_create(&decode_thread, NULL, play_loop, playback)) {
- fprintf(stderr, "uade: can't create play_loop() thread\n");
- uade_unalloc_song(uadesong);
- uade_lock();
-@@ -762,11 +765,11 @@
-
- err:
- /* close audio that was opened */
-- uade_ip.output->close_audio();
-+ playback->output->close_audio();
- abort_playing = 1;
- }
-
--static void uade_stop(void)
-+static void uade_stop(InputPlayback *playback)
- {
- /* Signal other subsystems to proceed to finished state as soon as possible
- */
-@@ -803,22 +806,22 @@
- uade_unlock();
- }
-
-- uade_ip.output->close_audio();
-+ playback->output->close_audio();
- }
-
-
- /* XMMS calls this function when pausing or unpausing */
--static void uade_pause(short paused)
-+static void uade_pause(InputPlayback *playback, short paused)
- {
- uade_lock();
- uade_is_paused = paused;
- uade_unlock();
-- uade_ip.output->pause(paused);
-+ playback->output->pause(paused);
- }
-
-
- /* XMMS calls this function when song is seeked */
--static void uade_seek(int time)
-+static void uade_seek(InputPlayback *playback, int time)
- {
- uade_gui_seek_subsong(time);
- }
-@@ -827,7 +830,7 @@
- /* XMMS calls this function periodically to determine current playing time.
- We use this function to report song name and title after play_file(),
- and to tell XMMS to end playing if song ends for any reason. */
--static int uade_get_time(void)
-+static int uade_get_time(InputPlayback *playback)
- {
- if (abort_playing || last_beat_played)
- return -1;
-@@ -842,7 +845,7 @@
- file_info_update(gui_module_filename, gui_player_filename, gui_modulename, gui_playername, gui_formatname);
- }
-
-- return uade_ip.output->output_time();
-+ return playback->output->output_time();
- }
-
-
diff --git a/app-emulation/uade/uade-2.05.ebuild b/app-emulation/uade/uade-2.05.ebuild
deleted file mode 100644
index 2379f58badd2..000000000000
--- a/app-emulation/uade/uade-2.05.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-2.05.ebuild,v 1.2 2007/03/16 20:03:01 spock Exp $
-
-inherit eutils
-
-DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation and cloned m68k-assembler Eagleplayer API"
-HOMEPAGE="http://zakalwe.fi/uade"
-SRC_URI="http://zakalwe.fi/uade/uade2/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="audacious"
-
-RDEPEND="media-libs/libao
- audacious? ( >=media-sound/audacious-0.2 )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- if has_version ">=media-sound/audacious-1.3.0"; then
- epatch ${FILESDIR}/uade-2.05-audacious-1.3api.patch
- fi
-}
-
-src_compile() {
- ./configure \
- --prefix=/usr \
- --package-prefix="${D}" \
- $(use_with audacious) \
- --without-xmms \
- || die "configure failed"
- emake || die 'emake failed'
-}
-
-src_install() {
- make install || die 'make install failed'
- dodoc AUTHORS ChangeLog doc/BUGS doc/PLANS
- doman doc/uade123.1
-}
diff --git a/app-emulation/uade/uade-2.06.ebuild b/app-emulation/uade/uade-2.06.ebuild
deleted file mode 100644
index 0f32819e7399..000000000000
--- a/app-emulation/uade/uade-2.06.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-2.06.ebuild,v 1.1 2007/04/13 18:27:07 spock Exp $
-
-inherit eutils
-
-DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation and cloned m68k-assembler Eagleplayer API"
-HOMEPAGE="http://zakalwe.fi/uade"
-SRC_URI="http://zakalwe.fi/uade/uade2/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="audacious"
-
-RDEPEND="media-libs/libao
- audacious? ( >=media-sound/audacious-0.2 )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_compile() {
- ./configure \
- --prefix=/usr \
- --package-prefix="${D}" \
- $(use_with audacious) \
- --without-xmms \
- || die "configure failed"
- emake || die 'emake failed'
-}
-
-src_install() {
- make install || die 'make install failed'
- dodoc AUTHORS ChangeLog doc/BUGS doc/PLANS
- doman doc/uade123.1
-}