summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Mendoza <ricmm@gentoo.org>2010-04-08 18:05:20 +0000
committerRicardo Mendoza <ricmm@gentoo.org>2010-04-08 18:05:20 +0000
commitedd4347019fe2ed2c6eb0e504b3f73f8ac521c92 (patch)
tree5c298eef3900ed5ee191427c1031ccdbccf8dadf /app-emulation/spim
parentUpdate HOMEPAGE. (diff)
downloadgentoo-2-edd4347019fe2ed2c6eb0e504b3f73f8ac521c92.tar.gz
gentoo-2-edd4347019fe2ed2c6eb0e504b3f73f8ac521c92.tar.bz2
gentoo-2-edd4347019fe2ed2c6eb0e504b3f73f8ac521c92.zip
Version bump. License update.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/spim')
-rw-r--r--app-emulation/spim/ChangeLog8
-rw-r--r--app-emulation/spim/files/spim-8.0-respect_env.patch155
-rw-r--r--app-emulation/spim/spim-8.0.ebuild81
3 files changed, 243 insertions, 1 deletions
diff --git a/app-emulation/spim/ChangeLog b/app-emulation/spim/ChangeLog
index 39b4e9d6268c..667871fea4cb 100644
--- a/app-emulation/spim/ChangeLog
+++ b/app-emulation/spim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/spim
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spim/ChangeLog,v 1.50 2010/01/15 02:27:54 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spim/ChangeLog,v 1.51 2010/04/08 18:05:20 ricmm Exp $
+
+*spim-8.0 (08 Apr 2010)
+
+ 08 Apr 2010; <ricmm@gentoo.org> +spim-8.0.ebuild,
+ +files/spim-8.0-respect_env.patch:
+ Version bump. License changed.
15 Jan 2010; Jonathan Callen <abcd@gentoo.org> spim-7.5.ebuild:
Add prefix keywords
diff --git a/app-emulation/spim/files/spim-8.0-respect_env.patch b/app-emulation/spim/files/spim-8.0-respect_env.patch
new file mode 100644
index 000000000000..3df337848049
--- /dev/null
+++ b/app-emulation/spim/files/spim-8.0-respect_env.patch
@@ -0,0 +1,155 @@
+--- spim-8.0-orig/spim/Makefile 2010-01-09 05:22:57.000000000 +0000
++++ spim-8.0/spim/Makefile 2010-04-08 18:49:55.000000000 +0100
+@@ -66,13 +66,13 @@
+
+
+ # Full path for the directory that will hold the executable files:
+-BIN_DIR = /usr/local/bin
++BIN_DIR = $(DESTDIR)/usr/bin
+
+ # Full path for the directory that will hold the exception handler:
+-EXCEPTION_DIR = /usr/local/lib/spim
++EXCEPTION_DIR = $(DESTDIR)/var/lib/spim
+
+ # Full path for the directory that will hold the man files:
+-MAN_DIR = /usr/local/man/en
++MAN_DIR = $(DESTDIR)/usr/share/man
+
+
+ # If you have flex, use it instead of lex. If you use flex, define this
+@@ -105,10 +105,9 @@
+ DEFINES = $(ENDIAN) $(MEM_SIZES) -DDEFAULT_EXCEPTION_HANDLER="\"$(EXCEPTION_DIR)/exceptions.s\"" -DSPIM_VERSION="\"`cat ../VERSION`\""
+
+ CC = gcc
+-CFLAGS = -I. -I$(CPU_DIR) $(DEFINES) -g -Wall
++CFLAGS = -I. -I$(CPU_DIR) $(DEFINES) -Wall
+ YFLAGS = -d --file-prefix=y
+ YCFLAGS =
+-LDFLAGS = -lm
+ CSH = bash
+
+ # lex.yy.c is usually compiled with -O to speed it up.
+@@ -122,10 +121,10 @@
+
+
+ spim: force
+- make -f Makefile spim2
++ $(MAKE) -f Makefile spim2
+
+ spim2: $(OBJS) spim.o
+- $(CC) -g $(OBJS) spim.o $(LDFLAGS) -o spim -lm
++ $(CC) $(OBJS) spim.o $(LDFLAGS) -o spim -lm
+
+
+ force: configuration
+@@ -143,19 +142,19 @@
+ @echo
+ @echo "Testing tt.bare.s:"
+ $(CSH) -c "./spim -delayed_branches -delayed_loads -noexception -file $(TEST_DIR)/tt.bare.s >& test.out"
+- @tail -2 test.out
++ @tail -n2 test.out
+ @echo
+
+ @echo
+ @echo "Testing tt.core.s:"
+ $(CSH) -c "./spim -ef $(CPU_DIR)/exceptions.s -file $(TEST_DIR)/tt.core.s < $(TEST_DIR)/tt.in >& test.out"
+- @tail -2 test.out
++ @tail -n2 test.out
+ @echo
+
+ @echo
+ @echo "Testing tt.endian.s:"
+ $(CSH) -c "./spim -ef $(CPU_DIR)/exceptions.s -file $(TEST_DIR)/tt.endian.s >& test.out"
+- @tail -2 test.out
++ @tail -n2 test.out
+ @echo
+ @echo
+
+@@ -166,13 +165,13 @@
+ @echo
+ @echo "Testing tt.alu.bare.s:"
+ $(CSH) -c "./spim -bare -noexception -file $(TEST_DIR)/tt.alu.bare.s >& test.out"
+- @tail -2 test.out
++ @tail -n2 test.out
+ @echo
+
+ @echo
+ @echo "Testing tt.fpt.bare.s:"
+ $(CSH) -c "./spim -bare -noexception -file $(TEST_DIR)/tt.fpu.bare.s >& test.out"
+- @tail -2 test.out
++ @tail -n2 test.out
+ @echo
+ @echo
+
+@@ -192,8 +191,6 @@
+ install -m 0444 $(CPU_DIR)/exceptions.s $(EXCEPTION_DIR)/exceptions.s
+
+ install-man:
+- install -d $(MAN_DIR)
+- install -m 0444 $(DOC_DIR)/spim.man $(MAN_DIR)
+
+ very-clean: clean
+ rm -f configuration
+--- spim-8.0-orig/xspim/Makefile 2010-01-09 05:22:58.000000000 +0000
++++ spim-8.0/xspim/Makefile 2010-04-08 18:52:21.000000000 +0100
+@@ -175,8 +175,7 @@
+ # from top Makefile
+ BOOTSTRAPCFLAGS =
+
+- CC = gcc -m32
+- AS = gcc -m32 -c -x assembler
++ AS = $(CC) -m32 -c -x assembler
+
+ .SUFFIXES: .cc
+
+@@ -201,12 +200,12 @@
+
+ CPP = cpp $(STD_CPP_DEFINES)
+ RAWCPP = cpp -undef $(STD_CPP_OPTIONS)
+- PREPROCESSCMD = gcc -m32 -E $(STD_CPP_DEFINES)
++ PREPROCESSCMD = $(CC) -m32 -E $(STD_CPP_DEFINES)
+
+ INSTALL = install
+ INSTALLFLAGS = -c
+
+- LD = gcc -m32 -nostdlib
++ LD = $(CC) -m32 -nostdlib
+
+ LEX = flex -l
+ M4 = m4
+@@ -270,14 +269,14 @@
+ COL = col
+ COLFLAGS = -b
+
+- MODCC = gcc -m32
++ MODCC = $(CC) -m32
+
+ MODCPP = cpp
+ MODCFLAGS = $(CFLAGS)
+- MODAS = gcc -m32 -c -x assembler
++ MODAS = $(CC) -m32 -c -x assembler
+ MODASFLAGS =
+
+- MODLD = gcc -m32 -nostdlib
++ MODLD = $(CC) -m32 -nostdlib
+
+ MODLDFLAGS =
+ MODLDCOMBINEFLAGS = -r
+@@ -330,7 +329,7 @@
+
+ ALLINCLUDES = $(INCLUDES) $(EXTRA_INCLUDES) $(TOP_INCLUDES) $(INSTALLED_INCLUDES) $(STD_INCLUDES)
+ ALLDEFINES = $(ALLINCLUDES) $(STD_DEFINES) $(PROTO_DEFINES) $(THREADS_DEFINES) $(MODULE_DEFINES) $(DEFINES) $(EXTRA_DEFINES)
+- CFLAGS = $(CDEBUGFLAGS) $(CCOPTIONS) $(THREADS_CFLAGS) $(MODULE_CFLAGS) $(ALLDEFINES)
++ CFLAGS = $(MODULE_CFLAGS) $(ALLDEFINES)
+ LINTFLAGS = $(LINTOPTS) -DLINT $(ALLDEFINES) $(DEPEND_DEFINES)
+ LDPRELIB = $(INSTALLED_LIBS)
+ LDPOSTLIB =
+@@ -339,7 +338,7 @@
+
+ LDLIBS = $(LDPOSTLIBS) $(THREADS_LIBS) $(SYS_LIBRARIES) $(EXTRA_LIBRARIES)
+
+- CCLINK = $(CC)
++ CCLINK = $(CC) $(LDFLAGS)
+
+ CXXLINK = $(CXX)
+
diff --git a/app-emulation/spim/spim-8.0.ebuild b/app-emulation/spim/spim-8.0.ebuild
new file mode 100644
index 000000000000..05510cba7d19
--- /dev/null
+++ b/app-emulation/spim/spim-8.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spim/spim-8.0.ebuild,v 1.1 2010/04/08 18:05:20 ricmm Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="MIPS Simulator"
+HOMEPAGE="http://www.cs.wisc.edu/~larus/spim.html"
+SRC_URI="http://www.cs.wisc.edu/~larus/SPIM/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="X"
+
+RDEPEND="X? ( x11-libs/libXaw
+ x11-libs/libXp )"
+DEPEND="${RDEPEND}
+ X? ( x11-misc/imake
+ x11-proto/xproto )
+ >=sys-apps/sed-4
+ sys-devel/bison"
+
+src_prepare() {
+ # fix bugs 240005 and 243588
+ epatch "${FILESDIR}/${P}-respect_env.patch"
+ tc-export CC
+
+ # Fix documentation files
+ cd "${S}/Documentation"
+ mv spim.man spim.1
+ mv xspim.man xspim.1
+}
+
+src_configure() {
+ cd "${S}/spim"
+ ./Configure || die "Configure Failed!"
+
+ if use X; then
+ cd "${S}/xspim"
+ ./Configure || die "Configure Failed!"
+ fi
+}
+
+src_compile() {
+ cd "${S}/spim"
+ emake || die
+
+ if use X; then
+ cd "${S}/xspim"
+ emake -j1 xspim || die
+ fi
+}
+
+src_install() {
+ dodir /var/lib/spim || die
+ dodoc README VERSION ChangeLog || die
+
+ cd "${S}/spim"
+ emake DESTDIR="${D}" install || die "Unable to install spim"
+
+ if use X; then
+ cd "${S}/xspim"
+ emake DESTDIR="${D}" install || die "Unable to install xspim"
+
+ doman "${S}/Documentation/xspim.1"
+ fi
+
+ cd "${S}/Documentation"
+ doman spim.1 || die
+
+ dohtml SPIM.html || die
+ dodoc BLURB || die
+}
+
+src_test() {
+ cd "${S}/spim"
+ make test || die "Failed to pass tests!"
+}