summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-14 20:18:17 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-14 20:18:17 +0000
commit85c46fbd134c8d6c4cf7421ba8ed30857d0ee22a (patch)
tree41a2e84c0020bcfe238fc949b36c1978b06d993f /app-emulation/spice
parentRemove old. (diff)
downloadgentoo-2-85c46fbd134c8d6c4cf7421ba8ed30857d0ee22a.tar.gz
gentoo-2-85c46fbd134c8d6c4cf7421ba8ed30857d0ee22a.tar.bz2
gentoo-2-85c46fbd134c8d6c4cf7421ba8ed30857d0ee22a.zip
app-emulation/spice: Fix gold patch
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/spice')
-rw-r--r--app-emulation/spice/ChangeLog6
-rw-r--r--app-emulation/spice/files/0.11.0-gold.patch30
-rw-r--r--app-emulation/spice/spice-0.11.0.ebuild7
3 files changed, 38 insertions, 5 deletions
diff --git a/app-emulation/spice/ChangeLog b/app-emulation/spice/ChangeLog
index a4ef203d688a..1925a8e233d5 100644
--- a/app-emulation/spice/ChangeLog
+++ b/app-emulation/spice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/spice
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.28 2012/06/14 20:04:44 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.29 2012/06/14 20:18:17 jlec Exp $
+
+ 14 Jun 2012; Justin Lecher <jlec@gentoo.org> +files/0.11.0-gold.patch,
+ spice-0.11.0.ebuild:
+ Fix gold patch
14 Jun 2012; Justin Lecher <jlec@gentoo.org> spice-0.11.0.ebuild,
metadata.xml:
diff --git a/app-emulation/spice/files/0.11.0-gold.patch b/app-emulation/spice/files/0.11.0-gold.patch
new file mode 100644
index 000000000000..ad08c14e9abc
--- /dev/null
+++ b/app-emulation/spice/files/0.11.0-gold.patch
@@ -0,0 +1,30 @@
+ server/tests/Makefile.am | 2 ++
+ server/tests/Makefile.in | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletions(-)
+
+diff --git a/server/tests/Makefile.am b/server/tests/Makefile.am
+index e77865c..905de9d 100644
+--- a/server/tests/Makefile.am
++++ b/server/tests/Makefile.am
+@@ -19,6 +19,8 @@ LDADD = \
+ $(top_builddir)/server/libspice-server.la \
+ $(NULL)
+
++AM_LDFLAGS = -pthread
++
+ COMMON_BASE = \
+ basic_event_loop.c \
+ basic_event_loop.h \
+diff --git a/server/tests/Makefile.in b/server/tests/Makefile.in
+index 5b177e2..3aacfd3 100644
+--- a/server/tests/Makefile.in
++++ b/server/tests/Makefile.in
+@@ -144,7 +144,7 @@ am__v_at_0 = @
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
+ $(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+- $(AM_LDFLAGS) $(LDFLAGS) -o $@
++ $(AM_LDFLAGS) $(LDFLAGS) -pthread -o $@
+ AM_V_CCLD = $(am__v_CCLD_@AM_V@)
+ am__v_CCLD_ = $(am__v_CCLD_@AM_DEFAULT_V@)
+ am__v_CCLD_0 = @echo " CCLD " $@;
diff --git a/app-emulation/spice/spice-0.11.0.ebuild b/app-emulation/spice/spice-0.11.0.ebuild
index b2799f496d91..d0aa2a56383e 100644
--- a/app-emulation/spice/spice-0.11.0.ebuild
+++ b/app-emulation/spice/spice-0.11.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.11.0.ebuild,v 1.3 2012/06/14 20:04:44 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.11.0.ebuild,v 1.4 2012/06/14 20:18:17 jlec Exp $
EAPI=4
PYTHON_DEPEND="2"
-inherit python
+inherit eutils python
DESCRIPTION="SPICE server and client."
HOMEPAGE="http://spice-space.org/"
@@ -65,8 +65,7 @@ pkg_setup() {
src_prepare() {
epatch \
- "${FILESDIR}/0.10.1-gold.patch"
- eautoreconf
+ "${FILESDIR}/${PV}-gold.patch"
}
src_configure() {