summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2011-02-17 10:28:44 +0000
committerTiziano Müller <dev-zero@gentoo.org>2011-02-17 10:28:44 +0000
commit49fad1492684d1400fa9e46744482b55059a6f5c (patch)
treec220ff0150d9e2af6ce391c10248458e34ddf919 /app-emulation/spice
parentVersion bump. Dropped old. (diff)
downloadgentoo-2-49fad1492684d1400fa9e46744482b55059a6f5c.tar.gz
gentoo-2-49fad1492684d1400fa9e46744482b55059a6f5c.tar.bz2
gentoo-2-49fad1492684d1400fa9e46744482b55059a6f5c.zip
Version bump. Dropped old.
(Portage version: 2.1.9.39/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/spice')
-rw-r--r--app-emulation/spice/ChangeLog12
-rw-r--r--app-emulation/spice/files/0001-Added-initial-connection-url-handling-using-the-urip.patch158
-rw-r--r--app-emulation/spice/files/spice.protocol12
-rw-r--r--app-emulation/spice/files/spice.schemas41
-rw-r--r--app-emulation/spice/spice-0.6.4.ebuild (renamed from app-emulation/spice/spice-0.6.3.ebuild)11
-rw-r--r--app-emulation/spice/spice-0.7.1.ebuild79
-rw-r--r--app-emulation/spice/spice-0.7.2.ebuild79
-rw-r--r--app-emulation/spice/spice-0.7.3.ebuild (renamed from app-emulation/spice/spice-0.5.3.ebuild)21
8 files changed, 27 insertions, 386 deletions
diff --git a/app-emulation/spice/ChangeLog b/app-emulation/spice/ChangeLog
index a85473e4e306..241a6afffbce 100644
--- a/app-emulation/spice/ChangeLog
+++ b/app-emulation/spice/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-emulation/spice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.7 2011/02/05 07:53:04 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.8 2011/02/17 10:28:44 dev-zero Exp $
+
+*spice-0.7.3 (17 Feb 2011)
+*spice-0.6.4 (17 Feb 2011)
+
+ 17 Feb 2011; Tiziano Müller <dev-zero@gentoo.org>
+ -files/0001-Added-initial-connection-url-handling-using-the-urip.patch,
+ -spice-0.5.3.ebuild, -spice-0.6.3.ebuild, +spice-0.6.4.ebuild,
+ -spice-0.7.1.ebuild, -spice-0.7.2.ebuild, +spice-0.7.3.ebuild,
+ -files/spice.protocol, -files/spice.schemas:
+ Version bump. Dropped old.
*spice-0.7.2 (05 Feb 2011)
diff --git a/app-emulation/spice/files/0001-Added-initial-connection-url-handling-using-the-urip.patch b/app-emulation/spice/files/0001-Added-initial-connection-url-handling-using-the-urip.patch
deleted file mode 100644
index 36ab8fc6c45f..000000000000
--- a/app-emulation/spice/files/0001-Added-initial-connection-url-handling-using-the-urip.patch
+++ /dev/null
@@ -1,158 +0,0 @@
-From d885244f70bff899b58f81eb4be76d7da3869706 Mon Sep 17 00:00:00 2001
-From: Tiziano Mueller <dev-zero@gentoo.org>
-Date: Fri, 24 Dec 2010 13:23:23 +0100
-Subject: [PATCH] Added initial connection url handling using the uriparser library for
- proper URI parsing and handling. Can handle port, tls-port and password
- for now.
-
----
- client/application.cpp | 61 ++++++++++++++++++++++++++++++++++++++++++++++++
- client/application.h | 1 +
- configure.ac | 19 +++++++++++++++
- 3 files changed, 81 insertions(+), 0 deletions(-)
-
-diff --git a/client/application.cpp b/client/application.cpp
-index d865e84..a9e86d1 100644
---- a/client/application.cpp
-+++ b/client/application.cpp
-@@ -53,6 +53,8 @@
- #include <smartcard_channel.h>
- #endif
-
-+#include <uriparser/Uri.h>
-+
- #define STICKY_KEY_PIXMAP ALT_IMAGE_RES_ID
- #define STICKY_KEY_TIMEOUT 750
-
-@@ -2130,6 +2132,56 @@ bool Application::set_disabled_display_effects(CmdLineParser& parser, char *val,
- return true;
- }
-
-+bool Application::parse_connection_uri(const char* uri, std::string& host, int& port, int& sport, std::string& password)
-+{
-+ UriParserStateA state;
-+ UriUriA uri_object;
-+
-+ state.uri = &uri_object;
-+
-+ if (uriParseUriA(&state, uri) != URI_SUCCESS) {
-+ uriFreeUriMembersA(&uri_object);
-+ return false;
-+ }
-+
-+ if ((uri_object.scheme.afterLast != uri_object.scheme.first + 5) ||
-+ (strncmp(uri_object.scheme.first, "spice", 5) != 0)) {
-+ uriFreeUriMembersA(&uri_object);
-+ return false;
-+ }
-+
-+ host.assign(uri_object.hostText.first, uri_object.hostText.afterLast);
-+
-+ UriQueryListA* queryList;
-+ int itemCount;
-+
-+ if (uriDissectQueryMallocA(&queryList, &itemCount,
-+ uri_object.query.first, uri_object.query.afterLast) != URI_SUCCESS) {
-+ uriFreeUriMembersA(&uri_object);
-+ return false;
-+ }
-+
-+ for (UriQueryListA* i(queryList); i != NULL; i = i->next) {
-+ if ((strcmp(i->key, "port") == 0) && (i->value != NULL)) {
-+ port = str_to_port(i->value);
-+ continue;
-+ }
-+ if ((strcmp(i->key, "tls-port") == 0) && (i->value != NULL)) {
-+ sport = str_to_port(i->value);
-+ continue;
-+ }
-+ if ((strcmp(i->key, "password") == 0) && (i->value != NULL)) {
-+ password = i->value;
-+ continue;
-+ }
-+ /* ignore all other parameters for now */
-+ }
-+
-+ uriFreeQueryListA(queryList);
-+ uriFreeUriMembersA(&uri_object);
-+ return true;
-+}
-+
- void Application::on_cmd_line_invalid_arg(const char* arg0, const char* what, const char* val)
- {
- Platform::term_printf("%s: invalid %s value %s\n", arg0, what, val);
-@@ -2185,6 +2237,7 @@ bool Application::process_cmd_line(int argc, char** argv)
- SPICE_OPT_HOST = CmdLineParser::OPTION_FIRST_AVILABLE,
- SPICE_OPT_PORT,
- SPICE_OPT_SPORT,
-+ SPICE_OPT_URI,
- SPICE_OPT_PASSWORD,
- SPICE_OPT_FULL_SCREEN,
- SPICE_OPT_SECURE_CHANNELS,
-@@ -2225,6 +2278,7 @@ bool Application::process_cmd_line(int argc, char** argv)
- parser.add(SPICE_OPT_HOST, "host", "spice server address", "host", true, 'h');
- parser.add(SPICE_OPT_PORT, "port", "spice server port", "port", true, 'p');
- parser.add(SPICE_OPT_SPORT, "secure-port", "spice server secure port", "port", true, 's');
-+ parser.add(SPICE_OPT_URI, "uri", "spice uri", "uri", true);
- parser.add(SPICE_OPT_SECURE_CHANNELS, "secure-channels",
- "force secure connection on the specified channels", "channel",
- true);
-@@ -2301,6 +2355,13 @@ bool Application::process_cmd_line(int argc, char** argv)
- }
- break;
- }
-+ case SPICE_OPT_URI: {
-+ if (parse_connection_uri(val, host, port, sport, password) == false) {
-+ on_cmd_line_invalid_arg(argv[0], "uri", val);
-+ return false;
-+ }
-+ break;
-+ }
- case SPICE_OPT_FULL_SCREEN:
- if (val) {
- if (strcmp(val, "auto-conf")) {
-diff --git a/client/application.h b/client/application.h
-index f9bbd53..f6ec524 100644
---- a/client/application.h
-+++ b/client/application.h
-@@ -289,6 +289,7 @@ private:
- bool set_canvas_option(CmdLineParser& parser, char *val, const char* arg0);
- bool set_disabled_display_effects(CmdLineParser& parser, char *val, const char* arg0,
- DisplaySetting& disp_setting);
-+ bool parse_connection_uri(const char* uri, std::string& host, int& port, int& sport, std::string& password);
- void on_cmd_line_invalid_arg(const char* arg0, const char* what, const char* val);
- bool process_cmd_line(int argc, char** argv);
- void register_channels();
-diff --git a/configure.ac b/configure.ac
-index 511d94e..ef4d68e 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -297,6 +297,25 @@ AC_SUBST(JPEG_LIBS)
- AC_CHECK_LIB(z, deflate, Z_LIBS='-lz', AC_MSG_ERROR([zlib not found]))
- AC_SUBST(Z_LIBS)
-
-+URIPARSER_MISSING="Please install uriparser 0.7.5 or later.
-+ On a Debian-based system enter 'sudo apt-get install liburiparser-dev'."
-+AC_CHECK_LIB(uriparser, uriParseUriA,, AC_MSG_ERROR(${URIPARSER_MISSING}))
-+AC_CHECK_HEADER(uriparser/Uri.h,, AC_MSG_ERROR(${URIPARSER_MISSING}))
-+
-+URIPARSER_TOO_OLD="uriparser 0.7.5 or later is required, your copy is too old."
-+AC_COMPILE_IFELSE([
-+#include <uriparser/Uri.h>
-+#if (defined(URI_VER_MAJOR) && defined(URI_VER_MINOR) && defined(URI_VER_RELEASE) \
-+&& ((URI_VER_MAJOR > 0) \
-+|| ((URI_VER_MAJOR == 0) && (URI_VER_MINOR > 7)) \
-+|| ((URI_VER_MAJOR == 0) && (URI_VER_MINOR == 7) && (URI_VER_RELEASE >= 5)) \
-+))
-+/* FINE */
-+#else
-+# error uriparser not recent enough
-+#endif
-+],,AC_MSG_ERROR(${URIPARSER_TOO_OLD}))
-+
- dnl ===========================================================================
- dnl check compiler flags
-
---
-1.7.3.4
-
diff --git a/app-emulation/spice/files/spice.protocol b/app-emulation/spice/files/spice.protocol
deleted file mode 100644
index 13a2817fd554..000000000000
--- a/app-emulation/spice/files/spice.protocol
+++ /dev/null
@@ -1,12 +0,0 @@
-[Protocol]
-exec=/usr/bin/spicec --uri "%u"
-protocol=spice
-input=none
-output=none
-helper=true
-listing=
-reading=false
-writing=false
-makedir=false
-deleting=false
-
diff --git a/app-emulation/spice/files/spice.schemas b/app-emulation/spice/files/spice.schemas
deleted file mode 100644
index f3ba2f5e5f87..000000000000
--- a/app-emulation/spice/files/spice.schemas
+++ /dev/null
@@ -1,41 +0,0 @@
-<?xml version="1.0"?>
-<gconfschemafile>
-<schemalist>
-<schema>
- <key>/schemas/desktop/gnome/url-handlers/spice/enabled</key>
- <applyto>/desktop/gnome/url-handlers/spice/enabled</applyto>
- <owner>spice</owner>
- <type>bool</type>
- <default>true</default>
- <locale name="C">
- <short>How to handle spice URLs</short>
- <long>Set to true to have a program specified in command handle spice URLs</long>
- </locale>
-</schema>
-
- <schema>
- <key>/schemas/desktop/gnome/url-handlers/spice/command</key>
- <applyto>/desktop/gnome/url-handlers/spice/command</applyto>
- <owner>spice</owner>
- <type>string</type>
- <default>/usr/bin/spicec --uri "%s"</default>
- <locale name="C">
- <short>URL handler for spice URIs</short>
- <long>URL handler for spice URIs</long>
- </locale>
- </schema>
-
- <schema>
- <key>/schemas/desktop/gnome/url-handlers/spice/need-terminal</key>
- <applyto>/desktop/gnome/url-handlers/spice/need-terminal</applyto>
- <owner>spice</owner>
- <type>bool</type>
- <default>false</default>
- <locale name="C">
- <short>Run program in terminal</short>
- <long>True if the program to handle this URL should be run in a terminal</long>
- </locale>
- </schema>
-</schemalist>
-</gconfschemafile>
-
diff --git a/app-emulation/spice/spice-0.6.3.ebuild b/app-emulation/spice/spice-0.6.4.ebuild
index a39ddfc960b9..bea498d67dc2 100644
--- a/app-emulation/spice/spice-0.6.3.ebuild
+++ b/app-emulation/spice/spice-0.6.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.6.3.ebuild,v 1.3 2010/11/18 12:52:29 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.6.4.ebuild,v 1.1 2011/02/17 10:28:44 dev-zero Exp $
-EAPI=3
+EAPI=4
DESCRIPTION="SPICE server and client."
HOMEPAGE="http://spice-space.org/"
@@ -25,7 +25,7 @@ RDEPEND="~app-emulation/spice-protocol-${PV}
x11-libs/libXfixes
virtual/jpeg
sys-libs/zlib
- gui? ( dev-games/cegui )"
+ gui? ( =dev-games/cegui-0.6* )"
DEPEND="dev-util/pkgconfig
${RDEPEND}"
@@ -40,7 +40,6 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc NEWS TODO
+ default
use static-libs || rm "${D}"/usr/lib*/*.la
}
diff --git a/app-emulation/spice/spice-0.7.1.ebuild b/app-emulation/spice/spice-0.7.1.ebuild
deleted file mode 100644
index a1b3753d37b4..000000000000
--- a/app-emulation/spice/spice-0.7.1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.7.1.ebuild,v 1.4 2011/01/05 15:04:32 dev-zero Exp $
-
-EAPI=3
-
-inherit autotools eutils gnome2-utils
-
-DESCRIPTION="SPICE server and client."
-HOMEPAGE="http://spice-space.org/"
-SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="gnome +gui kde static-libs uri"
-
-RDEPEND=">=app-emulation/spice-protocol-0.7.0
- >=x11-libs/pixman-0.17.7
- media-libs/alsa-lib
- media-libs/celt:0.5.1
- dev-libs/openssl
- >=x11-libs/libXrandr-1.2
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXrender
- x11-libs/libXfixes
- virtual/jpeg
- sys-libs/zlib
- gui? ( =dev-games/cegui-0.6* )
- uri? ( dev-libs/uriparser
- gnome? ( gnome-base/gconf ) )"
-DEPEND="dev-util/pkgconfig
- ${RDEPEND}"
-
-# maintainer notes:
-# * opengl support is currently broken
-
-src_prepare() {
- if use uri ; then
- epatch "${FILESDIR}/0001-Added-initial-connection-url-handling-using-the-urip.patch"
- eautoreconf
- fi
-}
-
-src_configure() {
- local myconf=""
- use gui && myconf+="--enable-gui "
- econf ${myconf} \
- $(use_enable static-libs static)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc NEWS TODO
- use static-libs || rm "${D}"/usr/lib*/*.la
-
- if use uri ; then
- if use gnome ; then
- insinto /etc/gconf/schemas
- doins "${FILESDIR}/spice.schemas"
- fi
- if use kde ; then
- insinto /usr/share/kde4/services
- doins "${FILESDIR}/spice.protocol"
- fi
- fi
-}
-
-pkg_preinst() {
- use uri && use gnome && gnome2_gconf_savelist
-}
-pkg_postinst() {
- use uri && use gnome && gnome2_gconf_install
-}
-
-pkg_prerm() {
- use uri && use gnome && gnome2_gconf_uninstall
-}
diff --git a/app-emulation/spice/spice-0.7.2.ebuild b/app-emulation/spice/spice-0.7.2.ebuild
deleted file mode 100644
index 9a701fd9eeaa..000000000000
--- a/app-emulation/spice/spice-0.7.2.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.7.2.ebuild,v 1.1 2011/02/05 07:53:04 dev-zero Exp $
-
-EAPI=3
-
-inherit autotools eutils gnome2-utils
-
-DESCRIPTION="SPICE server and client."
-HOMEPAGE="http://spice-space.org/"
-SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="gnome +gui kde static-libs uri"
-
-RDEPEND=">=app-emulation/spice-protocol-0.7.0
- >=x11-libs/pixman-0.17.7
- media-libs/alsa-lib
- media-libs/celt:0.5.1
- dev-libs/openssl
- >=x11-libs/libXrandr-1.2
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXrender
- x11-libs/libXfixes
- virtual/jpeg
- sys-libs/zlib
- gui? ( =dev-games/cegui-0.6* )
- uri? ( dev-libs/uriparser
- gnome? ( gnome-base/gconf ) )"
-DEPEND="dev-util/pkgconfig
- ${RDEPEND}"
-
-# maintainer notes:
-# * opengl support is currently broken
-
-src_prepare() {
- if use uri ; then
- epatch "${FILESDIR}/0001-Added-initial-connection-url-handling-using-the-urip.patch"
- eautoreconf
- fi
-}
-
-src_configure() {
- local myconf=""
- use gui && myconf+="--enable-gui "
- econf ${myconf} \
- $(use_enable static-libs static)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc NEWS TODO
- use static-libs || rm "${D}"/usr/lib*/*.la
-
- if use uri ; then
- if use gnome ; then
- insinto /etc/gconf/schemas
- doins "${FILESDIR}/spice.schemas"
- fi
- if use kde ; then
- insinto /usr/share/kde4/services
- doins "${FILESDIR}/spice.protocol"
- fi
- fi
-}
-
-pkg_preinst() {
- use uri && use gnome && gnome2_gconf_savelist
-}
-pkg_postinst() {
- use uri && use gnome && gnome2_gconf_install
-}
-
-pkg_prerm() {
- use uri && use gnome && gnome2_gconf_uninstall
-}
diff --git a/app-emulation/spice/spice-0.5.3.ebuild b/app-emulation/spice/spice-0.7.3.ebuild
index dc0083212953..09cc65cb2a27 100644
--- a/app-emulation/spice/spice-0.5.3.ebuild
+++ b/app-emulation/spice/spice-0.7.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.5.3.ebuild,v 1.2 2010/11/18 12:52:29 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.7.3.ebuild,v 1.1 2011/02/17 10:28:44 dev-zero Exp $
-EAPI=3
+EAPI=4
DESCRIPTION="SPICE server and client."
HOMEPAGE="http://spice-space.org/"
@@ -11,9 +11,9 @@ SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="+gui opengl static-libs"
+IUSE="+gui static-libs"
-RDEPEND="~app-emulation/spice-protocol-${PV}
+RDEPEND=">=app-emulation/spice-protocol-0.7.1
>=x11-libs/pixman-0.17.7
media-libs/alsa-lib
media-libs/celt:0.5.1
@@ -22,23 +22,24 @@ RDEPEND="~app-emulation/spice-protocol-${PV}
x11-libs/libX11
x11-libs/libXext
x11-libs/libXrender
+ x11-libs/libXfixes
virtual/jpeg
sys-libs/zlib
- gui? ( dev-games/cegui[opengl?] )
- opengl? ( virtual/opengl )"
+ gui? ( =dev-games/cegui-0.6* )"
DEPEND="dev-util/pkgconfig
${RDEPEND}"
+# maintainer notes:
+# * opengl support is currently broken
+
src_configure() {
local myconf=""
use gui && myconf+="--enable-gui "
- use opengl && myconf+="--enable-opengl "
econf ${myconf} \
$(use_enable static-libs static)
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc NEWS TODO
+ default
use static-libs || rm "${D}"/usr/lib*/*.la
}