summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-10-04 17:08:03 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-10-04 17:08:03 +0000
commit38198b36caa19b48f14ddfed2e9092541ba511e6 (patch)
tree638818e60b083903b7130b57aab6b34f461e0c5b /app-emulation/spice-vdagent
parentNeed to depend on dev-games/cegui with USE=opengl. bug #432612 (diff)
downloadgentoo-2-38198b36caa19b48f14ddfed2e9092541ba511e6.tar.gz
gentoo-2-38198b36caa19b48f14ddfed2e9092541ba511e6.tar.bz2
gentoo-2-38198b36caa19b48f14ddfed2e9092541ba511e6.zip
Fix up to use console-kit correctly. bug #431890
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/spice-vdagent')
-rw-r--r--app-emulation/spice-vdagent/ChangeLog5
-rw-r--r--app-emulation/spice-vdagent/spice-vdagent-0.10.1.ebuild8
2 files changed, 10 insertions, 3 deletions
diff --git a/app-emulation/spice-vdagent/ChangeLog b/app-emulation/spice-vdagent/ChangeLog
index 6042c2409302..d2b01300d5c3 100644
--- a/app-emulation/spice-vdagent/ChangeLog
+++ b/app-emulation/spice-vdagent/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/spice-vdagent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/ChangeLog,v 1.8 2012/08/21 21:25:52 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/ChangeLog,v 1.9 2012/10/04 17:08:03 cardoe Exp $
+
+ 04 Oct 2012; Doug Goldstein <cardoe@gentoo.org> spice-vdagent-0.10.1.ebuild:
+ Fix up to use console-kit correctly. bug #431890
21 Aug 2012; Doug Goldstein <cardoe@gentoo.org> spice-vdagent-0.10.1.ebuild:
Add missing depends. bug #431964
diff --git a/app-emulation/spice-vdagent/spice-vdagent-0.10.1.ebuild b/app-emulation/spice-vdagent/spice-vdagent-0.10.1.ebuild
index 1fb89c5f8a14..8afe4ce0aadd 100644
--- a/app-emulation/spice-vdagent/spice-vdagent-0.10.1.ebuild
+++ b/app-emulation/spice-vdagent/spice-vdagent-0.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/spice-vdagent-0.10.1.ebuild,v 1.3 2012/08/21 21:25:52 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-vdagent/spice-vdagent-0.10.1.ebuild,v 1.4 2012/10/04 17:08:03 cardoe Exp $
EAPI=4
@@ -30,9 +30,13 @@ ERROR_INPUT_UINPUT="User level input support is required"
ERROR_VIRTIO_CONSOLE="VirtIO console/serial device support is required"
src_configure() {
+ local opt=
+
+ use consolekit && opt="${opt} --with-session-info=console-kit"
+
econf \
--localstatedir=/var \
- $(use_enable consolekit console-kit)
+ ${opt}
}
src_install() {