summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2005-04-19 21:00:08 +0000
committerRyan Phillips <rphillips@gentoo.org>2005-04-19 21:00:08 +0000
commitf679664a28909f2521da076a3add50af840c93b1 (patch)
treef8c2ce5485bc91876e4a13363113189915f3f905 /app-emulation/spectemu
parentClearing out most vulnerable versions... waiting on hppa still for 1.100. (diff)
downloadgentoo-2-f679664a28909f2521da076a3add50af840c93b1.tar.gz
gentoo-2-f679664a28909f2521da076a3add50af840c93b1.tar.bz2
gentoo-2-f679664a28909f2521da076a3add50af840c93b1.zip
version bump and ebuild cleanup
Diffstat (limited to 'app-emulation/spectemu')
-rw-r--r--app-emulation/spectemu/ChangeLog7
-rw-r--r--app-emulation/spectemu/Manifest4
-rw-r--r--app-emulation/spectemu/files/digest-spectemu-0.99.31
-rw-r--r--app-emulation/spectemu/spectemu-0.99.3.ebuild35
4 files changed, 45 insertions, 2 deletions
diff --git a/app-emulation/spectemu/ChangeLog b/app-emulation/spectemu/ChangeLog
index d7ed300247d7..ae5941b14a5f 100644
--- a/app-emulation/spectemu/ChangeLog
+++ b/app-emulation/spectemu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/spectemu
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spectemu/ChangeLog,v 1.9 2005/01/01 14:17:00 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spectemu/ChangeLog,v 1.10 2005/04/19 21:00:08 rphillips Exp $
+
+*spectemu-0.99.3 (19 Apr 2005)
+
+ 19 Apr 2005; <rphillips@gentoo.org> +spectemu-0.99.3.ebuild:
+ Version bump and ebuild cleanups
30 Mar 2004; Donnie Berkholz <spyderous@gentoo.org>; spectemu-0.9.4.ebuild:
Change x11-base/xfree dependency to virtual/x11.
diff --git a/app-emulation/spectemu/Manifest b/app-emulation/spectemu/Manifest
index befefa4d3ab9..e6c9c10c2a62 100644
--- a/app-emulation/spectemu/Manifest
+++ b/app-emulation/spectemu/Manifest
@@ -1,3 +1,5 @@
-MD5 e2c235d85e1c9c1471725744fa387727 ChangeLog 1048
+MD5 ad2fbeabe613195af621de65a3f2a2b7 spectemu-0.99.3.ebuild 1735
MD5 7c31048b431a63a72f1c9350af5b78d4 spectemu-0.9.4.ebuild 1767
+MD5 e2c235d85e1c9c1471725744fa387727 ChangeLog 1048
MD5 3eff986352c598213569695176c1dadb files/digest-spectemu-0.9.4 65
+MD5 2fa8d7d58dd97f11057af7dc17b910a1 files/digest-spectemu-0.99.3 67
diff --git a/app-emulation/spectemu/files/digest-spectemu-0.99.3 b/app-emulation/spectemu/files/digest-spectemu-0.99.3
new file mode 100644
index 000000000000..f236e6c2e193
--- /dev/null
+++ b/app-emulation/spectemu/files/digest-spectemu-0.99.3
@@ -0,0 +1 @@
+MD5 67330d27e3f5c9127413bd6f35aa664b spectemu-0.99.3.tar.gz 269524
diff --git a/app-emulation/spectemu/spectemu-0.99.3.ebuild b/app-emulation/spectemu/spectemu-0.99.3.ebuild
new file mode 100644
index 000000000000..943fa6321a92
--- /dev/null
+++ b/app-emulation/spectemu/spectemu-0.99.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spectemu/spectemu-0.99.3.ebuild,v 1.1 2005/04/19 21:00:08 rphillips Exp $
+
+### Several versions of specemu exist, xspect & vgaspect, utilising X11
+### and/or svgalib. libreadline provides optional runtime features.
+### The ./configure script automagically figures out which binaries to build
+### so the run/compiletime dependancies here are use dependant
+
+DESCRIPTION="48k ZX Spectrum Emulator"
+HOMEPAGE="http://kempelen.iit.bme.hu/~mszeredi/spectemu/spectemu.html"
+SRC_URI="http://www.inf.bme.hu/~mszeredi/spectemu/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="X readline svga"
+
+DEPEND="X? ( virtual/x11 )
+ readline? ( sys-libs/readline )"
+RDEPEND="svga? ( media-libs/svgalib )"
+
+src_compile() {
+ local myflags
+ use X || myflags="${myflags} --with-x=no"
+ use readline || myflags="${myflags} --without-readline"
+
+ econf ${myflags} || die "Spectemu ./configure failed"
+ emake || die "Spectemu make failed"
+}
+
+src_install() {
+ einstall
+}
+