summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-18 00:18:15 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-18 00:18:15 +0000
commited08aa6e044a1263e5290e2433964359edb1a645 (patch)
treefd666d0c54c707de2e29a3e207c3cec46f8c2a3e /app-emulation/softgun
parentAdd support for USE=zlib #79179 by Stefan Riemer. (diff)
downloadgentoo-2-ed08aa6e044a1263e5290e2433964359edb1a645.tar.gz
gentoo-2-ed08aa6e044a1263e5290e2433964359edb1a645.tar.bz2
gentoo-2-ed08aa6e044a1263e5290e2433964359edb1a645.zip
Version bump by Yuri Vasilevski.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-emulation/softgun')
-rw-r--r--app-emulation/softgun/ChangeLog7
-rw-r--r--app-emulation/softgun/files/digest-softgun-0.111
-rw-r--r--app-emulation/softgun/softgun-0.11.ebuild37
3 files changed, 44 insertions, 1 deletions
diff --git a/app-emulation/softgun/ChangeLog b/app-emulation/softgun/ChangeLog
index 4f15e41780b5..1b00ef9c2ef1 100644
--- a/app-emulation/softgun/ChangeLog
+++ b/app-emulation/softgun/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/softgun
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/ChangeLog,v 1.5 2005/05/04 18:48:17 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/ChangeLog,v 1.6 2005/08/18 00:18:15 vapier Exp $
+
+*softgun-0.11 (18 Aug 2005)
+
+ 18 Aug 2005; Mike Frysinger <vapier@gentoo.org> +softgun-0.11.ebuild:
+ Version bump by Yuri Vasilevski.
04 May 2005; David Holm <dholm@gentoo.org> softgun-0.09.ebuild:
Added to ~ppc.
diff --git a/app-emulation/softgun/files/digest-softgun-0.11 b/app-emulation/softgun/files/digest-softgun-0.11
new file mode 100644
index 000000000000..9d09794c3e3f
--- /dev/null
+++ b/app-emulation/softgun/files/digest-softgun-0.11
@@ -0,0 +1 @@
+MD5 3b6d62063a394658b28efe507ab8ce61 softgun-0.11.tgz 206893
diff --git a/app-emulation/softgun/softgun-0.11.ebuild b/app-emulation/softgun/softgun-0.11.ebuild
new file mode 100644
index 000000000000..1aeca261b941
--- /dev/null
+++ b/app-emulation/softgun/softgun-0.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/softgun-0.11.ebuild,v 1.1 2005/08/18 00:18:15 vapier Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="ARM software emulator"
+HOMEPAGE="http://softgun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^CFLAGS/s:-O9.*-fomit-frame-pointer:${CFLAGS}:" \
+ config.mk || die "sed config.mk failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "Make feiled"
+}
+
+src_install() {
+ dodir /usr/bin
+ make install prefix="${D}/usr" || die "Install failed"
+ dodoc README configs/defaultconfig
+}
+
+pkg_postinst() {
+ einfo "To create a configuration file, run as user:"
+ einfo " gzcat /usr/share/doc/${PF}/defaultconfig.gz > ~/.emuconfig"
+}