summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-04 16:18:53 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-04 16:18:53 +0000
commit45a2b8ce0d5bdb227cd36216728af99e15598ae7 (patch)
tree70d18326e96cf35c84277201c0880e1e5851e42d /app-emulation/softgun
parentVersion bump (diff)
downloadgentoo-2-45a2b8ce0d5bdb227cd36216728af99e15598ae7.tar.gz
gentoo-2-45a2b8ce0d5bdb227cd36216728af99e15598ae7.tar.bz2
gentoo-2-45a2b8ce0d5bdb227cd36216728af99e15598ae7.zip
Version bump.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-emulation/softgun')
-rw-r--r--app-emulation/softgun/ChangeLog7
-rw-r--r--app-emulation/softgun/files/digest-softgun-0.081
-rw-r--r--app-emulation/softgun/softgun-0.08.ebuild40
3 files changed, 47 insertions, 1 deletions
diff --git a/app-emulation/softgun/ChangeLog b/app-emulation/softgun/ChangeLog
index b3cfccb009ed..122cae9b919a 100644
--- a/app-emulation/softgun/ChangeLog
+++ b/app-emulation/softgun/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/softgun
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/ChangeLog,v 1.2 2005/01/01 14:16:41 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/ChangeLog,v 1.3 2005/03/04 16:18:53 vapier Exp $
+
+*softgun-0.08 (04 Mar 2005)
+
+ 04 Mar 2005; Mike Frysinger <vapier@gentoo.org> +softgun-0.08.ebuild:
+ Version bump.
*softgun-0.07 (05 Dec 2004)
diff --git a/app-emulation/softgun/files/digest-softgun-0.08 b/app-emulation/softgun/files/digest-softgun-0.08
new file mode 100644
index 000000000000..05ec5c373622
--- /dev/null
+++ b/app-emulation/softgun/files/digest-softgun-0.08
@@ -0,0 +1 @@
+MD5 ef9f04587ea3a81ceabd2867be6bbdd7 softgun-0.08.tgz 153086
diff --git a/app-emulation/softgun/softgun-0.08.ebuild b/app-emulation/softgun/softgun-0.08.ebuild
new file mode 100644
index 000000000000..f36ff2c00370
--- /dev/null
+++ b/app-emulation/softgun/softgun-0.08.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/softgun-0.08.ebuild,v 1.1 2005/03/04 16:18:53 vapier Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="ARM software emulator"
+HOMEPAGE="http://softgun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e 's:/usr/local:$(DESTDIR)/usr:' \
+ Makefile || die "sed Makefile failed"
+ sed -i \
+ -e "/^CFLAGS/s:-O9.*-fomit-frame-pointer:${CFLAGS}:" \
+ config.mk || die "sed config.mk failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "Make feiled"
+}
+
+src_install() {
+ dodir /usr/bin
+ make install DESTDIR="${D}" || die "Install failed"
+ dodoc README defaultconfig
+}
+
+pkg_postinst() {
+ einfo "To create a configuration file, run as user:"
+ einfo " gzcat /usr/share/doc/${PF}/defaultconfig.gz > ~/.emuconfig"
+}