summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2010-11-12 17:15:27 +0000
committerMarkus Meier <maekke@gentoo.org>2010-11-12 17:15:27 +0000
commit328522208f3e8b170c6ae59164ea8c4a2baacb7b (patch)
tree4dad1ec056697ec2b369db08ecef8c0aa9d0c84a /app-emulation/softgun/softgun-0.19.ebuild
parentVersion bump. Cleanup (diff)
downloadgentoo-2-328522208f3e8b170c6ae59164ea8c4a2baacb7b.tar.gz
gentoo-2-328522208f3e8b170c6ae59164ea8c4a2baacb7b.tar.bz2
gentoo-2-328522208f3e8b170c6ae59164ea8c4a2baacb7b.zip
version bump, bug #296238
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'app-emulation/softgun/softgun-0.19.ebuild')
-rw-r--r--app-emulation/softgun/softgun-0.19.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/softgun/softgun-0.19.ebuild b/app-emulation/softgun/softgun-0.19.ebuild
new file mode 100644
index 000000000000..ac191d1a5c18
--- /dev/null
+++ b/app-emulation/softgun/softgun-0.19.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/softgun-0.19.ebuild,v 1.1 2010/11/12 17:15:27 maekke Exp $
+
+EAPI=2
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="ARM software emulator"
+HOMEPAGE="http://softgun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make.patch
+ sed -i \
+ -e "/^CFLAGS/s:-O9.*-Werror:${CFLAGS}:" \
+ config.mk || die "sed config.mk failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dodir /usr/bin
+ emake install prefix="${D}/usr" || die
+ dodoc README configs/*.sg
+}