summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-08-15 08:33:57 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-08-15 08:33:57 +0000
commit3f581a65a61feef1c05583a16bbea0c13b35630a (patch)
tree8f96b31d528e1d5107653661480d529743a9099a /app-emulation/qemu-user
parentMarked ~x64-solaris (diff)
downloadgentoo-2-3f581a65a61feef1c05583a16bbea0c13b35630a.tar.gz
gentoo-2-3f581a65a61feef1c05583a16bbea0c13b35630a.tar.bz2
gentoo-2-3f581a65a61feef1c05583a16bbea0c13b35630a.zip
Bump EAPI to 5, drop unneeded base eclass, add mips64 target
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-emulation/qemu-user')
-rw-r--r--app-emulation/qemu-user/ChangeLog5
-rw-r--r--app-emulation/qemu-user/qemu-user-9999.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/app-emulation/qemu-user/ChangeLog b/app-emulation/qemu-user/ChangeLog
index 7c317b724457..bab7f0d8ea1a 100644
--- a/app-emulation/qemu-user/ChangeLog
+++ b/app-emulation/qemu-user/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/qemu-user
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.57 2013/08/12 14:45:44 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.58 2013/08/15 08:33:57 pinkbyte Exp $
+
+ 15 Aug 2013; Sergey Popov <pinkbyte@gentoo.org> qemu-user-9999.ebuild:
+ Bump EAPI to 5, drop unneeded base eclass, add mips64 target
12 Aug 2013; Sergey Popov <pinkbyte@gentoo.org> qemu-user-0.12.2.ebuild,
qemu-user-1.0.ebuild, qemu-user-1.1.0.ebuild, qemu-user-1.1.0-r1.ebuild,
diff --git a/app-emulation/qemu-user/qemu-user-9999.ebuild b/app-emulation/qemu-user/qemu-user-9999.ebuild
index b2084c4e2604..a2049bdebc9c 100644
--- a/app-emulation/qemu-user/qemu-user-9999.ebuild
+++ b/app-emulation/qemu-user/qemu-user-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-9999.ebuild,v 1.8 2013/08/12 14:45:44 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-9999.ebuild,v 1.9 2013/08/15 08:33:57 pinkbyte Exp $
-EAPI=4
+EAPI=5
if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="git://git.qemu.org/qemu.git
@@ -10,7 +10,7 @@ if [[ ${PV} == *9999 ]]; then
GIT_ECLASS="git-2"
fi
-inherit eutils base flag-o-matic pax-utils toolchain-funcs ${GIT_ECLASS}
+inherit eutils flag-o-matic pax-utils toolchain-funcs ${GIT_ECLASS}
MY_P=${P/-user/}
@@ -29,7 +29,7 @@ SLOT="0"
IUSE=""
RESTRICT="test"
-COMMON_TARGETS="i386 x86_64 alpha arm cris m68k microblaze microblazeel mips mipsel ppc ppc64 sh4 sh4eb sparc sparc64 s390x"
+COMMON_TARGETS="i386 x86_64 alpha arm cris m68k microblaze microblazeel mips mips64 mipsel ppc ppc64 sh4 sh4eb sparc sparc64 s390x"
IUSE_USER_TARGETS="${COMMON_TARGETS} armeb ppc64abi32 sparc32plus unicore32"
for target in ${IUSE_USER_TARGETS}; do
@@ -62,6 +62,7 @@ QA_WX_LOAD="
usr/bin/qemu-static-armeb-binfmt
usr/bin/qemu-static-microblaze-binfmt
usr/bin/qemu-static-mips-binfmt
+ usr/bin/qemu-static-mips64-binfmt
usr/bin/qemu-static-mipsel-binfmt
usr/bin/qemu-static-sh4-binfmt
usr/bin/qemu-static-s390x-binfmt