summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2009-03-12 16:02:48 +0000
committerLuca Barbato <lu_zero@gentoo.org>2009-03-12 16:02:48 +0000
commit914cd12476554cd45f798f7818fcce58418a33af (patch)
tree433833ff4aedbb859240fb234364c11b7c431371 /app-emulation/qemu-softmmu
parentAdd ~amd64-fbsd keyword. (diff)
downloadgentoo-2-914cd12476554cd45f798f7818fcce58418a33af.tar.gz
gentoo-2-914cd12476554cd45f798f7818fcce58418a33af.tar.bz2
gentoo-2-914cd12476554cd45f798f7818fcce58418a33af.zip
Simplify hardened support
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/qemu-softmmu')
-rw-r--r--app-emulation/qemu-softmmu/ChangeLog5
-rw-r--r--app-emulation/qemu-softmmu/qemu-softmmu-0.10.0.ebuild22
2 files changed, 6 insertions, 21 deletions
diff --git a/app-emulation/qemu-softmmu/ChangeLog b/app-emulation/qemu-softmmu/ChangeLog
index 648eaccec6e3..2e3fc120b932 100644
--- a/app-emulation/qemu-softmmu/ChangeLog
+++ b/app-emulation/qemu-softmmu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/qemu-softmmu
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.58 2009/03/12 11:48:40 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.59 2009/03/12 16:02:48 lu_zero Exp $
+
+ 12 Mar 2009; Luca Barbato <lu_zero@gentoo.org> qemu-softmmu-0.10.0.ebuild:
+ Simplify hardened support
12 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
qemu-softmmu-0.9.1.ebuild, qemu-softmmu-0.9.1-r1.ebuild,
diff --git a/app-emulation/qemu-softmmu/qemu-softmmu-0.10.0.ebuild b/app-emulation/qemu-softmmu/qemu-softmmu-0.10.0.ebuild
index 25b02ee709c1..3b891aec642d 100644
--- a/app-emulation/qemu-softmmu/qemu-softmmu-0.10.0.ebuild
+++ b/app-emulation/qemu-softmmu/qemu-softmmu-0.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.10.0.ebuild,v 1.4 2009/03/12 11:48:40 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.10.0.ebuild,v 1.5 2009/03/12 16:02:48 lu_zero Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -73,27 +73,9 @@ src_compile() {
use pulseaudio && audio_opts="pa $audio_opts"
use sdl && audio_opts="sdl $audio_opts"
- ./configure ${conf_opts} --audio-drv-list="$audio_opts" || die "econf failed"
-
- mycc=$(cat config-host.mak | egrep "^CC=" | cut -d "=" -f 2)
-
filter-flags -fpie -fstack-protector
- # If using gentoo's compiler set the SPEC to non-hardened
- if [ ! -z ${GCC_SPECS} -a -f ${GCC_SPECS} ]; then
- local myccver=$(${mycc} -dumpversion)
- local gccver=$($(tc-getBUILD_CC) -dumpversion)
-
- #Is this a SPEC for the right compiler version?
- myspec="${GCC_SPECS/${gccver}/${myccver}}"
- if [ "${myspec}" == "${GCC_SPECS}" ]; then
- shopt -s extglob
- GCC_SPECS="${GCC_SPECS/%hardened*specs/vanilla.specs}"
- shopt -u extglob
- else
- unset GCC_SPECS
- fi
- fi
+ ./configure ${conf_opts} --audio-drv-list="$audio_opts" || die "econf failed"
emake || die "emake qemu failed"