summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-16 17:33:44 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-16 17:33:44 +0000
commit157ee435e514d9c2f8ced105089ae2af316b26b0 (patch)
tree416d8dc9f75a7f0ef2921e9e27ece6779b127acf /app-emulation/point2play
parentModified to use new wxwidgets eclass. Fixes bug# 60529 (Manifest recommit) (diff)
downloadgentoo-2-157ee435e514d9c2f8ced105089ae2af316b26b0.tar.gz
gentoo-2-157ee435e514d9c2f8ced105089ae2af316b26b0.tar.bz2
gentoo-2-157ee435e514d9c2f8ced105089ae2af316b26b0.zip
allow people to verify their download
Diffstat (limited to 'app-emulation/point2play')
-rw-r--r--app-emulation/point2play/files/digest-point2play-1.3.12
-rw-r--r--app-emulation/point2play/files/remove-watermark.sh16
-rw-r--r--app-emulation/point2play/point2play-1.3.1.ebuild9
3 files changed, 22 insertions, 5 deletions
diff --git a/app-emulation/point2play/files/digest-point2play-1.3.1 b/app-emulation/point2play/files/digest-point2play-1.3.1
index d92489a1f037..4fa2b5056eb4 100644
--- a/app-emulation/point2play/files/digest-point2play-1.3.1
+++ b/app-emulation/point2play/files/digest-point2play-1.3.1
@@ -1 +1 @@
-MD5 010f033c1a80165959939e9d2f1dd5f5 point2play-small-1.3.1.tgz 822911
+MD5 9fb3c8dfc56eb947b9447c1562d8e111 point2play-small-1.3.1.tgz 822911
diff --git a/app-emulation/point2play/files/remove-watermark.sh b/app-emulation/point2play/files/remove-watermark.sh
new file mode 100644
index 000000000000..f3384adc473f
--- /dev/null
+++ b/app-emulation/point2play/files/remove-watermark.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+
+file="$1"
+if [ ! -e "${file}" ] ; then
+ echo "The file '${file}' doesn't seem to exist."
+ echo "Aborting!"
+ exit 1
+fi
+
+dd \
+ if=/dev/zero \
+ of="${file}" \
+ seek=16 \
+ count=20 \
+ bs=1 \
+ conv=notrunc
diff --git a/app-emulation/point2play/point2play-1.3.1.ebuild b/app-emulation/point2play/point2play-1.3.1.ebuild
index 50225de73b1e..3633ae719c77 100644
--- a/app-emulation/point2play/point2play-1.3.1.ebuild
+++ b/app-emulation/point2play/point2play-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.3.1.ebuild,v 1.5 2004/08/16 15:29:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.3.1.ebuild,v 1.6 2004/08/16 17:33:44 vapier Exp $
inherit eutils
@@ -31,9 +31,10 @@ pkg_nofetch() {
ewarn "Please note that for some stupid reason Transgaming has"
ewarn "started watermarking their downloads."
ewarn "http://transgaming.org/forum/viewtopic.php?t=660"
- ewarn "This means you will have to rebuild the digest file"
- ewarn "before emerging it. Just run this command:"
- ewarn "ebuild /usr/portage/app-emulation/${PN}/${PF}.ebuild digest"
+ ewarn
+ ewarn "To remove the simple watermark and verify the"
+ ewarn "authenticity of your download, just do this:"
+ ewarn "sh /usr/portage/app-emulation/${PN}/files/remove-watermark.sh ${DISTDIR}/${MY_P}.tgz"
}
src_unpack() {