summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-09-04 01:05:53 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-09-04 01:05:53 +0000
commit35e48ecc2e0ac598486fe73ebfd5787e45583f1b (patch)
tree8ab67c9f0170d6523bac2268a1768de84019d097 /app-emulation/plex86
parentwhitespace fixes (diff)
downloadgentoo-2-35e48ecc2e0ac598486fe73ebfd5787e45583f1b.tar.gz
gentoo-2-35e48ecc2e0ac598486fe73ebfd5787e45583f1b.tar.bz2
gentoo-2-35e48ecc2e0ac598486fe73ebfd5787e45583f1b.zip
whitespace cleanup
Diffstat (limited to 'app-emulation/plex86')
-rw-r--r--app-emulation/plex86/Manifest4
-rw-r--r--app-emulation/plex86/plex86-20021117.ebuild73
2 files changed, 38 insertions, 39 deletions
diff --git a/app-emulation/plex86/Manifest b/app-emulation/plex86/Manifest
index 80dac313bb18..0191e4969ffa 100644
--- a/app-emulation/plex86/Manifest
+++ b/app-emulation/plex86/Manifest
@@ -1,3 +1,3 @@
-MD5 f69edd2779b3ded0aca117efae08365e files/digest-plex86-20021117 68
-MD5 8cf6d1701e53fc95d6ff03a66332520b plex86-20021117.ebuild 2625
MD5 a99bb091146d05bd181822681661d42d ChangeLog 350
+MD5 59914c28b7b0f8f080f6f73794f216d8 plex86-20021117.ebuild 2509
+MD5 f69edd2779b3ded0aca117efae08365e files/digest-plex86-20021117 68
diff --git a/app-emulation/plex86/plex86-20021117.ebuild b/app-emulation/plex86/plex86-20021117.ebuild
index fb66aa900224..50f2e3b2498d 100644
--- a/app-emulation/plex86/plex86-20021117.ebuild
+++ b/app-emulation/plex86/plex86-20021117.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/plex86/plex86-20021117.ebuild,v 1.5 2003/06/29 20:06:54 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/plex86/plex86-20021117.ebuild,v 1.6 2003/09/04 01:03:27 msterret Exp $
DESCRIPTION="Plex86 is THE opensource free-software alternative for VMWare, VirtualPC, and other IA-32 on IA-32 \"Virtual PC products.\""
HOMEPAGE="http://savannah.gnu.org/projects/plex86/"
@@ -10,58 +10,57 @@ SLOT="0"
KEYWORDS="x86"
IUSE="X sdl"
RDEPEND=">=sys-libs/ncurses-5.2-r7
- X? ( >=x11-base/xfree-4.2.0 )
- sdl? ( >=media-libs/libsdl-1.2.4 )"
+ X? ( >=x11-base/xfree-4.2.0 )
+ sdl? ( >=media-libs/libsdl-1.2.4 )"
DEPEND="${RDEPEND}"
DEPEND=""
S="${WORKDIR}/${P}"
src_compile() {
- MY_CONF="--with-Linux --enable-cdrom --enable-split-hd --enable-pci --enable-vbe --enable-sb16=linux --enable-instrumentation"
- # --enable-ne2000 not working at the moment
+ MY_CONF="--with-Linux --enable-cdrom --enable-split-hd --enable-pci --enable-vbe --enable-sb16=linux --enable-instrumentation"
+ # --enable-ne2000 not working at the moment
- MY_GUI="curses"
- use X && MY_GUI="x"
- use sdl && MY_GUI="sdl"
- use sdl && export SDL_CFLAGS="`sdl-config --cflags`"
-
- use X && MY_CONF="${MY_CONF} --with-x --with-linux-source=/usr/src/linux"
- MY_CONF="${MY_CONF} --with-gui=${MY_GUI}"
+ MY_GUI="curses"
+ use X && MY_GUI="x"
+ use sdl && MY_GUI="sdl"
+ use sdl && export SDL_CFLAGS="`sdl-config --cflags`"
- # fix typo (bug submitted)
- mv user/plugins/bochs/iodev/eth_fbsd.cc user/plugins/bochs/iodev/eth_fbsd.cc_orig
- sed s/'inclide'/'include'/ user/plugins/bochs/iodev/eth_fbsd.cc_orig > user/plugins/bochs/iodev/eth_fbsd.cc
+ use X && MY_CONF="${MY_CONF} --with-x --with-linux-source=/usr/src/linux"
+ MY_CONF="${MY_CONF} --with-gui=${MY_GUI}"
- ./configure \
+ # fix typo (bug submitted)
+ mv user/plugins/bochs/iodev/eth_fbsd.cc user/plugins/bochs/iodev/eth_fbsd.cc_orig
+ sed s/'inclide'/'include'/ user/plugins/bochs/iodev/eth_fbsd.cc_orig > user/plugins/bochs/iodev/eth_fbsd.cc
+
+ ./configure \
--host=${CHOST} \
--prefix=/usr \
--infodir=/usr/share/info \
--mandir=/usr/share/man ${MY_CONF} || die "./configure failed"
-
- make || die
+
+ make || die
}
src_install() {
- #make DESTDIR=${D} install || die
- # for now just this:
- dodir /opt/${P}
- cp -r * ${D}/opt/${P}
+ #make DESTDIR=${D} install || die
+ # for now just this:
+ dodir /opt/${P}
+ cp -r * ${D}/opt/${P}
}
pkg_postinst() {
- echo
- einfo ",-----------------------------------------------------------------."
- einfo "| IMPORTANT NOTICE |"
- einfo "|-----------------------------------------------------------------|"
- einfo "| This code is EXTREMELY EXPERIMENTAL, and may well result in a |"
- einfo "| SYSTEM CRASH, and who knows what other ill effects. RUN THIS |"
- einfo "| SOFTWARE AT YOUR OWN RISK. As a precaution, do not attempt to |"
- einfo "| run this software on a system with important data on it, and |"
- einfo "| make liberal use of the sync command! Expect to have to use |"
- einfo "| the power button. |"
- einfo "\`-----------------------------------------------------------------'"
- echo
- einfo "Contact me (lordvan@lordvan.com) if you encounter any problems."
- echo
-
+ echo
+ einfo ",-----------------------------------------------------------------."
+ einfo "| IMPORTANT NOTICE |"
+ einfo "|-----------------------------------------------------------------|"
+ einfo "| This code is EXTREMELY EXPERIMENTAL, and may well result in a |"
+ einfo "| SYSTEM CRASH, and who knows what other ill effects. RUN THIS |"
+ einfo "| SOFTWARE AT YOUR OWN RISK. As a precaution, do not attempt to |"
+ einfo "| run this software on a system with important data on it, and |"
+ einfo "| make liberal use of the sync command! Expect to have to use |"
+ einfo "| the power button. |"
+ einfo "\`-----------------------------------------------------------------'"
+ echo
+ einfo "Contact me (lordvan@lordvan.com) if you encounter any problems."
+ echo
}