summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-10-31 10:39:33 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-10-31 10:39:33 +0000
commitf0902302592e047af25bbd7b6a3f6ffb0fbab1d1 (patch)
tree14372ef2ad6d954e6874d8d2b411e6ec6781a02a /app-emulation/playonlinux
parentMask kde-misc/systemloadviewer because it's moved into kde-base/kdeplasma-add... (diff)
downloadgentoo-2-f0902302592e047af25bbd7b6a3f6ffb0fbab1d1.tar.gz
gentoo-2-f0902302592e047af25bbd7b6a3f6ffb0fbab1d1.tar.bz2
gentoo-2-f0902302592e047af25bbd7b6a3f6ffb0fbab1d1.zip
Version bump to 3.7 and remove oldest version.
Fix bug 288935. (Portage version: 14270-svn/cvs/Linux i686)
Diffstat (limited to 'app-emulation/playonlinux')
-rw-r--r--app-emulation/playonlinux/ChangeLog8
-rw-r--r--app-emulation/playonlinux/playonlinux-3.7.ebuild (renamed from app-emulation/playonlinux/playonlinux-3.5.ebuild)22
2 files changed, 19 insertions, 11 deletions
diff --git a/app-emulation/playonlinux/ChangeLog b/app-emulation/playonlinux/ChangeLog
index 905686c16f35..5f3af151e64d 100644
--- a/app-emulation/playonlinux/ChangeLog
+++ b/app-emulation/playonlinux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/playonlinux
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/ChangeLog,v 1.4 2009/07/13 12:18:46 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/ChangeLog,v 1.5 2009/10/31 10:39:33 volkmar Exp $
+
+*playonlinux-3.7 (31 Oct 2009)
+
+ 31 Oct 2009; Mounir Lamouri <volkmar@gentoo.org> -playonlinux-3.5.ebuild,
+ +playonlinux-3.7.ebuild:
+ Version bump to 3.7 and remove oldest version. Fix bug 288935
*playonlinux-3.6 (13 Jul 2009)
diff --git a/app-emulation/playonlinux/playonlinux-3.5.ebuild b/app-emulation/playonlinux/playonlinux-3.7.ebuild
index 4b69317f3be4..5a53798fd8cb 100644
--- a/app-emulation/playonlinux/playonlinux-3.5.ebuild
+++ b/app-emulation/playonlinux/playonlinux-3.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/playonlinux-3.5.ebuild,v 1.3 2009/06/13 10:16:23 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/playonlinux-3.7.ebuild,v 1.1 2009/10/31 10:39:33 volkmar Exp $
-EAPI="1"
+EAPI="2"
inherit eutils python games
@@ -31,6 +31,14 @@ S=${WORKDIR}/${PN}
# Having a real install script and let playonlinux use standard filesystem
# architecture to prevent having everything installed into GAMES_DATADIR
# It will let using LANGUAGES easily
+# How to deal with Microsoft Fonts installation asked every time ?
+# How to deal with wine version installed ? (have a better mgmt of system one)
+
+src_prepare() {
+ einfo "Removing temporary files..."
+ rm -f $(find . -name *.pyc) || die "rm -f doesn't die"
+ rm -f $(find . -name *~) || die "rm -f doesn't die"
+}
src_install() {
# all things without exec permissions
@@ -44,14 +52,10 @@ src_install() {
doexe bash/terminals/* || die "doexe failed"
exeinto "${GAMES_DATADIR}/${PN}/bash/expert"
doexe bash/expert/* || die "doexe failed"
- exeinto "${GAMES_DATADIR}/${PN}/bash/options"
- doexe bash/options/* || die "doexe failed"
# python/ install
exeinto "${GAMES_DATADIR}/${PN}/python"
doexe python/* || die "doexe failed"
- exeinto "${GAMES_DATADIR}/${PN}/python/tools"
- doexe python/tools/* || die "doexe failed"
# sub dir without exec permissions
insinto "${GAMES_DATADIR}/${PN}/python"
doins -r python/lib || die "doins failed"
@@ -62,9 +66,7 @@ src_install() {
# main executable files
exeinto "${GAMES_DATADIR}/${PN}"
- doexe ${PN} || die "doexe failed"
- doexe ${PN}-pkg || die "doexe failed"
- doexe ${PN}-daemon || die "doexe failed"
+ doexe ${PN}{,-pkg,-daemon} || die "doexe failed"
# making a script to run app from ${GAMES_BINDIR}
echo "#!/bin/bash" > ${PN}_launcher
@@ -74,7 +76,7 @@ src_install() {
dodoc CHANGELOG || die "dodoc failed"
doicon etc/${PN}.png || die "doicon failed"
- make_desktop_entry ${PN} ${MY_PN} || die "make_desktop_entry failed"
+ domenu etc/${MY_PN}.desktop || die "domenu failed"
prepgamesdirs
}