summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-10-10 20:15:35 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-10-10 20:15:35 +0000
commit2f88fdeb529babdfe3b78232eb258c162c22c9eb (patch)
tree9fb2982663135424796b1e9d81d3547304c61e82 /app-emulation/phpvirtualbox
parentVersion bump, bug 437828 - CVE CVE-2012-5166 (diff)
downloadgentoo-2-2f88fdeb529babdfe3b78232eb258c162c22c9eb.tar.gz
gentoo-2-2f88fdeb529babdfe3b78232eb258c162c22c9eb.tar.bz2
gentoo-2-2f88fdeb529babdfe3b78232eb258c162c22c9eb.zip
Version bump. Remove old
(Portage version: 2.1.11.24/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/phpvirtualbox')
-rw-r--r--app-emulation/phpvirtualbox/ChangeLog10
-rw-r--r--app-emulation/phpvirtualbox/phpvirtualbox-4.1.11.ebuild67
-rw-r--r--app-emulation/phpvirtualbox/phpvirtualbox-4.2.1.ebuild (renamed from app-emulation/phpvirtualbox/phpvirtualbox-4.1.7.ebuild)19
3 files changed, 94 insertions, 2 deletions
diff --git a/app-emulation/phpvirtualbox/ChangeLog b/app-emulation/phpvirtualbox/ChangeLog
index fb37a3c08766..fd140487c64c 100644
--- a/app-emulation/phpvirtualbox/ChangeLog
+++ b/app-emulation/phpvirtualbox/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/phpvirtualbox
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/ChangeLog,v 1.5 2012/08/18 10:53:51 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/ChangeLog,v 1.6 2012/10/10 20:15:35 hwoarang Exp $
+
+*phpvirtualbox-4.1.11 (10 Oct 2012)
+*phpvirtualbox-4.2.1 (10 Oct 2012)
+
+ 10 Oct 2012; Markos Chandras <hwoarang@gentoo.org>
+ +phpvirtualbox-4.1.11.ebuild, +phpvirtualbox-4.2.1.ebuild,
+ -phpvirtualbox-4.1.7.ebuild:
+ Version bump. Remove old
18 Aug 2012; Markos Chandras <hwoarang@gentoo.org>
phpvirtualbox-4.1.7-r2.ebuild:
diff --git a/app-emulation/phpvirtualbox/phpvirtualbox-4.1.11.ebuild b/app-emulation/phpvirtualbox/phpvirtualbox-4.1.11.ebuild
new file mode 100644
index 000000000000..c6cfa099f20b
--- /dev/null
+++ b/app-emulation/phpvirtualbox/phpvirtualbox-4.1.11.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/phpvirtualbox-4.1.11.ebuild,v 1.1 2012/10/10 20:15:35 hwoarang Exp $
+
+EAPI="2"
+
+inherit versionator eutils webapp depend.php
+
+MY_PV="$(replace_version_separator 2 '-')"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Web-based administration for VirtualBox in PHP"
+HOMEPAGE="http://phpvirtualbox.googlecode.com"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/php[session,unicode,soap,gd]
+"
+DEPEND="app-arch/unzip"
+
+need_php_httpd
+
+src_install() {
+ webapp_src_preinst
+
+ cd ${MY_P}
+
+ dodoc CHANGELOG.txt LICENSE.txt README.txt || die
+ rm -f CHANGELOG.txt LICENSE.txt README.txt
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php-example
+ webapp_serverowned "${MY_HTDOCSDIR}"/config.php-example
+
+ webapp_src_install
+ if has_version app-emulation/virtualbox[vboxwebsrv] || \
+ has_version app-emulation/virtualbox-bin[vboxwebsrv]
+ then
+ newinitd "${FILESDIR}"/vboxinit-initd vboxinit
+ fi
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ elog "Local or remote virtualbox hosts must be compiled with"
+ elog "'vboxwebsrv' useflag and the respective init script"
+ elog "must be running to use this interface"
+ elog " /etc/init.d/vboxwebsrv start"
+ elog
+ elog "To enable the automatic startup mode feature uncomment the"
+ elog "following line in the config.php file:"
+ elog " var \$startStopConfig = true;"
+ elog
+ elog "You should also add the /etc/init.d/vboxinit script to the"
+ elog "default runlevel on the virtualbox host:"
+ elog "\`rc-update add vboxinit default\`"
+ elog "If the server is on a remote host, than the script must be"
+ elog "copied manually from"
+ elog "${FILESDIR}/vboxinit-initd to /etc/init.d/vboxinit"
+ elog "on the remote host."
+}
diff --git a/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7.ebuild b/app-emulation/phpvirtualbox/phpvirtualbox-4.2.1.ebuild
index 72de25e5220d..984c8c74abf8 100644
--- a/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7.ebuild
+++ b/app-emulation/phpvirtualbox/phpvirtualbox-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7.ebuild,v 1.1 2012/03/16 22:44:27 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/phpvirtualbox-4.2.1.ebuild,v 1.1 2012/10/10 20:15:35 hwoarang Exp $
EAPI="2"
@@ -39,6 +39,11 @@ src_install() {
webapp_serverowned "${MY_HTDOCSDIR}"/config.php-example
webapp_src_install
+ if has_version app-emulation/virtualbox[vboxwebsrv] || \
+ has_version app-emulation/virtualbox-bin[vboxwebsrv]
+ then
+ newinitd "${FILESDIR}"/vboxinit-initd vboxinit
+ fi
}
pkg_postinst() {
@@ -47,4 +52,16 @@ pkg_postinst() {
elog "'vboxwebsrv' useflag and the respective init script"
elog "must be running to use this interface"
elog " /etc/init.d/vboxwebsrv start"
+ elog
+ elog "To enable the automatic startup mode feature uncomment the"
+ elog "following line in the config.php file:"
+ elog " var \$startStopConfig = true;"
+ elog
+ elog "You should also add the /etc/init.d/vboxinit script to the"
+ elog "default runlevel on the virtualbox host:"
+ elog "\`rc-update add vboxinit default\`"
+ elog "If the server is on a remote host, than the script must be"
+ elog "copied manually from"
+ elog "${FILESDIR}/vboxinit-initd to /etc/init.d/vboxinit"
+ elog "on the remote host."
}