summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-07-12 00:27:34 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-07-12 00:27:34 +0000
commit17c2a042f4fd35d97250ab2f75555a680f59966f (patch)
tree75e55d603c027f62235ba2cca1fac4ed3373f562 /app-emulation/pearpc
parentUpdate to the new GTK2 version. This has been a long time coming. Thanks a ... (diff)
downloadgentoo-2-17c2a042f4fd35d97250ab2f75555a680f59966f.tar.gz
gentoo-2-17c2a042f4fd35d97250ab2f75555a680f59966f.tar.bz2
gentoo-2-17c2a042f4fd35d97250ab2f75555a680f59966f.zip
ebuild updates thanks to cedk
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'app-emulation/pearpc')
-rw-r--r--app-emulation/pearpc/ChangeLog6
-rw-r--r--app-emulation/pearpc/files/pearpc-0.4-configure.patch50
-rw-r--r--app-emulation/pearpc/pearpc-0.4.ebuild104
3 files changed, 96 insertions, 64 deletions
diff --git a/app-emulation/pearpc/ChangeLog b/app-emulation/pearpc/ChangeLog
index ac59c4c59caf..6459d6ff96aa 100644
--- a/app-emulation/pearpc/ChangeLog
+++ b/app-emulation/pearpc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/pearpc
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/pearpc/ChangeLog,v 1.11 2006/03/18 23:53:56 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pearpc/ChangeLog,v 1.12 2006/07/12 00:27:34 genstef Exp $
+
+ 12 Jul 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/pearpc-0.4-configure.patch, pearpc-0.4.ebuild:
+ ebuild updates thanks to cedk
18 Mar 2006; Joshua Baergen <joshuabaergen@gentoo.org>
pearpc-0.3.1.ebuild, pearpc-0.4.ebuild:
diff --git a/app-emulation/pearpc/files/pearpc-0.4-configure.patch b/app-emulation/pearpc/files/pearpc-0.4-configure.patch
new file mode 100644
index 000000000000..2ca4b4ea5d5e
--- /dev/null
+++ b/app-emulation/pearpc/files/pearpc-0.4-configure.patch
@@ -0,0 +1,50 @@
+--- pearpc-0.4~/configure 2006-07-11 13:34:45.000000000 +0200
++++ pearpc-0.4/configure 2006-07-11 13:44:02.000000000 +0200
+@@ -1492,11 +1492,11 @@
+ PPC_LDFLAGS="$LDFLAGS"
+
+ if test "x$enable_release" = "xyes"; then
+- PPC_CFLAGS="$CFLAGS $PPC_CFLAGS -O2"
+- PPC_CXXFLAGS="$CXXFLAGS $PPC_CXXFLAGS -O2"
++ PPC_CFLAGS="$CFLAGS $PPC_CFLAGS"
++ PPC_CXXFLAGS="$CXXFLAGS $PPC_CXXFLAGS"
+ else
+- PPC_CFLAGS="$PPC_CFLAGS -O0"
+- PPC_CXXFLAGS="$PPC_CXXFLAGS -O0"
++ PPC_CFLAGS="$CFLAGS $PPC_CFLAGS"
++ PPC_CXXFLAGS="$CXXFLAGS $PPC_CXXFLAGS"
+ fi
+
+ if test "x$enable_fpo" = "xyes"; then
+@@ -2903,13 +2903,13 @@
+ CFLAGS=$ac_save_CFLAGS
+ elif test $ac_cv_prog_cc_g = yes; then
+ if test "$GCC" = yes; then
+- CFLAGS="-g -O2"
++ CFLAGS="-g"
+ else
+ CFLAGS="-g"
+ fi
+ else
+ if test "$GCC" = yes; then
+- CFLAGS="-O2"
++ CFLAGS=""
+ else
+ CFLAGS=
+ fi
+@@ -3584,13 +3584,13 @@
+ CXXFLAGS=$ac_save_CXXFLAGS
+ elif test $ac_cv_prog_cxx_g = yes; then
+ if test "$GXX" = yes; then
+- CXXFLAGS="-g -O2"
++ CXXFLAGS="-g"
+ else
+ CXXFLAGS="-g"
+ fi
+ else
+ if test "$GXX" = yes; then
+- CXXFLAGS="-O2"
++ CXXFLAGS=""
+ else
+ CXXFLAGS=
+ fi
diff --git a/app-emulation/pearpc/pearpc-0.4.ebuild b/app-emulation/pearpc/pearpc-0.4.ebuild
index 9e6fb3874efe..424393807206 100644
--- a/app-emulation/pearpc/pearpc-0.4.ebuild
+++ b/app-emulation/pearpc/pearpc-0.4.ebuild
@@ -1,11 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/pearpc/pearpc-0.4.ebuild,v 1.3 2006/03/18 23:53:56 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pearpc/pearpc-0.4.ebuild,v 1.4 2006/07/12 00:27:34 genstef Exp $
-inherit flag-o-matic
-
-IUSE="debug jit sdl"
-#IUSE="debug qt gtk jit sdl"
+inherit eutils flag-o-matic linux-info
DESCRIPTION="PowerPC Architecture Emulator"
HOMEPAGE="http://pearpc.sourceforge.net/"
@@ -14,94 +11,75 @@ SRC_URI="mirror://sourceforge/pearpc/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
-
-DEPEND="x86? ( dev-lang/nasm )
- || ( x11-libs/libXt virtual/x11 )"
-
-RDEPEND="media-libs/libmng
- media-libs/jpeg
- media-libs/libpng
- sys-libs/zlib
- media-libs/freetype
- sdl? ( media-libs/libsdl )"
-# gtk? ( >=x11-libs/gtk-2.0 )
-# qt? ( >=x11-libs/qt-3.1.1 )"
-
-DEFAULT_TO_X11=0
+KEYWORDS="~x86"
+IUSE="debug jit X sdl"
+
+DEPEND="virtual/libc
+ sys-devel/flex
+ sys-devel/bison
+ x86? ( dev-lang/nasm )
+ jit? ( dev-lang/nasm )
+ X? ( || ( x11-libs/libX11 virtual/x11 ) )
+ sdl? ( >=media-libs/libsdl-1.2.0 )"
+RDEPEND="${DEPEND}
+ sys-apps/net-tools
+ net-firewall/iptables
+ net-misc/bridge-utils"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-configure.patch"
+}
pkg_setup() {
-
- append-ldflags $(bindnow-flags)
-
-# if (use qt && use sdl) || (use qt && use gtk) || (use gtk && sdl) || (use gtk && use qt && use sdl); then
-# ewarn
-# ewarn "More than one frontend USE flags enabled, defaulting to X11 support."
-# ewarn
-# DEFAULT_TO_X11=1
-# fi
+ linux_chkconfig_present TUN && die "You must have TUN/TAP enabled in your kernel."
}
src_compile() {
local myconf
- myconf="--enable-release"
use jit && myconf="${myconf} --enable-cpu=jitc_x86"
-
- if use debug; then
- myconf="${myconf} --enable-debug"
- else
- myconf="${myconf} --disable-debug"
- fi
-
- if [ $DEFAULT_TO_X11 = 1 ]; then
+ if use sdl; then
+ myconf="${myconf} --enable-ui=sdl"
+ elif use X; then
myconf="${myconf} --enable-ui=x11"
else
- if use sdl; then
- myconf="${myconf} --enable-ui=sdl"
-# elif use qt; then
-# myconf="${myconf} --enable-ui=qt"
-# elif use gtk; then
-# myconf="${myconf} --enable-ui=gtk"
- else
- myconf="${myconf} --enable-ui=x11"
- fi
+ die "You must set at least one of this flags X, sdl"
fi
- econf ${myconf} || die "econf failed"
+ append-ldflags $(bindnow-flags)
+
+ econf \
+ $(use_enable debug) \
+ ${myconf} \
+ || die "econf failed"
emake || die "emake failed"
+ sed -i -e "s:video.x:/usr/share/${P}/video.x:g" ppccfg.example
}
src_install() {
dobin src/ppc
- dodoc ChangeLog AUTHORS COPYING README TODO
+ dodoc ChangeLog AUTHORS README TODO ppccfg.example
- dodir /usr/share/${P}
insinto /usr/share/${P}
- doins scripts/ifppc_down scripts/ifppc_up scripts/ifppc_up.setuid scripts/ifppc_down.setuid
- doins video.x
- fperms u+s /usr/share/${P}/ifppc_up.setuid /usr/share/${P}/ifppc_down.setuid
-
- insinto /usr/share/doc/${P}
- sed -i -e "s:video.x:/usr/share/${P}/video.x:g" ppccfg.example
- doins ppccfg.example
+ doins scripts/ifppc_{down,up}{,.setuid} video.x "${FILESDIR}"/settings
+ fperms u+s,a+x /usr/share/${P}/ifppc_{up,down}.setuid
- dodir /usr/share/${P}/scripts
insinto /usr/share/${P}/scripts
doins "${DISTDIR}"/createdisk.py
}
pkg_postinst() {
- echo
einfo "You will need to update your configuration files to point"
einfo "to the new location of video.x, which is now"
einfo "/usr/share/${P}/video.x"
- echo
+ einfo ""
einfo "To create disk images for PearPC, you can use the Python"
einfo "script located at: /usr/share/${P}/scripts/createdisk.py"
einfo "Usage: createdisk.py <image name> <image size>"
- echo
- einfo "Also, be sure to check /usr/share/doc/${P}/ppccfg.example"
+ einfo ""
+ einfo "Also, be sure to check /usr/share/doc/${P}/ppccfg.example.gz"
einfo "for new configuration options."
- echo
}