summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2003-03-11 19:26:41 +0000
committerMark Guertin <gerk@gentoo.org>2003-03-11 19:26:41 +0000
commit8f60eeaa1d004c4d0c7c5378ee3466c7501a7c1d (patch)
treed32ed35b473da123f5889aa5e715979017243ab2 /app-emulation/mol
parentadd ~alpha (diff)
downloadgentoo-2-8f60eeaa1d004c4d0c7c5378ee3466c7501a7c1d.tar.gz
gentoo-2-8f60eeaa1d004c4d0c7c5378ee3466c7501a7c1d.tar.bz2
gentoo-2-8f60eeaa1d004c4d0c7c5378ee3466c7501a7c1d.zip
new version for DHCP fixups
Diffstat (limited to 'app-emulation/mol')
-rw-r--r--app-emulation/mol/ChangeLog8
-rw-r--r--app-emulation/mol/files/digest-mol-0.9.68-r31
-rw-r--r--app-emulation/mol/mol-0.9.68-r3.ebuild67
3 files changed, 75 insertions, 1 deletions
diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
index d9e7ccd27538..4d6c18531189 100644
--- a/app-emulation/mol/ChangeLog
+++ b/app-emulation/mol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/mol
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.14 2003/03/02 01:19:15 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.15 2003/03/11 19:26:41 gerk Exp $
+
+*mol-0.9.68-r3 (11 Mar 2003)
+
+ 11 Mar 2003; Mark Guertin <gerk@gentoo.org> mol-0.9.68-r3.ebuild:
+ revision bump to fixup some silent DHCP failures which were giving users hard
+ times
*mol-0.9.68-r2 (26 Feb 2003)
diff --git a/app-emulation/mol/files/digest-mol-0.9.68-r3 b/app-emulation/mol/files/digest-mol-0.9.68-r3
new file mode 100644
index 000000000000..9b0c7ec772e6
--- /dev/null
+++ b/app-emulation/mol/files/digest-mol-0.9.68-r3
@@ -0,0 +1 @@
+MD5 02a65ff0a75b403927d6f1b17d98c74a mol-0.9.68-r3.tar.bz2 1368463
diff --git a/app-emulation/mol/mol-0.9.68-r3.ebuild b/app-emulation/mol/mol-0.9.68-r3.ebuild
new file mode 100644
index 000000000000..842fd315adb2
--- /dev/null
+++ b/app-emulation/mol/mol-0.9.68-r3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.68-r3.ebuild,v 1.1 2003/03/11 19:26:41 gerk Exp $
+
+inherit flag-o-matic
+
+S=${WORKDIR}/${P}-${PR}
+DESCRIPTION="MOL (Mac-on-Linux) lets PPC users run MacOS under Linux"
+SRC_URI="http://cvs.gentoo.org/~gerk/distfiles/${P}-${PR}.tar.bz2"
+HOMEPAGE="http://www.maconlinux.net/"
+
+DEPEND=""
+RDEPEND="net-misc/dhcp
+ sys-apps/iptables
+ >=sys-apps/sed-4.0.5"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="ppc -x86 -sparc -alpha -mips -arm"
+IUSE=""
+
+src_compile() {
+
+ filter-flags -fsigned-char
+
+ # dhcp config fix and show dchpd messages on starting mol
+ cd ${S}
+ sed -i "s:#ddns-update-style:ddns-update-style:g" Doc/config/dhcpd-mol.conf || die
+ sed -i "s:DHCPD\ -q\ -cf:DHCPD\ -cf:g" Doc/config/tunconfig || die
+
+ ./configure --prefix=/usr || die "This is a ppc-only package (time to buy that iBook, no?)"
+ emake || die "Failed to compile MOL"
+
+}
+
+src_install() {
+
+ emake DESTDIR=${D} install || die "Failed to install MOL"
+
+ dodoc 0README BUILDING COPYING COPYRIGHT CREDITS Doc/*
+
+}
+
+pkg_postinst() {
+ echo
+ einfo "Mac-on-Linux is now installed. To run, use the command startmol."
+ einfo "You might want to configure video modes first with molvconfig."
+ einfo "Other configuration is in /etc/molrc. For more info see:"
+ einfo " www.maconlinux.net"
+ einfo "Also try man molrc, man molvconfig, man startmol"
+ echo
+ einfo "For networking and sound you might install the drivers in the"
+ einfo "folder \"MOL-Install\" on your Mac OS X-Desktop."
+ echo
+ einfo "If errors with networking occur, make sure you have the following"
+ einfo "kernel functions enabled:"
+ einfo "For the dhcp server:"
+ einfo " Socket Filtering (CONFIG_FILTER)"
+ einfo " Packet Socket (CONFIG_PACKET)"
+ einfo "For NAT:"
+ einfo " Network packet filtering (CONFIG_NETFILTER)"
+ einfo " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
+ einfo " IP tables support (CONFIG_IP_NF_IPTABLES)"
+ einfo " Packet filtering (CONFIG_IP_NF_FILTER)"
+ einfo " Full NAT (CONFIG_IP_NF_NAT)"
+ einfo " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
+ echo
+}