summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-01-27 23:19:54 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-01-27 23:19:54 +0000
commit5a8b00ab952074d60f5fbdd3a343921675061ea1 (patch)
tree20a126baf40e9e944fd20b711438b2ccfb147cc0 /app-emulation/mol
parentMarked ppc stable for bug #79617. (diff)
downloadgentoo-2-5a8b00ab952074d60f5fbdd3a343921675061ea1.tar.gz
gentoo-2-5a8b00ab952074d60f5fbdd3a343921675061ea1.tar.bz2
gentoo-2-5a8b00ab952074d60f5fbdd3a343921675061ea1.zip
Rev-bump for patch and removed patch from 0.9.70 to give users more options.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-emulation/mol')
-rw-r--r--app-emulation/mol/ChangeLog9
-rw-r--r--app-emulation/mol/Manifest6
-rw-r--r--app-emulation/mol/files/digest-mol-0.9.70-r11
-rw-r--r--app-emulation/mol/mol-0.9.70-r1.ebuild112
-rw-r--r--app-emulation/mol/mol-0.9.70.ebuild3
5 files changed, 126 insertions, 5 deletions
diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
index 0506dea29046..bec19a8bc1d5 100644
--- a/app-emulation/mol/ChangeLog
+++ b/app-emulation/mol/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/mol
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.42 2005/01/27 18:18:12 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.43 2005/01/27 23:19:54 josejx Exp $
+
+*mol-0.9.70-r1 (28 Jan 2005)
+
+ 28 Jan 2005; Joseph Jezak <josejx@gentoo.org> +mol-0.9.70-r1.ebuild,
+ mol-0.9.70.ebuild:
+ Revision bump to ensure everyone is using the patched version. Removed patch
+ from 0.9.70 so users can keep the priority changes if so desired.
28 Jan 2005; Joseph Jezak <josejx@gentoo.org>
+files/mol-0.9.70-nopriority.patch,
diff --git a/app-emulation/mol/Manifest b/app-emulation/mol/Manifest
index a4c20e828a58..650d5d340e49 100644
--- a/app-emulation/mol/Manifest
+++ b/app-emulation/mol/Manifest
@@ -1,8 +1,10 @@
-MD5 bd7d894e95effc2a5f228b24e42b2717 ChangeLog 8336
-MD5 21e8bed87e5fa4da6b0a02fe7133e31b mol-0.9.70.ebuild 3938
+MD5 48ae5a6b88ad7c6ce7b1d00ed9f79dfd ChangeLog 8606
+MD5 788ed74bb37150401009ff62dc038dd9 mol-0.9.70.ebuild 3896
MD5 3263d375abba2d098c636efc2b135ea5 metadata.xml 333
+MD5 21e8bed87e5fa4da6b0a02fe7133e31b mol-0.9.70-r1.ebuild 3938
MD5 bed6f1ce7cb68d6a2f960221656931c9 mol-0.9.71_pre1.ebuild 4051
MD5 934e9ecf483ff3c4e34bb6307212d776 files/mol-0.9.70-nopriority.patch 1853
+MD5 3944510308e77b92ac85c07708947ad0 files/digest-mol-0.9.70-r1 64
MD5 2f8f758938db9b3cb5a13c0b33d989e3 files/mol-module-fix.patch 327
MD5 453e05b555f037270dd6da665e100aa8 files/digest-mol-0.9.71_pre1 69
MD5 0ea7bd65a5ff4666665a71fb9652aae8 files/mol-0.9.70-makefile-fix.patch 924
diff --git a/app-emulation/mol/files/digest-mol-0.9.70-r1 b/app-emulation/mol/files/digest-mol-0.9.70-r1
new file mode 100644
index 000000000000..77c5311411e1
--- /dev/null
+++ b/app-emulation/mol/files/digest-mol-0.9.70-r1
@@ -0,0 +1 @@
+MD5 16f801f3c1db1d75dd3fcb8f4bb06d55 mol-0.9.70.tar.bz2 1640430
diff --git a/app-emulation/mol/mol-0.9.70-r1.ebuild b/app-emulation/mol/mol-0.9.70-r1.ebuild
new file mode 100644
index 000000000000..547f39ff54dc
--- /dev/null
+++ b/app-emulation/mol/mol-0.9.70-r1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.70-r1.ebuild,v 1.1 2005/01/27 23:19:54 josejx Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="MOL (Mac-on-Linux) lets PPC users run MacOS (X) under Linux"
+HOMEPAGE="http://www.maconlinux.net/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ppc"
+IUSE="vnc alsa oss fbcon X oldworld sheep debug"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+DEPEND=""
+RDEPEND="net-misc/dhcp
+ net-firewall/iptables
+ alsa? ( virtual/alsa )
+ vnc? ( net-misc/vnc )
+ X? ( virtual/x11 )"
+
+pkg_setup() {
+ echo
+ einfo "If you want to use MOL fullscreen on a virtual console"
+ einfo "be sure to have the USE-flag \"fbcon\" set!"
+ echo
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # dhcp config fix and show dchpd messages on starting mol
+ cd ${S}
+ sed -i "s:#ddns-update-style:ddns-update-style:g" Doc/config/dhcpd-mol.conf || die
+ sed -i "s:DHCPD\ -q\ -cf:DHCPD\ -cf:g" Doc/config/tunconfig || die
+
+ sed -i "s:prefix = /usr/local:prefix = /usr:" Makefile.top || die
+ sed -i "s#VENDOR :=#VENDOR := -gentoo#" Makefile.top || die
+ epatch ${FILESDIR}/${P}-makefile-fix.patch
+ epatch ${FILESDIR}/${PN}-module-fix.patch
+ epatch ${FILESDIR}/${P}-nopriority.patch
+}
+
+src_compile() {
+ filter-flags -fsigned-char
+
+ export KERNEL_SOURCE="/usr/src/${FK}"
+ export LDFLAGS=""
+
+ # initialize all needed build-files
+ ./autogen.sh
+ #workaround
+ ./configure --disable-png
+ make defconfig || die "This is a ppc-only package (time to buy that iBook, no?)"
+
+ sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config
+ sed -i "s:CONFIG_TAP=y:# CONFIG_TAP is not set:" .config
+ use alsa || sed -i "s:CONFIG_ALSA=y:# CONFIG_ALSA is not set:" .config
+ use debug && sed -i "s:# CONFIG_DEBUGGER is not set:CONFIG_DEBUGGER=y:" .config
+ use oss || sed -i "s:CONFIG_OSS=y:# CONFIG_OSS is not set:" .config
+ use oldworld || sed -i "s:CONFIG_OLDWORLD=y:# CONFIG_OLDWORLD is not set:" .config
+ use sheep || sed -i "s:CONFIG_SHEEP=y:# CONFIG_SHEEP is not set:" .config
+ use X || sed -i "s:CONFIG_X11=y:# CONFIG_X11 is not set:" .config
+ use fbcon || sed -i "s:CONFIG_FBDEV=y:# CONFIG_FBDEV is not set:" .config
+ use vnc || sed -i "s:CONFIG_VNC=y:# CONFIG_VNC is not set:" .config
+
+ einfo "The configuration has been altered according to your USE-flags."
+ # reinitialize our changed configuration
+ make oldconfig
+
+ addwrite "/usr/src/${FK}"
+ make || die "Build mol with: FEATURES=\"-userpriv -usersandbox\" emerge mol"
+}
+
+src_install() {
+ # MOL needs write access to some .depend-files in the kernel-dir
+ # (at least arch/ppc/) to build the kernel-modules. With
+ # sandboxing enabled this would result in an access violation.
+
+ addwrite "/usr/src/${FK}"
+ make DESTDIR=${D} install || die "Failed to install MOL."
+
+ dodoc 0README BUILDING COPYRIGHT CREDITS Doc/*
+}
+
+pkg_postinst() {
+ echo
+ einfo "Mac-on-Linux is now installed. To run, use the command startmol."
+ einfo "You might want to configure video modes first with molvconfig."
+ einfo "Other configuration is in /etc/molrc. For more info see:"
+ einfo " http://www.maconlinux.net"
+ einfo "Also try man molrc, man molvconfig, man startmol"
+ echo
+ ewarn "For networking and sound you might install the drivers in the"
+ ewarn "folder \"MOL-Install\" on your Mac OS X-Desktop."
+ echo
+ ewarn "If errors with networking occur, make sure you have the following"
+ ewarn "kernel functions enabled:"
+ einfo "For the dhcp server:"
+ einfo " Packet Socket (CONFIG_PACKET)"
+ einfo "For NAT:"
+ einfo " Network packet filtering (CONFIG_NETFILTER)"
+ einfo " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
+ einfo " IP tables support (CONFIG_IP_NF_IPTABLES)"
+ einfo " Packet filtering (CONFIG_IP_NF_FILTER)"
+ einfo " Full NAT (CONFIG_IP_NF_NAT)"
+ einfo " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
+ echo
+}
diff --git a/app-emulation/mol/mol-0.9.70.ebuild b/app-emulation/mol/mol-0.9.70.ebuild
index fcd1f57c5a5c..e66a3cb3dd39 100644
--- a/app-emulation/mol/mol-0.9.70.ebuild
+++ b/app-emulation/mol/mol-0.9.70.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.70.ebuild,v 1.12 2005/01/27 18:18:12 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.70.ebuild,v 1.13 2005/01/27 23:19:54 josejx Exp $
inherit flag-o-matic eutils
@@ -41,7 +41,6 @@ src_unpack() {
sed -i "s#VENDOR :=#VENDOR := -gentoo#" Makefile.top || die
epatch ${FILESDIR}/${P}-makefile-fix.patch
epatch ${FILESDIR}/${PN}-module-fix.patch
- epatch ${FILESDIR}/${P}-nopriority.patch
}
src_compile() {