summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-05-02 09:12:49 +0000
committerPacho Ramos <pacho@gentoo.org>2014-05-02 09:12:49 +0000
commit56de2a19ed80150677c6555b274551d87d4d922f (patch)
treef70b3c05bce2e1ebb2aa7b4fb5c70fdbf93f8029 /app-emulation/libvirt-glib
parentFix gtk-doc dep (#509118 by Chris Williams) (diff)
downloadgentoo-2-56de2a19ed80150677c6555b274551d87d4d922f.tar.gz
gentoo-2-56de2a19ed80150677c6555b274551d87d4d922f.tar.bz2
gentoo-2-56de2a19ed80150677c6555b274551d87d4d922f.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-emulation/libvirt-glib')
-rw-r--r--app-emulation/libvirt-glib/ChangeLog7
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-0.1.8.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/app-emulation/libvirt-glib/ChangeLog b/app-emulation/libvirt-glib/ChangeLog
index cc60af03fe6f..fa75a01988ca 100644
--- a/app-emulation/libvirt-glib/ChangeLog
+++ b/app-emulation/libvirt-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/libvirt-glib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.26 2014/04/23 20:47:29 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.27 2014/05/02 09:12:49 pacho Exp $
+
+*libvirt-glib-0.1.8 (02 May 2014)
+
+ 02 May 2014; Pacho Ramos <pacho@gentoo.org> +libvirt-glib-0.1.8.ebuild:
+ Version bump
23 Apr 2014; Pacho Ramos <pacho@gentoo.org> -libvirt-glib-0.1.6.ebuild:
Drop old
diff --git a/app-emulation/libvirt-glib/libvirt-glib-0.1.8.ebuild b/app-emulation/libvirt-glib/libvirt-glib-0.1.8.ebuild
new file mode 100644
index 000000000000..7774b3fb748f
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-0.1.8.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/libvirt-glib-0.1.8.ebuild,v 1.1 2014/05/02 09:12:49 pacho Exp $
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.14"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit gnome2 python-single-r1 vala
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection python +vala"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ vala? ( introspection )
+"
+
+# https://bugzilla.redhat.com/show_bug.cgi?id=1093633
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=app-emulation/libvirt-0.9.10:=
+ >=dev-libs/glib-2.38.0:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-test-coverage \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(use_with python)
+}
+
+src_compile() {
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1093631
+ if use vala; then
+ MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_compile
+ else
+ gnome2_src_compile
+ fi
+}