summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-07-16 16:47:11 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-07-16 16:47:11 +0000
commit38fe139350bc957be61d48726a18a0b0a004a59c (patch)
tree4d99b2aac50ec0c50cbdb523c2420c16c8debaa0 /app-emulation/libvirt-glib
parentVersion bump (diff)
downloadgentoo-2-38fe139350bc957be61d48726a18a0b0a004a59c.tar.gz
gentoo-2-38fe139350bc957be61d48726a18a0b0a004a59c.tar.bz2
gentoo-2-38fe139350bc957be61d48726a18a0b0a004a59c.zip
Version bump.
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/libvirt-glib')
-rw-r--r--app-emulation/libvirt-glib/ChangeLog7
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-0.1.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/app-emulation/libvirt-glib/ChangeLog b/app-emulation/libvirt-glib/ChangeLog
index 1daae4e04892..2710b4503231 100644
--- a/app-emulation/libvirt-glib/ChangeLog
+++ b/app-emulation/libvirt-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/libvirt-glib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.13 2012/06/25 15:57:40 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.14 2012/07/16 16:47:11 cardoe Exp $
+
+*libvirt-glib-0.1.0 (16 Jul 2012)
+
+ 16 Jul 2012; Doug Goldstein <cardoe@gentoo.org> +libvirt-glib-0.1.0.ebuild:
+ Version bump.
*libvirt-glib-0.0.9 (25 Jun 2012)
diff --git a/app-emulation/libvirt-glib/libvirt-glib-0.1.0.ebuild b/app-emulation/libvirt-glib/libvirt-glib-0.1.0.ebuild
new file mode 100644
index 000000000000..07b34e388b80
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-0.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/libvirt-glib-0.1.0.ebuild,v 1.1 2012/07/16 16:47:11 cardoe Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 python
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +introspection python +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=app-emulation/libvirt-0.9.10
+ >=dev-libs/glib-2.10:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ vala? ( dev-lang/vala:0.14 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ G2CONF="--disable-test-coverage
+ VAPIGEN=$(type -P vapigen-0.14)
+ $(use_enable introspection)
+ $(use_enable vala)
+ $(use_with python)"
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_compile() {
+ emake -j1
+}