summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-10-08 15:44:22 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-10-08 15:44:22 +0000
commit342479152640b0af1561039a4ef37e05fcd34629 (patch)
tree9a2c1eacc6410155f5835a08cdad2ec0999ca95f /app-emulation/libvirt-glib
parentRemove useflag 'doc' as HTML documentation was eleminated from the distributi... (diff)
downloadgentoo-2-342479152640b0af1561039a4ef37e05fcd34629.tar.gz
gentoo-2-342479152640b0af1561039a4ef37e05fcd34629.tar.bz2
gentoo-2-342479152640b0af1561039a4ef37e05fcd34629.zip
Version bump
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/libvirt-glib')
-rw-r--r--app-emulation/libvirt-glib/ChangeLog7
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-0.1.3.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-emulation/libvirt-glib/ChangeLog b/app-emulation/libvirt-glib/ChangeLog
index 9d68569ee67e..9fce136391e3 100644
--- a/app-emulation/libvirt-glib/ChangeLog
+++ b/app-emulation/libvirt-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/libvirt-glib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.15 2012/09/29 13:39:02 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.16 2012/10/08 15:44:22 cardoe Exp $
+
+*libvirt-glib-0.1.3 (08 Oct 2012)
+
+ 08 Oct 2012; Doug Goldstein <cardoe@gentoo.org> +libvirt-glib-0.1.3.ebuild:
+ Version bump
*libvirt-glib-0.1.2 (29 Sep 2012)
diff --git a/app-emulation/libvirt-glib/libvirt-glib-0.1.3.ebuild b/app-emulation/libvirt-glib/libvirt-glib-0.1.3.ebuild
new file mode 100644
index 000000000000..89a0859fe33a
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-0.1.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/libvirt-glib-0.1.3.ebuild,v 1.1 2012/10/08 15:44:22 cardoe Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.14"
+
+inherit gnome2 python vala
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +introspection python +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=app-emulation/libvirt-0.9.10
+ >=dev-libs/glib-2.10:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ use vala && vala_src_prepare
+}
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ G2CONF="--disable-test-coverage
+ $(use_enable introspection)
+ $(use_enable vala)
+ $(use_with python)"
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_compile() {
+ emake -j1
+}