summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-01-12 06:12:24 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-01-12 06:12:24 +0000
commit0a44ea95b651b9fc3e2dfffcbcf5b36b7046bd10 (patch)
tree501a30be21e0d058fb4b39a8e6be7085f4430372 /app-emulation/kvm-kmod
parentVersion bump. (diff)
downloadgentoo-2-0a44ea95b651b9fc3e2dfffcbcf5b36b7046bd10.tar.gz
gentoo-2-0a44ea95b651b9fc3e2dfffcbcf5b36b7046bd10.tar.bz2
gentoo-2-0a44ea95b651b9fc3e2dfffcbcf5b36b7046bd10.zip
version bump. fixes migration issues. fixes Windows 2008 R2
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/kvm-kmod')
-rw-r--r--app-emulation/kvm-kmod/ChangeLog7
-rw-r--r--app-emulation/kvm-kmod/kvm-kmod-2.6.32.3.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/app-emulation/kvm-kmod/ChangeLog b/app-emulation/kvm-kmod/ChangeLog
index 11214ea6e940..d5342b822889 100644
--- a/app-emulation/kvm-kmod/ChangeLog
+++ b/app-emulation/kvm-kmod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/kvm-kmod
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/ChangeLog,v 1.6 2010/01/05 22:35:12 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/ChangeLog,v 1.7 2010/01/12 06:12:24 cardoe Exp $
+
+*kvm-kmod-2.6.32.3 (12 Jan 2010)
+
+ 12 Jan 2010; Doug Goldstein <cardoe@gentoo.org> +kvm-kmod-2.6.32.3.ebuild:
+ version bump. fixes migration issues. fixes Windows 2008 R2
*kvm-kmod-2.6.32.2 (05 Jan 2010)
diff --git a/app-emulation/kvm-kmod/kvm-kmod-2.6.32.3.ebuild b/app-emulation/kvm-kmod/kvm-kmod-2.6.32.3.ebuild
new file mode 100644
index 000000000000..e58b74d8850f
--- /dev/null
+++ b/app-emulation/kvm-kmod/kvm-kmod-2.6.32.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/kvm-kmod-2.6.32.3.ebuild,v 1.1 2010/01/12 06:12:24 cardoe Exp $
+
+EAPI="2"
+
+inherit eutils linux-mod
+
+SRC_URI="mirror://sourceforge/kvm/${P}.tar.bz2"
+
+DESCRIPTION="Kernel-based Virtual Machine kernel modules"
+HOMEPAGE="http://www.linux-kvm.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if ! linux_chkconfig_present KVM; then
+ eerror "KVM now needs CONFIG_KVM built into your kernel, even"
+ eerror "if you're using the external modules from this package."
+ eerror "Please enable KVM support in your kernel, found at:"
+ eerror
+ eerror " Virtualization"
+ eerror " Kernel-based Virtual Machine (KVM) support"
+ eerror
+ die "KVM support not detected!"
+ fi
+ BUILD_TARGETS="all"
+ MODULE_NAMES="kvm(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-intel(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-amd(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ linux-mod_pkg_setup
+}
+
+src_configure() {
+ local conf_opts
+
+ conf_opts="--kerneldir=$KV_DIR"
+
+ if has_multilib_profile && [[ "${DEFAULT_ABI}" == "x86" ]] ; then
+ conf_opts="$conf_opts --arch=x86"
+ fi
+
+ ./configure ${conf_opts} || die "configure failed"
+}
+
+src_compile() {
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+}
+
+pkg_preinst() {
+ find /lib/modules/${KV_FULL} -name 'kvm*.ko' -type f -delete
+
+ linux-mod_pkg_preinst
+}