summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2009-03-09 09:01:57 +0000
committerLuca Barbato <lu_zero@gentoo.org>2009-03-09 09:01:57 +0000
commit9f88b550d436d2dc66b50828b9412568bf187a7e (patch)
treebb82767d17bb720a2c03dd74a13199c5365d31d3 /app-emulation/kqemu
parentVersion bump. (diff)
downloadgentoo-2-9f88b550d436d2dc66b50828b9412568bf187a7e.tar.gz
gentoo-2-9f88b550d436d2dc66b50828b9412568bf187a7e.tar.bz2
gentoo-2-9f88b550d436d2dc66b50828b9412568bf187a7e.zip
Fix bug #261664, thanks to pva for doing all the work
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/kqemu')
-rw-r--r--app-emulation/kqemu/ChangeLog7
-rw-r--r--app-emulation/kqemu/files/kqemu-1.4.0_pre1-missing-sched-header.patch12
-rw-r--r--app-emulation/kqemu/kqemu-1.4.0_pre1.ebuild23
3 files changed, 34 insertions, 8 deletions
diff --git a/app-emulation/kqemu/ChangeLog b/app-emulation/kqemu/ChangeLog
index d72ab551c1e9..3e0c4ebd4043 100644
--- a/app-emulation/kqemu/ChangeLog
+++ b/app-emulation/kqemu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/kqemu
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/ChangeLog,v 1.24 2009/03/06 22:18:01 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/ChangeLog,v 1.25 2009/03/09 09:01:57 lu_zero Exp $
+
+ 09 Mar 2009; Luca Barbato <lu_zero@gentoo.org>
+ +files/kqemu-1.4.0_pre1-missing-sched-header.patch,
+ kqemu-1.4.0_pre1.ebuild:
+ Fix bug #261664, thanks to pva for doing all the work
*kqemu-1.4.0_pre1 (06 Mar 2009)
diff --git a/app-emulation/kqemu/files/kqemu-1.4.0_pre1-missing-sched-header.patch b/app-emulation/kqemu/files/kqemu-1.4.0_pre1-missing-sched-header.patch
new file mode 100644
index 000000000000..6df868590c83
--- /dev/null
+++ b/app-emulation/kqemu/files/kqemu-1.4.0_pre1-missing-sched-header.patch
@@ -0,0 +1,12 @@
+=== modified file 'kqemu-linux.c'
+--- kqemu-linux.c 2009-03-08 10:40:57 +0000
++++ kqemu-linux.c 2009-03-08 10:40:58 +0000
+@@ -30,6 +30,7 @@
+ #include <asm/processor.h>
+ #include <asm/uaccess.h>
+ #include <asm/io.h>
++#include <linux/sched.h>
+
+ #include "kqemu-kernel.h"
+
+
diff --git a/app-emulation/kqemu/kqemu-1.4.0_pre1.ebuild b/app-emulation/kqemu/kqemu-1.4.0_pre1.ebuild
index 4d7421306c82..11c32dd4a34c 100644
--- a/app-emulation/kqemu/kqemu-1.4.0_pre1.ebuild
+++ b/app-emulation/kqemu/kqemu-1.4.0_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/kqemu-1.4.0_pre1.ebuild,v 1.1 2009/03/06 22:18:01 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/kqemu-1.4.0_pre1.ebuild,v 1.2 2009/03/09 09:01:57 lu_zero Exp $
inherit eutils flag-o-matic linux-mod toolchain-funcs
@@ -17,7 +17,7 @@ KEYWORDS="-* ~amd64 ~x86"
RESTRICT="strip"
IUSE=""
-S="${WORKDIR}/$MY_P"
+S="${WORKDIR}/${MY_P}"
DEPEND=""
RDEPEND=""
@@ -31,6 +31,16 @@ src_unpack() {
unpack ${A}
cd "${S}"
sed -i 's:MODULE_PARM(\([^,]*\),"i");:module_param(\1, int, 0);:' kqemu-linux.c
+ sed -e 's:-Werror::' -i common/Makefile #260876
+ sed -e '/^CC/d;/^HOST_CC/d;' \
+ -e 's/\(^MON_CC=\).*/\1$(CC)/' \
+ -e "s/\(^MON_LD=\).*/\1$(tc-getLD)/" \
+ -e 's/^\(TOOLS_CFLAGS.*\)/\1 $(CFLAGS)/' \
+ -e 's/^\(MON_CFLAGS.*\)/\1 $(CFLAGS)/' \
+ -e 's/^\(KERNEL_CFLAGS.*\)/\1 $(CFLAGS)/' \
+ -e 's/^CFLAGS=\(.*\)/CFLAGS+=\1/' \
+ -i common/Makefile
+ epatch "${FILESDIR}/${P}-missing-sched-header.patch"
}
src_compile() {
@@ -41,6 +51,10 @@ src_compile() {
filter-flags -fpie -fstack-protector
./configure --kernel-path="${KV_DIR}" \
+ --cc="$(tc-getCC)" \
+ --host-cc="$(tc-getBUILD_CC)" \
+ --extra-cflags="${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}" \
|| die "could not configure"
make
@@ -67,9 +81,4 @@ pkg_postinst() {
enewgroup qemu
elog "Make sure you have the kernel module loaded before running qemu"
elog "and your user is in the 'qemu' group"
- case ${CHOST} in
- *-darwin*) elog "Just run 'niutil -appendprop / /groups/qemu users <USER>'";;
- *-freebsd*|*-dragonfly*) elog "Just run 'pw groupmod qemu -m <USER>'";;
- *) elog "Just run 'gpasswd -a <USER> qemu', then have <USER> re-login.";;
- esac
}