summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-02-11 11:30:15 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-02-11 11:30:15 +0000
commit367ae2a4ebee1f050ac640233b3462abbd748681 (patch)
tree8af3e79bcdffe1b5a4ef9014b961d39f88a0d8e9 /app-emulation/hercules
parentfixed DEPEND (Manifest recommit) (diff)
downloadgentoo-2-367ae2a4ebee1f050ac640233b3462abbd748681.tar.gz
gentoo-2-367ae2a4ebee1f050ac640233b3462abbd748681.tar.bz2
gentoo-2-367ae2a4ebee1f050ac640233b3462abbd748681.zip
version bump, bug #39612
Diffstat (limited to 'app-emulation/hercules')
-rw-r--r--app-emulation/hercules/ChangeLog9
-rw-r--r--app-emulation/hercules/Manifest2
-rw-r--r--app-emulation/hercules/files/digest-hercules-3.011
-rw-r--r--app-emulation/hercules/hercules-3.01.ebuild59
4 files changed, 69 insertions, 2 deletions
diff --git a/app-emulation/hercules/ChangeLog b/app-emulation/hercules/ChangeLog
index d5b92e0b2389..a27384fbc50d 100644
--- a/app-emulation/hercules/ChangeLog
+++ b/app-emulation/hercules/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/hercules
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.8 2003/10/12 18:27:22 lanius Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.9 2004/02/11 11:30:15 lanius Exp $
+
+*hercules-3.01 (11 Feb 2004)
+
+ 11 Feb 2004; Heinrich Wendel <lanius@gentoo.org> hercules-3.01.ebuild:
+ version bump, bug #39612
*hercules-3.00 (12 Oct 2003)
diff --git a/app-emulation/hercules/Manifest b/app-emulation/hercules/Manifest
index 635db652a250..a56c63b88995 100644
--- a/app-emulation/hercules/Manifest
+++ b/app-emulation/hercules/Manifest
@@ -1,5 +1,7 @@
+MD5 197d86da686aa9af74994a8753530db6 hercules-3.01.ebuild 1900
MD5 58a4661b6dbc455aa7403cc0e653f430 hercules-2.17.1-r1.ebuild 1775
MD5 9520d32fb53bf71a191b50a785291f77 hercules-3.00.ebuild 1918
MD5 43065f9047f8c18832b3ea277ad6af0a ChangeLog 1055
MD5 e09f0c008fb3b02510eb63971a66ecf3 files/digest-hercules-2.17.1-r1 68
MD5 64b6313ec62cc77a8a5b021ab426a67d files/digest-hercules-3.00 66
+MD5 420850c3a641b2b1c34c6a9794e2278c files/digest-hercules-3.01 66
diff --git a/app-emulation/hercules/files/digest-hercules-3.01 b/app-emulation/hercules/files/digest-hercules-3.01
new file mode 100644
index 000000000000..63645a71a4ba
--- /dev/null
+++ b/app-emulation/hercules/files/digest-hercules-3.01
@@ -0,0 +1 @@
+MD5 a410fa6446da025ef8aba0b25bf08caa hercules-3.01.tar.gz 1719086
diff --git a/app-emulation/hercules/hercules-3.01.ebuild b/app-emulation/hercules/hercules-3.01.ebuild
new file mode 100644
index 000000000000..0d71aae2f9f4
--- /dev/null
+++ b/app-emulation/hercules/hercules-3.01.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-3.01.ebuild,v 1.1 2004/02/11 11:30:15 lanius Exp $
+
+DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
+SRC_URI="http://www.conmicro.cx/hercules/${P}.tar.gz"
+HOMEPAGE="http://www.conmicro.cx/hercules/"
+LICENSE="QPL-1.0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/glibc
+ app-arch/bzip2"
+
+src_compile() {
+ local mycflags
+ mycflags="${CFLAGS}"
+ unset CFLAGS ; unset CXXFLAGS
+
+ econf \
+ --enable-optimization="${mycflags}" \
+ --enable-cckd-bzip2 \
+ --enable-het-bzip2 \
+ --enable-setuid-hercifc \
+ --enable-custom="Gentoo Linux ${PF}.ebuild" \
+ --enable-multi-cpu=7 \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install
+ dohtml -r html/
+ insinto /usr/share/hercules
+ doins hercules.cnf
+ dodoc README.COMMADPT README.CVS README.ECPSVM README.HDL
+ dodoc README.NETWORKING README.OSX README.TAPE
+ dodoc RELEASE.NOTES CHANGES
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Hercules System/370, ESA/390 and zArchitecture Mainframe"
+ einfo "Emulator has been installed. Some useful utility files have"
+ einfo "been placed in /usr/share/hercules. For detailed configuration"
+ einfo "and operating instructions, see http://www.conmicro.cx/hercules"
+ einfo
+ einfo "In order to use Hercules you will need a guest operating"
+ einfo "system. There are several flavours of 'Linux for S/390' and"
+ einfo "'Linux for zSeries' available, or if you want that 'Big Iron'"
+ einfo "feel, you can download several real mainframe operating systems"
+ einfo "such as OS/360, DOS/VS, MVS, or VM370 from http://www.cbttape.org"
+ einfo
+ einfo "Hercules is also capable of runing OS/390, z/OS, and z/VM with an"
+ einfo "appropriate liscense."
+ einfo
+}