summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-20 21:00:38 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-20 21:00:38 +0000
commitdc89791e7eee4a58819d31ddfcebc3ee993879c0 (patch)
tree0e737f5df430176fdf890dad8e94b9368f2efbc3 /app-emulation/gxemul
parentStable on amd64 wrt bug #337153 (diff)
downloadgentoo-2-dc89791e7eee4a58819d31ddfcebc3ee993879c0.tar.gz
gentoo-2-dc89791e7eee4a58819d31ddfcebc3ee993879c0.tar.bz2
gentoo-2-dc89791e7eee4a58819d31ddfcebc3ee993879c0.zip
Version bump. Respect LDFLAGS (bug #336342). New HOMEPAGE and SRC_URI. Do not install LICENSE.
(Portage version: 2.2_rc84/cvs/Linux i686)
Diffstat (limited to 'app-emulation/gxemul')
-rw-r--r--app-emulation/gxemul/ChangeLog10
-rw-r--r--app-emulation/gxemul/gxemul-0.6.0.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/app-emulation/gxemul/ChangeLog b/app-emulation/gxemul/ChangeLog
index 2f325f09878e..5ed1220f6a70 100644
--- a/app-emulation/gxemul/ChangeLog
+++ b/app-emulation/gxemul/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/gxemul
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/ChangeLog,v 1.14 2009/10/25 20:20:53 tove Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/ChangeLog,v 1.15 2010/09/20 21:00:38 jer Exp $
+
+*gxemul-0.6.0 (20 Sep 2010)
+
+ 20 Sep 2010; Jeroen Roovers <jer@gentoo.org> +gxemul-0.6.0.ebuild:
+ Version bump. Respect LDFLAGS (bug #336342). New HOMEPAGE and SRC_URI. Do
+ not install LICENSE.
25 Oct 2009; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove drizzt from metadata.xml (#149111)
diff --git a/app-emulation/gxemul/gxemul-0.6.0.ebuild b/app-emulation/gxemul/gxemul-0.6.0.ebuild
new file mode 100644
index 000000000000..c8600835bdcb
--- /dev/null
+++ b/app-emulation/gxemul/gxemul-0.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/gxemul-0.6.0.ebuild,v 1.1 2010/09/20 21:00:38 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A Machine Emulator, Mainly emulates MIPS, but supports other CPU types."
+HOMEPAGE="http://gxemul.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/gxemul/GXemul/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="X"
+
+RDEPEND="X? ( x11-libs/libX11 )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )"
+
+src_prepare() {
+ sed -i configure -e 's|-O3||g' || die "sed configure"
+}
+
+src_configure() {
+ tc-export CC CXX
+
+ # no autotools
+ ./configure $(use X || echo --disable-x) || die "configure failed"
+}
+
+src_install() {
+ dobin gxemul || die
+ doman man/gxemul.1
+ dodoc HISTORY README RELEASE TODO
+ dohtml doc/*
+}