summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2006-11-06 23:07:38 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2006-11-06 23:07:38 +0000
commit26714d430ebcfce5f8e48ba889fb58af2b3aeac2 (patch)
treed3b02dc95098662878f4947d5d545c2a066c0814 /app-emulation/gxemul
parentClean up the dependencies a bit, add a patch to fix a CXXFLAGS=CFLAGS error. (diff)
downloadgentoo-2-26714d430ebcfce5f8e48ba889fb58af2b3aeac2.tar.gz
gentoo-2-26714d430ebcfce5f8e48ba889fb58af2b3aeac2.tar.bz2
gentoo-2-26714d430ebcfce5f8e48ba889fb58af2b3aeac2.zip
Version bump.
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'app-emulation/gxemul')
-rw-r--r--app-emulation/gxemul/ChangeLog7
-rw-r--r--app-emulation/gxemul/files/digest-gxemul-0.4.33
-rw-r--r--app-emulation/gxemul/gxemul-0.4.3.ebuild41
3 files changed, 50 insertions, 1 deletions
diff --git a/app-emulation/gxemul/ChangeLog b/app-emulation/gxemul/ChangeLog
index 089b921b7d27..ed1bb066cc24 100644
--- a/app-emulation/gxemul/ChangeLog
+++ b/app-emulation/gxemul/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/gxemul
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/ChangeLog,v 1.5 2006/10/24 10:36:24 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/ChangeLog,v 1.6 2006/11/06 23:07:38 drizzt Exp $
+
+*gxemul-0.4.3 (06 Nov 2006)
+
+ 06 Nov 2006; Timothy Redaelli <drizzt@gentoo.org> +gxemul-0.4.3.ebuild:
+ Version bump.
24 Oct 2006; Timothy Redaelli <drizzt@gentoo.org> gxemul-0.4.2.ebuild:
Added ~x86-fbsd keyword.
diff --git a/app-emulation/gxemul/files/digest-gxemul-0.4.3 b/app-emulation/gxemul/files/digest-gxemul-0.4.3
new file mode 100644
index 000000000000..90798189d3f4
--- /dev/null
+++ b/app-emulation/gxemul/files/digest-gxemul-0.4.3
@@ -0,0 +1,3 @@
+MD5 4d719fde71784ead1c85c78b2a9c37a8 gxemul-0.4.3.tar.gz 2026817
+RMD160 5c4599f8dc5d0942629981f041868f92d46e8c22 gxemul-0.4.3.tar.gz 2026817
+SHA256 589e2577e5f4c93c2a08775c03800f09d59a3bf82187332e03353355006e8ad2 gxemul-0.4.3.tar.gz 2026817
diff --git a/app-emulation/gxemul/gxemul-0.4.3.ebuild b/app-emulation/gxemul/gxemul-0.4.3.ebuild
new file mode 100644
index 000000000000..8e30386ac087
--- /dev/null
+++ b/app-emulation/gxemul/gxemul-0.4.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/gxemul-0.4.3.ebuild,v 1.1 2006/11/06 23:07:38 drizzt Exp $
+
+inherit eutils
+
+DESCRIPTION="A Machine Emulator, Mainly emulates MIPS, but supports other CPU types."
+HOMEPAGE="http://gavare.se/gxemul/"
+SRC_URI="http://gavare.se/gxemul/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="X"
+
+RDEPEND="X? ( || ( ( x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXdmcp
+ )
+ virtual/x11 ) )"
+
+DEPEND="${RDEPEND}
+ X? ( || ( x11-proto/xproto virtual/x11 ) )"
+
+src_compile() {
+ local myconf=""
+
+ use X || myconf="${myconf} --disable-x"
+
+ einfo "Configuring with: ${myconf}"
+ ./configure ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin gxemul || die "gxemul not found in ${S}"
+ doman man/gxemul.1
+ dodoc HISTORY LICENSE README RELEASE TODO
+ dohtml doc/*
+}