summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2010-05-07 18:57:43 +0000
committerLance Albertson <ramereth@gentoo.org>2010-05-07 18:57:43 +0000
commit87c4dda23728157290f21aff32ac28de68a92a84 (patch)
tree821fd7e9bdf87f4331cb95f907a432385fa98ef8 /app-emulation/ganeti
parentMove fossil and svk from dev-util to dev-vcs, bug 56967. (diff)
downloadgentoo-2-87c4dda23728157290f21aff32ac28de68a92a84.tar.gz
gentoo-2-87c4dda23728157290f21aff32ac28de68a92a84.tar.bz2
gentoo-2-87c4dda23728157290f21aff32ac28de68a92a84.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/ganeti')
-rw-r--r--app-emulation/ganeti/ChangeLog7
-rw-r--r--app-emulation/ganeti/ganeti-2.1.2.1.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/app-emulation/ganeti/ChangeLog b/app-emulation/ganeti/ChangeLog
index 5f76685a39c2..c0ce54b618fa 100644
--- a/app-emulation/ganeti/ChangeLog
+++ b/app-emulation/ganeti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/ganeti
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.20 2010/03/12 19:21:58 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.21 2010/05/07 18:57:43 ramereth Exp $
+
+*ganeti-2.1.2.1 (07 May 2010)
+
+ 07 May 2010; Lance Albertson <ramereth@gentoo.org> +ganeti-2.1.2.1.ebuild:
+ Version bump
*ganeti-2.1.1 (12 Mar 2010)
diff --git a/app-emulation/ganeti/ganeti-2.1.2.1.ebuild b/app-emulation/ganeti/ganeti-2.1.2.1.ebuild
new file mode 100644
index 000000000000..1a4757feef46
--- /dev/null
+++ b/app-emulation/ganeti/ganeti-2.1.2.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.1.2.1.ebuild,v 1.1 2010/05/07 18:57:43 ramereth Exp $
+
+EAPI=2
+
+inherit eutils confutils bash-completion
+
+MY_PV="${PV/_rc/~rc}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Ganeti is a virtual server management software tool"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kvm xen drbd +filestorage syslog"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="xen? ( >=app-emulation/xen-3.0 )
+ kvm? ( app-emulation/qemu-kvm )
+ drbd? ( >=sys-cluster/drbd-8.0 )
+ dev-libs/openssl
+ dev-python/pyopenssl
+ dev-python/pyparsing
+ dev-python/pyinotify
+ dev-python/simplejson
+ net-analyzer/arping
+ net-misc/bridge-utils
+ net-misc/openssh
+ net-misc/socat
+ sys-apps/iproute2
+ sys-fs/lvm2"
+RDEPEND="${DEPEND}"
+
+pkg_setup () {
+ confutils_require_any kvm xen
+}
+
+src_configure () {
+ local myconf
+ if use filestorage ; then
+ myconf="--with-file-storage-dir=/var/lib/ganeti-storage/file"
+ else
+ myconf="--with-file-storage-dir=no"
+ fi
+ econf --localstatedir=/var \
+ --docdir=/usr/share/doc/${P} \
+ --with-ssh-initscript=/etc/init.d/sshd \
+ --with-export-dir=/var/lib/ganeti-storage/export \
+ --with-os-search-path=/usr/share/ganeti/os \
+ $(use_enable syslog) \
+ ${myconf}
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/ganeti-2.1.initd ganeti
+ newconfd "${FILESDIR}"/ganeti.confd ganeti
+ dobashcompletion doc/examples/bash_completion ganeti
+ dodoc INSTALL NEWS README doc/*.rst
+ rm -rf "${D}"/usr/share/doc/ganeti
+ docinto examples
+ dodoc doc/examples/{dumb-allocator,ganeti.cron,gnt-config-backup}
+ docinto examples/hooks
+ dodoc doc/examples/hooks/{ipsec,ethers}
+
+ keepdir /var/{lib,log,run}/ganeti/
+ keepdir /usr/share/ganeti/os/
+ keepdir /var/lib/ganeti-storage/{export,file}/
+}
+
+pkg_postinst () {
+ bash-completion_pkg_postinst
+}