summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2006-06-10 07:59:46 +0000
committerChris Bainbridge <chrb@gentoo.org>2006-06-10 07:59:46 +0000
commit626ac5e6a72bd9ca8c620e0a5bbbdb709c704d74 (patch)
tree1eaf29bf54c9ccb586ed0ea28ce4dd5c50ac7cb8 /app-emulation/domi
parentFixed gcc patch not working in some cases due to Windows EOL characters in th... (diff)
downloadgentoo-2-626ac5e6a72bd9ca8c620e0a5bbbdb709c704d74.tar.gz
gentoo-2-626ac5e6a72bd9ca8c620e0a5bbbdb709c704d74.tar.bz2
gentoo-2-626ac5e6a72bd9ca8c620e0a5bbbdb709c704d74.zip
Added DEPEND on yum, bug #133848. Fix DOMI_DISK_VG, bug #136241
(Portage version: 2.1)
Diffstat (limited to 'app-emulation/domi')
-rw-r--r--app-emulation/domi/ChangeLog8
-rw-r--r--app-emulation/domi/domi-20060406-r3.ebuild35
-rw-r--r--app-emulation/domi/files/digest-domi-20060406-r33
-rw-r--r--app-emulation/domi/files/domi.conf4
4 files changed, 47 insertions, 3 deletions
diff --git a/app-emulation/domi/ChangeLog b/app-emulation/domi/ChangeLog
index a3b9d9929bf3..2d33159426cb 100644
--- a/app-emulation/domi/ChangeLog
+++ b/app-emulation/domi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/domi
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/domi/ChangeLog,v 1.3 2006/06/03 09:55:51 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/domi/ChangeLog,v 1.4 2006/06/10 07:59:46 chrb Exp $
+
+*domi-20060406-r3 (10 Jun 2006)
+
+ 10 Jun 2006; Chris Bainbridge <chrb@gentoo.org> files/domi.conf,
+ +domi-20060406-r3.ebuild:
+ Added DEPEND on yum, bug #133848. Fix DOMI_DISK_VG, bug #136241
*domi-20060406-r2 (03 Jun 2006)
diff --git a/app-emulation/domi/domi-20060406-r3.ebuild b/app-emulation/domi/domi-20060406-r3.ebuild
new file mode 100644
index 000000000000..0dfca1268d76
--- /dev/null
+++ b/app-emulation/domi/domi-20060406-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/domi/domi-20060406-r3.ebuild,v 1.1 2006/06/10 07:59:46 chrb Exp $
+
+inherit eutils
+DESCRIPTION="Scripts for building Xen domains"
+HOMEPAGE="http://www.bytesex.org"
+EXTRA_VERSION="104418"
+SRC_URI="http://dl.bytesex.org/cvs-snapshots/${P}-${EXTRA_VERSION}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="app-emulation/xen-tools
+ app-arch/rpm
+ sys-apps/parted
+ sys-apps/yum
+ sys-fs/lvm2
+ sys-fs/multipath-tools"
+# there are some other depends we may need depending on the target system
+# these packages aren't in gentoo yet. feel free to submit ebuilds via bugzilla.
+# y2pmsh
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's:/dev/loop\$:/dev/loop/\$:' ${S}/domi
+}
+
+src_install() {
+ einstall || die
+ insinto /etc
+ doins ${FILESDIR}/domi.conf || die
+}
diff --git a/app-emulation/domi/files/digest-domi-20060406-r3 b/app-emulation/domi/files/digest-domi-20060406-r3
new file mode 100644
index 000000000000..5b16412356fb
--- /dev/null
+++ b/app-emulation/domi/files/digest-domi-20060406-r3
@@ -0,0 +1,3 @@
+MD5 fa41a5b6f59a4ffcb6020ddb93630297 domi-20060406-104418.tar.gz 14936
+RMD160 9923dbc3bc003bcb0602e5b0a5181ab54fc70874 domi-20060406-104418.tar.gz 14936
+SHA256 373fc778c8d245603b71c9d38c5c54211fe38c75961546e8f773e104a358e139 domi-20060406-104418.tar.gz 14936
diff --git a/app-emulation/domi/files/domi.conf b/app-emulation/domi/files/domi.conf
index 432cc740c13b..429a16505156 100644
--- a/app-emulation/domi/files/domi.conf
+++ b/app-emulation/domi/files/domi.conf
@@ -62,7 +62,7 @@ DOMI_XEN_MEMORY="128"
#setup the virtual disk.
#Recommended.
#DOMI_DISK_VG="volg-md9"# without a "/"
-DOMI_DISK_VG=" "
+DOMI_DISK_VG=""
#DOMI_DISK_FILE
#If you don't use LVM you can specify an image file to use for the
@@ -92,4 +92,4 @@ DOMI_SWAP_SIZE="256"
#DOMI_HOOK_POST
#Custom postinstall script to run.
-################### \ No newline at end of file
+###################