summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-03 05:17:34 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-03 05:17:34 +0000
commit60c8cbffca76628240ff76112cb51582ccd8e197 (patch)
treed45be3ea4c7d5f434e76c350cb83120e4f572fec /app-emulation/crossover-office-pro-bin
parentBug #321785 - Use build? conditional to avoid pulling in python3 for stage1 b... (diff)
downloadgentoo-2-60c8cbffca76628240ff76112cb51582ccd8e197.tar.gz
gentoo-2-60c8cbffca76628240ff76112cb51582ccd8e197.tar.bz2
gentoo-2-60c8cbffca76628240ff76112cb51582ccd8e197.zip
Version bump #330257 by Michiel de Bruijne.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/crossover-office-pro-bin')
-rw-r--r--app-emulation/crossover-office-pro-bin/ChangeLog8
-rw-r--r--app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-9.1.0.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/app-emulation/crossover-office-pro-bin/ChangeLog b/app-emulation/crossover-office-pro-bin/ChangeLog
index 917528b57688..6f7310a3b749 100644
--- a/app-emulation/crossover-office-pro-bin/ChangeLog
+++ b/app-emulation/crossover-office-pro-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/crossover-office-pro-bin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/ChangeLog,v 1.17 2010/04/30 13:17:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/ChangeLog,v 1.18 2010/08/03 05:17:34 vapier Exp $
+
+*crossover-office-pro-bin-9.1.0 (03 Aug 2010)
+
+ 03 Aug 2010; Mike Frysinger <vapier@gentoo.org>
+ +crossover-office-pro-bin-9.1.0.ebuild:
+ Version bump #330257 by Michiel de Bruijne.
*crossover-office-pro-bin-9.0.1 (30 Apr 2010)
diff --git a/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-9.1.0.ebuild b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-9.1.0.ebuild
new file mode 100644
index 000000000000..7385f8659cff
--- /dev/null
+++ b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-9.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-9.1.0.ebuild,v 1.1 2010/08/03 05:17:34 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="simplified/streamlined version of wine with commercial support"
+HOMEPAGE="http://www.codeweavers.com/products/cxoffice/"
+SRC_URI="install-crossover-pro-${PV}.sh"
+
+LICENSE="CROSSOVER"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="nas"
+RESTRICT="fetch strip"
+
+RDEPEND="sys-libs/glibc
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ dev-util/desktop-file-utils
+ nas? ( media-libs/nas )
+ amd64? ( app-emulation/emul-linux-x86-xlibs )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ dodir /opt/cxoffice
+ cp -r * "${D}"/opt/cxoffice || die "cp failed"
+ rm -r "${D}"/opt/cxoffice/setup.{sh,data}
+ insinto /opt/cxoffice/etc
+ doins share/crossover/data/cxoffice.conf
+}
+
+pkg_postinst() {
+ elog "Run /opt/cxoffice/bin/cxsetup as normal user to create"
+ elog "bottles and install Windows applications."
+}