summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-15 07:39:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-15 07:39:28 +0000
commitf9887ccbc302068bbf3323810854591bde6de4ac (patch)
tree6ed181b199efc0b7e5f6c954def2db90208cb34b /app-emulation/bochs
parent[This is a placeholder. Please ignore.] (diff)
downloadgentoo-2-f9887ccbc302068bbf3323810854591bde6de4ac.tar.gz
gentoo-2-f9887ccbc302068bbf3323810854591bde6de4ac.tar.bz2
gentoo-2-f9887ccbc302068bbf3323810854591bde6de4ac.zip
[This is a placeholder. Please ignore.]
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/bochs')
-rw-r--r--app-emulation/bochs/ChangeLog10
-rw-r--r--app-emulation/bochs/bochs-2.3.6.ebuild123
-rw-r--r--app-emulation/bochs/bochs-2.3.7.ebuild155
-rw-r--r--app-emulation/bochs/bochs-2.3.ebuild104
-rw-r--r--app-emulation/bochs/files/bochs-2.3-floppy.patch35
-rw-r--r--app-emulation/bochs/files/bochs-2.3-ne2k.patch19
-rw-r--r--app-emulation/bochs/files/bochs-2.3-redog.patch11
-rw-r--r--app-emulation/bochs/files/bochs-2.3.7-gcc43.patch12
-rw-r--r--app-emulation/bochs/files/bochs-2.3.7-typos.patch24
9 files changed, 8 insertions, 485 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index c9a12996a3e6..896ca8bf1183 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/bochs
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.88 2010/09/04 09:22:32 lu_zero Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.89 2011/09/15 07:39:28 ssuominen Exp $
+
+ 15 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> -bochs-2.3.ebuild,
+ -bochs-2.3.6.ebuild, -bochs-2.3.7.ebuild, -files/bochs-2.3.7-gcc43.patch,
+ -files/bochs-2.3.7-typos.patch, -files/bochs-2.3-floppy.patch,
+ -files/bochs-2.3-ne2k.patch, -files/bochs-2.3-redog.patch:
+ [This is a placeholder. Please ignore.]
*bochs-2.4.5 (04 Sep 2010)
diff --git a/app-emulation/bochs/bochs-2.3.6.ebuild b/app-emulation/bochs/bochs-2.3.6.ebuild
deleted file mode 100644
index e8f811eb3a13..000000000000
--- a/app-emulation/bochs/bochs-2.3.6.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.6.ebuild,v 1.6 2010/02/10 06:32:50 dirtyepic Exp $
-
-inherit eutils wxwidgets
-
-DESCRIPTION="a LGPL-ed pc emulator"
-HOMEPAGE="http://bochs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
- http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="X debugger readline usb wxwidgets svga sdl ncurses vnc acpi"
-
-RDEPEND="X? ( x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXpm )
- sdl? ( media-libs/libsdl )
- svga? ( media-libs/svgalib )
- wxwidgets? ( =x11-libs/wxGTK-2.6* )
- readline? ( sys-libs/readline )
- ncurses? ( sys-libs/ncurses )"
-
-DEPEND="${RDEPEND}
- X? ( x11-proto/xproto )
- >=sys-apps/sed-4
- >=app-text/opensp-1.5"
-
-src_unpack() {
- unpack "${P}.tar.gz"
- cd "${S}"
-
- # we already downloaded dlxlinux4.tar.gz so let the Makefile cp it instead
- # of downloading it again
- sed -i \
- -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux4.tar.gz .:" \
- Makefile.in || \
- die "sed Makefile.in failed"
-}
-
-src_compile() {
- WX_GTK_VER=2.6
-
- use wxwidgets && \
- need-wxwidgets ansi
-
- use x86 && \
- myconf="--enable-idle-hack --enable-fast-function-calls"
-
- use amd64 && \
- myconf="--enable-x86-64"
-
- use wxwidgets && \
- myconf="${myconf} --with-wx"
- use wxwidgets || \
- myconf="${myconf} --without-wx"
-
- use vnc && \
- myconf="${myconf} --with-rfb"
-
- use X && \
- myconf="${myconf} --with-x11"
-
- use ncurses && \
- myconf="${myconf} --with-term"
-
- # --enable-all-optimizations causes bus error on sparc :(
- use sparc || \
- myconf="${myconf} --enable-all-optimizations"
-
- econf \
- --prefix=/usr \
- --enable-ne2000 \
- --enable-sb16=linux \
- --enable-plugins \
- --enable-cdrom \
- --enable-pci \
- --enable-mmx \
- --enable-sse=2 \
- --enable-3dnow \
- --enable-cpu-level=6 \
- --with-nogui \
- $(use_enable usb) \
- $(use_enable readline) \
- $(use_enable debugger) \
- $(use_with X) \
- $(use_with sdl) \
- $(use_with svga) \
- $(use_with acpi) \
- ${myconf} || \
- die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install unpack_dlx || die "make install failed"
-
- # workaround
- make prefix="${D}/usr" install_dlx
-
- dodoc \
- CHANGES \
- PARAM_TREE.txt \
- README \
- README-plugins \
- TESTFORM.txt \
- TODO || \
- die "doco failed"
-
- if [ use vnc ]
- then
- dodoc README.rfb || die "dodoc failed"
- fi
-
- if [ use wxwidgets ]
- then
- dodoc README-wxWindows || die "dodoc failed"
- fi
-}
diff --git a/app-emulation/bochs/bochs-2.3.7.ebuild b/app-emulation/bochs/bochs-2.3.7.ebuild
deleted file mode 100644
index 8d1363d1e337..000000000000
--- a/app-emulation/bochs/bochs-2.3.7.ebuild
+++ /dev/null
@@ -1,155 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.7.ebuild,v 1.8 2010/02/10 06:32:50 dirtyepic Exp $
-
-inherit eutils wxwidgets
-
-DESCRIPTION="a LGPL-ed pc emulator"
-HOMEPAGE="http://bochs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
- http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc ~sparc x86"
-IUSE="X debugger readline usb wxwidgets svga sdl ncurses vnc acpi"
-
-RDEPEND="X? ( x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXpm )
- sdl? ( media-libs/libsdl )
- svga? ( media-libs/svgalib )
- wxwidgets? ( =x11-libs/wxGTK-2.6* )
- readline? ( sys-libs/readline )
- ncurses? ( sys-libs/ncurses )"
-
-DEPEND="${RDEPEND}
- X? ( x11-proto/xproto )
- >=sys-apps/sed-4
- >=app-text/opensp-1.5"
-
-src_unpack() {
- unpack "${P}.tar.gz"
- cd "${S}"
-
- epatch "${FILESDIR}/bochs-2.3.7-typos.patch"
- epatch "${FILESDIR}/bochs-2.3.7-gcc43.patch"
-
- # we already downloaded dlxlinux4.tar.gz so let the Makefile cp it instead
- # of downloading it again
- sed -i \
- -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux4.tar.gz .:" \
- Makefile.in || \
- die "sed Makefile.in failed"
-}
-
-src_compile() {
- WX_GTK_VER=2.6
-
- use wxwidgets && \
- need-wxwidgets ansi
-
- use x86 && \
- myconf="--enable-idle-hack --enable-fast-function-calls"
-
- use amd64 && \
- myconf="--enable-x86-64"
-
- use wxwidgets && \
- myconf="${myconf} --with-wx"
- use wxwidgets || \
- myconf="${myconf} --without-wx"
-
- use vnc && \
- myconf="${myconf} --with-rfb"
-
- use X && \
- myconf="${myconf} --with-x11"
-
- use ncurses && \
- myconf="${myconf} --with-term"
-
- # --enable-all-optimizations causes bus error on sparc :(
- use sparc || \
- myconf="${myconf} --enable-all-optimizations"
-
- econf \
- --enable-pae \
- --enable-large-pages \
- --enable-global-pages \
- --enable-mtrr \
- --enable-guest2host-tlb \
- --enable-repeat-speedups \
- --enable-trace-cache \
- --enable-icache \
- --enable-fast-function-calls \
- --enable-ignore-bad-msr \
- --enable-port-e9-hack \
- --enable-disasm \
- --enable-logging \
- --enable-raw-serial \
- --enable-vbe \
- --enable-clgd54xx \
- --enable-fpu \
- --enable-vme \
- --enable-alignment-check \
- --enable-sep \
- --enable-popcnt \
- --enable-monitor-mwait \
- --enable-gameport \
- --enable-iodebug \
- --prefix=/usr \
- --enable-ne2000 \
- --enable-sb16=linux \
- --enable-plugins \
- --enable-cdrom \
- --enable-pci \
- --enable-pcidev \
- --enable-pnic \
- --enable-mmx \
- --enable-sse=2 \
- --enable-3dnow \
- --enable-cpu-level=6 \
- --enable-smp \
- --with-nogui \
- --enable-xsave \
- --enable-aes \
- $(use_enable usb) \
- $(use_enable readline) \
- $(use_enable debugger) \
- $(use_with X) \
- $(use_with sdl) \
- $(use_with svga) \
- $(use_enable acpi) \
- ${myconf} || \
- die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install unpack_dlx || die "make install failed"
-
- # workaround
- make prefix="${D}/usr" install_dlx
-
- dodoc \
- CHANGES \
- PARAM_TREE.txt \
- README \
- README-plugins \
- TESTFORM.txt \
- TODO || \
- die "doco failed"
-
- if [ use vnc ]
- then
- dodoc README.rfb || die "dodoc failed"
- fi
-
- if [ use wxwidgets ]
- then
- dodoc README-wxWindows || die "dodoc failed"
- fi
-}
diff --git a/app-emulation/bochs/bochs-2.3.ebuild b/app-emulation/bochs/bochs-2.3.ebuild
deleted file mode 100644
index 131326699841..000000000000
--- a/app-emulation/bochs/bochs-2.3.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.ebuild,v 1.10 2010/02/10 06:32:50 dirtyepic Exp $
-
-inherit eutils wxwidgets autotools
-
-DESCRIPTION="a LGPL-ed pc emulator"
-HOMEPAGE="http://bochs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
- http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc ~sparc x86"
-IUSE="debugger readline sdl wxwidgets X ncurses vnc"
-
-RDEPEND="X? ( x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXpm )
- sdl? ( media-libs/libsdl )
- wxwidgets? ( =x11-libs/wxGTK-2.6* )
- readline? ( sys-libs/readline )
- ncurses? ( sys-libs/ncurses )"
-
-DEPEND="${RDEPEND}
- X? ( x11-proto/xproto )
- >=sys-apps/sed-4
- >=app-text/opensp-1.5"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd ${S}
- sed -i \
- -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux4.tar.gz .:" \
- -e "s:BOCHSDIR=:BOCHSDIR=/usr/$(get_libdir)/bochs#:" \
- -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in || \
- die "sed Makefile.in failed"
-
-# Make it use the correct path to gtk-2
- sed -i -e "s:/opt/gnome:/usr:" configure
-# Fix some bad coding for gcc-4.1 compliance
- sed -i -e "s:\#ifndef PARANOID:\#if 0:" iodev/hdimage.h
-# wx unicode patches from fedora and bits the fedora missed
-# epatch ${DISTDIR}/${P}-unicode.patch.gz
- epatch ${FILESDIR}/${P}-redog.patch
- epatch ${FILESDIR}/${P}-floppy.patch
- epatch ${FILESDIR}/${P}-ne2k.patch
- eautoconf
-}
-
-src_compile() {
- WX_GTK_VER=2.6
-
- use wxwidgets && \
- need-wxwidgets ansi
-
- [[ "$ARCH" == "x86" ]] \
- && myconf="--enable-idle-hack --enable-fast-function-calls"
- myconf="${myconf} `use_with sdl`"
- myconf="${myconf} `use_enable readline`"
- use wxwidgets && \
- myconf="${myconf} --with-wx"
- use wxwidgets || \
- myconf="${myconf} --without-wx"
- use debugger && \
- myconf="$myconf --enable-debugger --enable-disasm \
- --enable-x86-debugger --enable-iodebug"
- use debugger || \
- myconf="$myconf --enable-gdb-stub"
- use vnc && \
- myconf="$myconf --with-rfb"
-
- use X && \
- myconf="$myconf --with-x11"
-
- use ncurses && \
- myconf="$myconf --with-term"
-
- if ! use X && ! use ncurses && ! use vnc && ! use sdl
- then
- myconf="$myconf --with-nogui"
- fi
-
- ./configure \
- --enable-usb --enable-pci --enable-vbe \
- --enable-sse=2 --enable-3dnow --enable-plugins \
- --enable-cpu-level=6 --enable-all-optimizations \
- --enable-ne2000 --enable-sb16=linux --enable-clgd54xx \
- --enable-apic --enable-compressed-hd \
- --enable-pni --enable-sep --host=${CHOST} \
- --libdir=/usr/$(get_libdir) --prefix=/usr \
- ${myconf} || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR=${D} install unpack_dlx || die "make install failed"
- #workaround
- make prefix=${D}/usr install_dlx
-
- dodoc CHANGES README TESTFORM.txt || die "dodoc failed"
-}
diff --git a/app-emulation/bochs/files/bochs-2.3-floppy.patch b/app-emulation/bochs/files/bochs-2.3-floppy.patch
deleted file mode 100644
index 0e0ae6a9d924..000000000000
--- a/app-emulation/bochs/files/bochs-2.3-floppy.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Index: iodev/floppy.cc
-===================================================================
-RCS file: /cvsroot/bochs/bochs/iodev/floppy.cc,v
-retrieving revision 1.106
-retrieving revision 1.107
-diff -u -p -r1.106 -r1.107
---- iodev/floppy.cc 6 Apr 2007 15:22:17 -0000 1.106
-+++ iodev/floppy.cc 21 Aug 2007 14:18:16 -0000 1.107
-@@ -1785,7 +1785,7 @@ bx_bool bx_floppy_ctrl_c::evaluate_media
- }
- media->sectors = media->heads * media->tracks * media->sectors_per_track;
- }
-- return(1); // success
-+ return (media->sectors > 0); // success
- }
-
- else if ( S_ISCHR(stat_buf.st_mode)
-@@ -1805,7 +1805,7 @@ bx_bool bx_floppy_ctrl_c::evaluate_media
- media->heads = floppy_type[type_idx].hd;
- media->sectors_per_track = floppy_type[type_idx].spt;
- media->sectors = floppy_type[type_idx].sectors;
-- return 1;
-+ return (media->sectors > 0);
- }
- media->tracks = floppy_geom.track;
- media->heads = floppy_geom.head;
-@@ -1822,7 +1822,7 @@ bx_bool bx_floppy_ctrl_c::evaluate_media
- media->sectors_per_track = floppy_type[type_idx].spt;
- media->sectors = floppy_type[type_idx].sectors;
- #endif
-- return 1; // success
-+ return (media->sectors > 0); // success
- } else {
- // unknown file type
- BX_ERROR(("unknown mode type"));
diff --git a/app-emulation/bochs/files/bochs-2.3-ne2k.patch b/app-emulation/bochs/files/bochs-2.3-ne2k.patch
deleted file mode 100644
index 558cf636a8f7..000000000000
--- a/app-emulation/bochs/files/bochs-2.3-ne2k.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Index: iodev/ne2k.cc
-===================================================================
-RCS file: /cvsroot/bochs/bochs/iodev/ne2k.cc,v
-retrieving revision 1.91
-retrieving revision 1.92
-diff -u -p -r1.91 -r1.92
---- iodev/ne2k.cc 3 Feb 2007 17:56:35 -0000 1.91
-+++ iodev/ne2k.cc 10 Mar 2007 15:17:31 -0000 1.92
-@@ -1278,8 +1278,8 @@ void bx_ne2k_c::rx_handler(void *arg, co
- */
- void bx_ne2k_c::rx_frame(const void *buf, unsigned io_len)
- {
-- unsigned pages;
-- unsigned avail;
-+ int pages;
-+ int avail;
- unsigned idx;
- int wrapped;
- int nextpage;
diff --git a/app-emulation/bochs/files/bochs-2.3-redog.patch b/app-emulation/bochs/files/bochs-2.3-redog.patch
deleted file mode 100644
index e1bdb3bf4d17..000000000000
--- a/app-emulation/bochs/files/bochs-2.3-redog.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- bochs-2.3.orig/iodev/hdimage.cc 2006-09-17 02:28:23.000000000 +0300
-+++ bochs-2.3/iodev/hdimage.cc 2006-09-17 02:28:53.000000000 +0300
-@@ -1586,7 +1586,7 @@
- sprintf (logname, "%s%s", pathname, UNDOABLE_REDOLOG_EXTENSION);
- }
-
-- if (redolog->open(logname,REDOLOG_SUBTYPE_UNDOABLE,size) < 0)
-+ if (redolog->open(logname, REDOLOG_SUBTYPE_UNDOABLE) < 0)
- {
- if (redolog->create(logname, REDOLOG_SUBTYPE_UNDOABLE, size) < 0)
- {
diff --git a/app-emulation/bochs/files/bochs-2.3.7-gcc43.patch b/app-emulation/bochs/files/bochs-2.3.7-gcc43.patch
deleted file mode 100644
index 4646edf6762e..000000000000
--- a/app-emulation/bochs/files/bochs-2.3.7-gcc43.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- bochs-2.3.7.orig/bx_debug/symbols.cc 2008/03/30 14:32:14 1.11
-+++ bochs-2.3.7/bx_debug/symbols.cc 2008/06/16 17:09:52 1.12
-@@ -95,6 +95,9 @@
- #endif
-
- using namespace std;
-+#ifdef __GNUC__
-+using namespace __gnu_cxx;
-+#endif
-
- struct symbol_entry_t
- {
diff --git a/app-emulation/bochs/files/bochs-2.3.7-typos.patch b/app-emulation/bochs/files/bochs-2.3.7-typos.patch
deleted file mode 100644
index c9fb168e438b..000000000000
--- a/app-emulation/bochs/files/bochs-2.3.7-typos.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -NaurwB bochs-2.3.7.orig/cpu/ia_opcodes.h bochs-2.3.7/cpu/ia_opcodes.h
---- bochs-2.3.7.orig/cpu/ia_opcodes.h 2008-05-30 22:35:08.000000000 +0200
-+++ bochs-2.3.7/cpu/ia_opcodes.h 2008-06-04 14:56:46.000000000 +0200
-@@ -891,7 +891,7 @@
- bx_define_opcode(BX_IA_PF2ID_PqQq, BX_CPU_C::PF2ID_PqQq)
- bx_define_opcode(BX_IA_PF2IW_PqQq, BX_CPU_C::PF2IW_PqQq)
- bx_define_opcode(BX_IA_PFACC_PqQq, BX_CPU_C::PFACC_PqQq)
--bx_define_opcode(BX_IA_PFADD_PqQq, BX_CPU_C::BX_PFADD_PqQq)
-+bx_define_opcode(BX_IA_PFADD_PqQq, BX_CPU_C::PFADD_PqQq)
- bx_define_opcode(BX_IA_PFCMPEQ_PqQq, BX_CPU_C::PFCMPEQ_PqQq)
- bx_define_opcode(BX_IA_PFCMPGE_PqQq, BX_CPU_C::PFCMPGE_PqQq)
- bx_define_opcode(BX_IA_PFCMPGT_PqQq, BX_CPU_C::PFCMPGT_PqQq)
-diff -NaurwB bochs-2.3.7.orig/iodev/iodebug.h bochs-2.3.7/iodev/iodebug.h
---- bochs-2.3.7.orig/iodev/iodebug.h 2008-05-01 22:46:58.000000000 +0200
-+++ bochs-2.3.7/iodev/iodebug.h 2008-06-04 14:45:50.000000000 +0200
-@@ -18,7 +18,7 @@
- virtual void init(void);
- virtual void reset (unsigned type) {}
- static void mem_write(BX_CPU_C *cpu, bx_phy_address addr, unsigned len, void *data);
-- static void mem_read(BX_CPU_C *cpu, bx_phy_addressu addr, unsigned len, void *data);
-+ static void mem_read(BX_CPU_C *cpu, bx_phy_address addr, unsigned len, void *data);
-
- private:
- static Bit32u read_handler(void *this_ptr, Bit32u address, unsigned io_len);