summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2009-07-10 20:01:44 +0000
committerLuca Barbato <lu_zero@gentoo.org>2009-07-10 20:01:44 +0000
commitca459a73bc989cc4c8107a6bfeae10456917b407 (patch)
tree212e3185e2b0c753394e7a280e8d3f8e0ae44d22 /app-emulation/bochs
parentVersion bump. (diff)
downloadgentoo-2-ca459a73bc989cc4c8107a6bfeae10456917b407.tar.gz
gentoo-2-ca459a73bc989cc4c8107a6bfeae10456917b407.tar.bz2
gentoo-2-ca459a73bc989cc4c8107a6bfeae10456917b407.zip
New version
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/bochs')
-rw-r--r--app-emulation/bochs/ChangeLog7
-rw-r--r--app-emulation/bochs/bochs-2.4.1.ebuild154
2 files changed, 160 insertions, 1 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index d5201f6ef085..5f03ba98b8b3 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/bochs
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.83 2009/02/25 13:01:29 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.84 2009/07/10 20:01:44 lu_zero Exp $
+
+*bochs-2.4.1 (10 Jul 2009)
+
+ 10 Jul 2009; Luca Barbato <lu_zero@gentoo.org> +bochs-2.4.1.ebuild:
+ New version
25 Feb 2009; Joseph Jezak <josejx@gentoo.org> bochs-2.3.7.ebuild:
Marked ppc stable for bug #245554.
diff --git a/app-emulation/bochs/bochs-2.4.1.ebuild b/app-emulation/bochs/bochs-2.4.1.ebuild
new file mode 100644
index 000000000000..eb772fd32074
--- /dev/null
+++ b/app-emulation/bochs/bochs-2.4.1.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.4.1.ebuild,v 1.1 2009/07/10 20:01:44 lu_zero Exp $
+
+inherit eutils wxwidgets autotools
+
+DESCRIPTION="a LGPL-ed pc emulator"
+HOMEPAGE="http://bochs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
+ http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="X debugger readline usb wxwindows svga sdl ncurses vnc acpi"
+
+RDEPEND="virtual/libc
+ X? ( x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm )
+ sdl? ( media-libs/libsdl )
+ svga? ( media-libs/svgalib )
+ wxwindows? ( =x11-libs/wxGTK-2.6* )
+ readline? ( sys-libs/readline )
+ ncurses? ( sys-libs/ncurses )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )
+ >=sys-apps/sed-4
+ >=app-text/opensp-1.5"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ cd "${S}"
+
+ # we already downloaded dlxlinux4.tar.gz so let the Makefile cp it instead
+ # of downloading it again
+ sed -i \
+ -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux4.tar.gz .:" \
+ Makefile.in || \
+ die "sed Makefile.in failed"
+
+ # Make sure wxwindows 2.6 is used in case both 2.6 and 2.4 are installed
+ sed -i -e "s:wx-config:wx-config-2.6:" configure.in
+ eautoconf
+}
+
+src_compile() {
+ export WX_GTK_VER=2.6
+
+ use wxwindows && \
+ need-wxwidgets gtk2
+
+ use x86 && \
+ myconf="--enable-idle-hack --enable-fast-function-calls"
+
+ use amd64 && \
+ myconf="--enable-x86-64"
+
+ use wxwindows && \
+ myconf="${myconf} --with-wx"
+ use wxwindows || \
+ myconf="${myconf} --without-wx"
+
+ use vnc && \
+ myconf="${myconf} --with-rfb"
+
+ use X && \
+ myconf="${myconf} --with-x11"
+
+ use ncurses && \
+ myconf="${myconf} --with-term"
+
+ # --enable-all-optimizations causes bus error on sparc :(
+ use sparc || \
+ myconf="${myconf} --enable-all-optimizations"
+
+ econf \
+ --enable-pae \
+ --enable-large-pages \
+ --enable-global-pages \
+ --enable-mtrr \
+ --enable-repeat-speedups \
+ --enable-trace-cache \
+ --enable-fast-function-calls \
+ --enable-ignore-bad-msr \
+ --enable-disasm \
+ --enable-logging \
+ --enable-raw-serial \
+ --enable-vbe \
+ --enable-clgd54xx \
+ --enable-fpu \
+ --enable-vme \
+ --enable-alignment-check \
+ --enable-sep \
+ --enable-popcnt \
+ --enable-monitor-mwait \
+ --enable-gameport \
+ --enable-iodebug \
+ --prefix=/usr \
+ --enable-ne2000 \
+ --enable-sb16=linux \
+ --enable-plugins \
+ --enable-cdrom \
+ --enable-pci \
+ --enable-pcidev \
+ --enable-pnic \
+ --enable-mmx \
+ --enable-sse=2 \
+ --enable-3dnow \
+ --enable-cpu-level=6 \
+ --enable-smp \
+ --with-nogui \
+ --enable-xsave \
+ --enable-aes \
+ $(use_enable usb) \
+ $(use_enable readline) \
+ $(use_enable debugger) \
+ $(use_with X) \
+ $(use_with sdl) \
+ $(use_with svga) \
+ $(use_enable acpi) \
+ ${myconf} || \
+ die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install unpack_dlx || die "make install failed"
+
+ # workaround
+ make prefix="${D}/usr" install_dlx
+
+ dodoc \
+ CHANGES \
+ PARAM_TREE.txt \
+ README \
+ README-plugins \
+ TESTFORM.txt \
+ TODO || \
+ die "doco failed"
+
+ if [ use vnc ]
+ then
+ dodoc README.rfb || die "dodoc failed"
+ fi
+
+ if [ use wxwindows ]
+ then
+ dodoc README-wxWindows || die "dodoc failed"
+ fi
+}