summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2008-06-05 02:22:52 +0000
committerLuca Barbato <lu_zero@gentoo.org>2008-06-05 02:22:52 +0000
commit8267d64fefa89de1cc92cdaf0f61a37717e312e0 (patch)
tree57e68c341b7a0579c3f0ce741852d6c06d384633 /app-emulation/bochs
parent2.1.5.4 bump. This fixes bug #224713 (unhandled TypeError exception (diff)
downloadgentoo-2-8267d64fefa89de1cc92cdaf0f61a37717e312e0.tar.gz
gentoo-2-8267d64fefa89de1cc92cdaf0f61a37717e312e0.tar.bz2
gentoo-2-8267d64fefa89de1cc92cdaf0f61a37717e312e0.zip
New version, thanks to mastamind@users.sourceforge.net for proposing an ebuild on bug #224885
(Portage version: 2.1.5.3)
Diffstat (limited to 'app-emulation/bochs')
-rw-r--r--app-emulation/bochs/ChangeLog9
-rw-r--r--app-emulation/bochs/bochs-2.3.6.ebuild8
-rw-r--r--app-emulation/bochs/bochs-2.3.7.ebuild159
-rw-r--r--app-emulation/bochs/files/bochs-2.3.7-typos.patch24
4 files changed, 193 insertions, 7 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index 7b39c4a9784f..ddd0a729e58d 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/bochs
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.75 2008/03/31 12:54:20 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.76 2008/06/05 02:22:51 lu_zero Exp $
+
+*bochs-2.3.7 (05 Jun 2008)
+
+ 05 Jun 2008; Luca Barbato <lu_zero@gentoo.org>
+ +files/bochs-2.3.7-typos.patch, bochs-2.3.6.ebuild, +bochs-2.3.7.ebuild:
+ New version, thanks to mastamind@users.sourceforge.net for proposing an
+ ebuild on bug #224885
31 Mar 2008; Luca Barbato <lu_zero@gentoo.org> bochs-2.3.6.ebuild:
Update ebuild, remove wrongly used flags
diff --git a/app-emulation/bochs/bochs-2.3.6.ebuild b/app-emulation/bochs/bochs-2.3.6.ebuild
index b25536111c77..9947f43cfe96 100644
--- a/app-emulation/bochs/bochs-2.3.6.ebuild
+++ b/app-emulation/bochs/bochs-2.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.6.ebuild,v 1.2 2008/03/31 12:54:20 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.6.ebuild,v 1.3 2008/06/05 02:22:51 lu_zero Exp $
inherit eutils wxwidgets autotools
@@ -72,11 +72,6 @@ src_compile() {
use ncurses && \
myconf="${myconf} --with-term"
- if ! use X && ! use ncurses && ! use vnc && ! use sdl
- then
- myconf="${myconf} --with-nogui"
- fi
-
# --enable-all-optimizations causes bus error on sparc :(
use sparc || \
myconf="${myconf} --enable-all-optimizations"
@@ -92,6 +87,7 @@ src_compile() {
--enable-sse=2 \
--enable-3dnow \
--enable-cpu-level=6 \
+ --with-nogui \
$(use_enable usb) \
$(use_enable readline) \
$(use_enable debugger) \
diff --git a/app-emulation/bochs/bochs-2.3.7.ebuild b/app-emulation/bochs/bochs-2.3.7.ebuild
new file mode 100644
index 000000000000..59db59de42c7
--- /dev/null
+++ b/app-emulation/bochs/bochs-2.3.7.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.3.7.ebuild,v 1.1 2008/06/05 02:22:51 lu_zero Exp $
+
+inherit eutils wxwidgets autotools
+
+DESCRIPTION="a LGPL-ed pc emulator"
+HOMEPAGE="http://bochs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
+ http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="X debugger readline usb wxwindows svga sdl ncurses vnc acpi"
+
+RDEPEND="virtual/libc
+ X? ( x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm )
+ sdl? ( media-libs/libsdl )
+ svga? ( media-libs/svgalib )
+ wxwindows? ( =x11-libs/wxGTK-2.6* )
+ readline? ( sys-libs/readline )
+ ncurses? ( sys-libs/ncurses )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )
+ >=sys-apps/sed-4
+ >=app-text/opensp-1.5"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ cd "${S}"
+
+ epatch "${FILESDIR}/bochs-2.3.7-typos.patch"
+
+ # we already downloaded dlxlinux4.tar.gz so let the Makefile cp it instead
+ # of downloading it again
+ sed -i \
+ -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux4.tar.gz .:" \
+ Makefile.in || \
+ die "sed Makefile.in failed"
+
+ # Make sure wxwindows 2.6 is used in case both 2.6 and 2.4 are installed
+ sed -i -e "s:wx-config:wx-config-2.6:" configure.in
+ eautoconf
+}
+
+src_compile() {
+ export WX_GTK_VER=2.6
+
+ use wxwindows && \
+ need-wxwidgets gtk2
+
+ use x86 && \
+ myconf="--enable-idle-hack --enable-fast-function-calls"
+
+ use amd64 && \
+ myconf="--enable-x86-64"
+
+ use wxwindows && \
+ myconf="${myconf} --with-wx"
+ use wxwindows || \
+ myconf="${myconf} --without-wx"
+
+ use vnc && \
+ myconf="${myconf} --with-rfb"
+
+ use X && \
+ myconf="${myconf} --with-x11"
+
+ use ncurses && \
+ myconf="${myconf} --with-term"
+
+ # --enable-all-optimizations causes bus error on sparc :(
+ use sparc || \
+ myconf="${myconf} --enable-all-optimizations"
+
+ econf \
+ --enable-pae \
+ --enable-large-pages \
+ --enable-global-pages \
+ --enable-mtrr \
+ --enable-guest2host-tlb \
+ --enable-repeat-speedups \
+ --enable-trace-cache \
+ --enable-icache \
+ --enable-fast-function-calls \
+ --enable-ignore-bad-msr \
+ --enable-port-e9-hack \
+ --enable-disasm \
+ --enable-logging \
+ --enable-raw-serial \
+ --enable-vbe \
+ --enable-clgd54xx \
+ --enable-fpu \
+ --enable-vme \
+ --enable-alignment-check \
+ --enable-sep \
+ --enable-popcnt \
+ --enable-monitor-mwait \
+ --enable-gameport \
+ --enable-iodebug \
+ --prefix=/usr \
+ --enable-ne2000 \
+ --enable-sb16=linux \
+ --enable-plugins \
+ --enable-cdrom \
+ --enable-pci \
+ --enable-pcidev \
+ --enable-pnic \
+ --enable-mmx \
+ --enable-sse=2 \
+ --enable-3dnow \
+ --enable-cpu-level=6 \
+ --enable-smp \
+ --with-nogui \
+ --enable-xsave \
+ --enable-aes \
+ $(use_enable usb) \
+ $(use_enable readline) \
+ $(use_enable debugger) \
+ $(use_with X) \
+ $(use_with sdl) \
+ $(use_with svga) \
+ $(use_enable acpi) \
+ ${myconf} || \
+ die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install unpack_dlx || die "make install failed"
+
+ # workaround
+ make prefix="${D}/usr" install_dlx
+
+ dodoc \
+ CHANGES \
+ PARAM_TREE.txt \
+ README \
+ README-plugins \
+ TESTFORM.txt \
+ TODO || \
+ die "doco failed"
+
+ if [ use vnc ]
+ then
+ dodoc README.rfb || die "dodoc failed"
+ fi
+
+ if [ use wxwindows ]
+ then
+ dodoc README-wxWindows || die "dodoc failed"
+ fi
+}
diff --git a/app-emulation/bochs/files/bochs-2.3.7-typos.patch b/app-emulation/bochs/files/bochs-2.3.7-typos.patch
new file mode 100644
index 000000000000..c9fb168e438b
--- /dev/null
+++ b/app-emulation/bochs/files/bochs-2.3.7-typos.patch
@@ -0,0 +1,24 @@
+diff -NaurwB bochs-2.3.7.orig/cpu/ia_opcodes.h bochs-2.3.7/cpu/ia_opcodes.h
+--- bochs-2.3.7.orig/cpu/ia_opcodes.h 2008-05-30 22:35:08.000000000 +0200
++++ bochs-2.3.7/cpu/ia_opcodes.h 2008-06-04 14:56:46.000000000 +0200
+@@ -891,7 +891,7 @@
+ bx_define_opcode(BX_IA_PF2ID_PqQq, BX_CPU_C::PF2ID_PqQq)
+ bx_define_opcode(BX_IA_PF2IW_PqQq, BX_CPU_C::PF2IW_PqQq)
+ bx_define_opcode(BX_IA_PFACC_PqQq, BX_CPU_C::PFACC_PqQq)
+-bx_define_opcode(BX_IA_PFADD_PqQq, BX_CPU_C::BX_PFADD_PqQq)
++bx_define_opcode(BX_IA_PFADD_PqQq, BX_CPU_C::PFADD_PqQq)
+ bx_define_opcode(BX_IA_PFCMPEQ_PqQq, BX_CPU_C::PFCMPEQ_PqQq)
+ bx_define_opcode(BX_IA_PFCMPGE_PqQq, BX_CPU_C::PFCMPGE_PqQq)
+ bx_define_opcode(BX_IA_PFCMPGT_PqQq, BX_CPU_C::PFCMPGT_PqQq)
+diff -NaurwB bochs-2.3.7.orig/iodev/iodebug.h bochs-2.3.7/iodev/iodebug.h
+--- bochs-2.3.7.orig/iodev/iodebug.h 2008-05-01 22:46:58.000000000 +0200
++++ bochs-2.3.7/iodev/iodebug.h 2008-06-04 14:45:50.000000000 +0200
+@@ -18,7 +18,7 @@
+ virtual void init(void);
+ virtual void reset (unsigned type) {}
+ static void mem_write(BX_CPU_C *cpu, bx_phy_address addr, unsigned len, void *data);
+- static void mem_read(BX_CPU_C *cpu, bx_phy_addressu addr, unsigned len, void *data);
++ static void mem_read(BX_CPU_C *cpu, bx_phy_address addr, unsigned len, void *data);
+
+ private:
+ static Bit32u read_handler(void *this_ptr, Bit32u address, unsigned io_len);