summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2004-01-05 04:47:11 +0000
committerLuca Barbato <lu_zero@gentoo.org>2004-01-05 04:47:11 +0000
commit2e25f8c144b49bd4db06a3c65129da3fea380914 (patch)
tree398d07b03cbd0acaf347ef09a4151bc3874b4788 /app-emulation/bochs
parentremove old version as they are broken and require too much effort to fix manu... (diff)
downloadgentoo-2-2e25f8c144b49bd4db06a3c65129da3fea380914.tar.gz
gentoo-2-2e25f8c144b49bd4db06a3c65129da3fea380914.tar.bz2
gentoo-2-2e25f8c144b49bd4db06a3c65129da3fea380914.zip
Fix
Diffstat (limited to 'app-emulation/bochs')
-rw-r--r--app-emulation/bochs/ChangeLog5
-rw-r--r--app-emulation/bochs/bochs-2.0.2.ebuild30
2 files changed, 27 insertions, 8 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index 03c4da85a259..47e6057c1ec2 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/bochs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.16 2003/12/24 19:03:46 bazik Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.17 2004/01/05 04:47:11 lu_zero Exp $
+
+ 05 Jan 2004; Luca Barbato <lu_zero@gentoo.org> bochs-2.0.2.ebuild:
+ Fix for bug #36662, thanks to Andrew Kirilenko for the font setup idea.
24 Dec 2003; Sven Blumenstein <bazik@gentoo.org> bochs-2.0.2.ebuild:
Added ~sparc keyword.
diff --git a/app-emulation/bochs/bochs-2.0.2.ebuild b/app-emulation/bochs/bochs-2.0.2.ebuild
index 83395a23fd3e..fa85458f7725 100644
--- a/app-emulation/bochs/bochs-2.0.2.ebuild
+++ b/app-emulation/bochs/bochs-2.0.2.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.2.ebuild,v 1.9 2003/12/24 19:03:46 bazik Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.2.ebuild,v 1.10 2004/01/05 04:47:11 lu_zero Exp $
inherit eutils
DESCRIPTION="a LGPL-ed pc emulator"
HOMEPAGE="http://bochs.sourceforge.net/"
SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
- http://bochs.sourceforge.net/guestos/dlxlinux3.tar.gz"
+ http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -21,11 +21,12 @@ DEPEND=">=sys-libs/glibc-2.1.3
gtk? x11-libs/wxGTK"
src_unpack() {
- unpack ${P}.tar.gz
+ unpack ${A}
+# unpack ${P}.tar.gz
cd ${S}
-
+# -e 's:MAN_PAGE_1_LIST=bochs bximage bochs-dlx:MAN_PAGE_1_LIST=bochs bximage:'
sed -i \
- -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
+ -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux4.tar.gz .:" \
-e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
-e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in || \
die "sed Makefile.in failed"
@@ -48,6 +49,21 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR=${D} install unpack_dlx || die "make install failed"
+ #workaround
+ make prefix=${D}/usr install_dlx
+ #cleanup
+ rm -rf ${D}/usr/share/bochs/{vga.pcf,install-x11-fonts,test-x11-fonts}
+ rm -rf ${D}/usr/share/bochs/keymaps/CVS
+ insinto /usr/X11R6/lib/X11/fonts/misc
+ doins ${S}/font/vga.pcf
+ gzip ${D}/usr/X11R6/lib/X11/fonts/misc/vga.pcf
dodoc CHANGES CVS README TESTFORM.txt || die "dodoc failed"
}
+
+pkg_postinst() {
+ einfo "Updating the font index"
+ mkfontdir /usr/X11R6/lib/X11/fonts/misc
+ einfo "If you are running X please update the fontlist with:"
+ einfo "# xset fp rehash"
+}