summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-02-21 11:21:51 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-02-21 11:21:51 +0000
commit9254a647f3d47662f5c4a9d2f692733045190870 (patch)
tree6f0dca993b2c0562145562eda05fee388c559ccd /app-emulation/aqemu
parentVersion bump. (diff)
downloadgentoo-2-9254a647f3d47662f5c4a9d2f692733045190870.tar.gz
gentoo-2-9254a647f3d47662f5c4a9d2f692733045190870.tar.bz2
gentoo-2-9254a647f3d47662f5c4a9d2f692733045190870.zip
Revbump to 0.8.2-r2, fix bug 405117
(Portage version: 2.1.10.48/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/aqemu')
-rw-r--r--app-emulation/aqemu/ChangeLog8
-rw-r--r--app-emulation/aqemu/aqemu-0.8.2-r2.ebuild40
-rw-r--r--app-emulation/aqemu/files/aqemu-0.8.2_desktop_file.patch33
-rw-r--r--app-emulation/aqemu/files/aqemu-0.8.2_qt48_build.patch27
4 files changed, 107 insertions, 1 deletions
diff --git a/app-emulation/aqemu/ChangeLog b/app-emulation/aqemu/ChangeLog
index 961911621921..332ed7c53c14 100644
--- a/app-emulation/aqemu/ChangeLog
+++ b/app-emulation/aqemu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/aqemu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aqemu/ChangeLog,v 1.10 2012/02/19 10:31:59 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aqemu/ChangeLog,v 1.11 2012/02/21 11:21:51 maksbotan Exp $
+
+*aqemu-0.8.2-r2 (21 Feb 2012)
+
+ 21 Feb 2012; Maxim Koltsov <maksbotan@gentoo.org> +aqemu-0.8.2-r2.ebuild,
+ +files/aqemu-0.8.2_desktop_file.patch, +files/aqemu-0.8.2_qt48_build.patch:
+ Revbump to 0.8.2-r2, fix bug 405117
19 Feb 2012; Agostino Sarubbo <ago@gentoo.org> aqemu-0.8.2-r1.ebuild:
Stable for amd64, wrt bug #404483
diff --git a/app-emulation/aqemu/aqemu-0.8.2-r2.ebuild b/app-emulation/aqemu/aqemu-0.8.2-r2.ebuild
new file mode 100644
index 000000000000..c05d7b42c463
--- /dev/null
+++ b/app-emulation/aqemu/aqemu-0.8.2-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aqemu/aqemu-0.8.2-r2.ebuild,v 1.1 2012/02/21 11:21:51 maksbotan Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Graphical interface for QEMU and KVM emulators. Using Qt4."
+HOMEPAGE="http://sourceforge.net/projects/aqemu"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kvm vnc"
+
+DEPEND="${RDEPEND}"
+RDEPEND="kvm? ( app-emulation/qemu-kvm )
+ !kvm? ( >=app-emulation/qemu-0.9.0 )
+ vnc? ( net-libs/libvncserver )
+ x11-libs/qt-gui:4
+ x11-libs/qt-test:4
+ x11-libs/qt-xmlpatterns:4"
+
+DOCS="AUTHORS CHANGELOG README TODO"
+PATCHES=( "${FILESDIR}"/aqemu-0.8.2_sigsev_propertis.patch
+"${FILESDIR}"/aqemu-0.8.2_qt48_build.patch
+"${FILESDIR}"/aqemu-0.8.2_desktop_file.patch )
+
+src_configure() {
+ local mycmakeargs=" -DMAN_PAGE_COMPRESSOR="" "
+ if use vnc; then
+ mycmakeargs+=" -DWITHOUT_EMBEDDED_DISPLAY=OFF "
+ else
+ mycmakeargs+=" -DWITHOUT_EMBEDDED_DISPLAY=ON "
+ fi
+
+ cmake-utils_src_configure
+}
diff --git a/app-emulation/aqemu/files/aqemu-0.8.2_desktop_file.patch b/app-emulation/aqemu/files/aqemu-0.8.2_desktop_file.patch
new file mode 100644
index 000000000000..4cf20ea578d0
--- /dev/null
+++ b/app-emulation/aqemu/files/aqemu-0.8.2_desktop_file.patch
@@ -0,0 +1,33 @@
+From 2a0f32e8cb46c8a1c0a33ed151737e5abb5679ed Mon Sep 17 00:00:00 2001
+From: Andrey Rijov <rdron@users.sourceforge.net>
+Date: Mon, 31 Oct 2011 19:38:17 +0400
+Subject: [PATCH] Updated aqemu.desktop file (See bug: 3430317)
+
+---
+ menu_data/aqemu.desktop | 9 +++++----
+ 1 files changed, 5 insertions(+), 4 deletions(-)
+
+--- a/menu_data/aqemu.desktop
++++ b/menu_data/aqemu.desktop
+@@ -1,14 +1,15 @@
+ [Desktop Entry]
+ Encoding=UTF-8
+-Name=AQEMU
+ Exec=aqemu
+ Terminal=false
+ Type=Application
+-Icon=aqemu_48x48.png
++Icon=aqemu_48x48
+ StartupNotify=true
+ Categories=System;Emulator;
+
+-Name[ru]=AQEMU
++Name=AQEMU
++Comment=Virtual machine manager
+ Name[en]=AQEMU
+-Comment[ru]=Управление виртуальными машинами
+ Comment[en]=Virtual machine manager
++Name[ru]=AQEMU
++Comment[ru]=Управление виртуальными машинами
+--
+1.7.4.1
diff --git a/app-emulation/aqemu/files/aqemu-0.8.2_qt48_build.patch b/app-emulation/aqemu/files/aqemu-0.8.2_qt48_build.patch
new file mode 100644
index 000000000000..afd1f0c853d4
--- /dev/null
+++ b/app-emulation/aqemu/files/aqemu-0.8.2_qt48_build.patch
@@ -0,0 +1,27 @@
+From 9b21d88a4f4a681f9e80c11e83e81c976e0fc91e Mon Sep 17 00:00:00 2001
+From: Andrey Rijov <rdron@users.sourceforge.net>
+Date: Sat, 29 Oct 2011 10:20:32 +0400
+Subject: [PATCH 1/1] Fix build error on Qt 4.8
+
+---
+ Embedded_Display/vncview.cpp | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Embedded_Display/vncview.cpp b/Embedded_Display/vncview.cpp
+index 9e105c9..0be5944 100644
+--- a/Embedded_Display/vncview.cpp
++++ b/Embedded_Display/vncview.cpp
+@@ -27,8 +27,8 @@
+ #include <QMessageBox>
+ #include <QInputDialog>
+ #define KMessageBox QMessageBox
+- #define error(parent, message, caption) \
+- critical(parent, caption, message)
++/* #define error(parent, message, caption) \
++ critical(parent, caption, message)*/
+ #else
+ #include "settings.h"
+ #include <KActionCollection>
+--
+1.7.4.1
+