summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-12-03 04:32:37 +0000
committerMamoru Komachi <usata@gentoo.org>2004-12-03 04:32:37 +0000
commitd17b6a663aef8ce6ef1e46deed24592afc9231aa (patch)
tree158bf7e792296200bb2d3aa92e8a75afc7c64a14 /app-emacs
parentputting the profile on a diet (diff)
downloadgentoo-2-d17b6a663aef8ce6ef1e46deed24592afc9231aa.tar.gz
gentoo-2-d17b6a663aef8ce6ef1e46deed24592afc9231aa.tar.bz2
gentoo-2-d17b6a663aef8ce6ef1e46deed24592afc9231aa.zip
Fixed pycomplete.py. Thanks to Nick Savchenko <rust@voliacable.com>; bug #72712.
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/python-mode/ChangeLog9
-rw-r--r--app-emacs/python-mode/Manifest13
-rw-r--r--app-emacs/python-mode/files/55python-mode-gentoo.el13
-rw-r--r--app-emacs/python-mode/files/digest-python-mode-4.63-r11
-rw-r--r--app-emacs/python-mode/python-mode-4.63-r1.ebuild34
5 files changed, 59 insertions, 11 deletions
diff --git a/app-emacs/python-mode/ChangeLog b/app-emacs/python-mode/ChangeLog
index 66e5a67475e9..4d6ceabd159a 100644
--- a/app-emacs/python-mode/ChangeLog
+++ b/app-emacs/python-mode/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/python-mode
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.7 2004/11/11 10:29:46 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.8 2004/12/03 04:32:37 usata Exp $
+
+*python-mode-4.63-r1 (03 Dec 2004)
+
+ 03 Dec 2004; Mamoru KOMACHI <usata@gentoo.org>
+ +files/55python-mode-gentoo.el, +python-mode-4.63-r1.ebuild:
+ Fixed pycomplete.py. Thanks to Nick Savchenko <rust@voliacable.com>;
+ bug #72712.
*python-mode-4.63 (11 Nov 2004)
diff --git a/app-emacs/python-mode/Manifest b/app-emacs/python-mode/Manifest
index 1338126d3858..1e524a1966b2 100644
--- a/app-emacs/python-mode/Manifest
+++ b/app-emacs/python-mode/Manifest
@@ -1,17 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 20c82f87ad30929a1a8eb07d7a86144a ChangeLog 878
MD5 fcd33d07e4ee719b01157946734f4fe8 metadata.xml 158
MD5 5ec0d617968fa3436913945c7713994f python-mode-4.6.ebuild 772
MD5 aeabbb29eeb625fcf53e425bad1a6a76 python-mode-4.63.ebuild 780
+MD5 6a0c8ffbf129389bfa9ffffb12b5c21b python-mode-4.63-r1.ebuild 867
MD5 b16866ae5b915c74ccb69ff8591a4ada files/50python-mode-gentoo.el 334
MD5 7842a604f7fbeda6be9d9b86f6d143bb files/digest-python-mode-4.6 67
MD5 45d20c84f1cf40ffa73a3471d5e4ac6f files/digest-python-mode-4.63 71
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (Darwin)
-
-iD8DBQFBkz8jVWNWqTUmv+0RApElAJ9ZtwRhmbTncC50sMTXaTGurTvW8gCeNs/V
-YisZkiGCCahrLbXnAQYe3qw=
-=GOHa
------END PGP SIGNATURE-----
+MD5 2f5fc2b5c01b7202432d5e420db9d66b files/55python-mode-gentoo.el 505
+MD5 45d20c84f1cf40ffa73a3471d5e4ac6f files/digest-python-mode-4.63-r1 71
diff --git a/app-emacs/python-mode/files/55python-mode-gentoo.el b/app-emacs/python-mode/files/55python-mode-gentoo.el
new file mode 100644
index 000000000000..5f2018b7c493
--- /dev/null
+++ b/app-emacs/python-mode/files/55python-mode-gentoo.el
@@ -0,0 +1,13 @@
+
+;;; python-mode site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(setq auto-mode-alist
+ (cons '("\\.py$" . python-mode) auto-mode-alist))
+(add-to-list 'auto-mode-alist '("\\.doctest$" . doctest-mode))
+(setq interpreter-mode-alist
+ (cons '("python" . python-mode)
+ interpreter-mode-alist))
+(autoload 'python-mode "python-mode" "Python editing mode." t)
+(autoload 'doctest-mode "doctest-mode" "Editing mode for Python Doctest examples." t)
+(require 'pycomplete)
diff --git a/app-emacs/python-mode/files/digest-python-mode-4.63-r1 b/app-emacs/python-mode/files/digest-python-mode-4.63-r1
new file mode 100644
index 000000000000..56a5c4f651b5
--- /dev/null
+++ b/app-emacs/python-mode/files/digest-python-mode-4.63-r1
@@ -0,0 +1 @@
+MD5 41adbb7bc4079d9aac3323e962c1e542 python-mode-1.0alpha.tar.gz 53666
diff --git a/app-emacs/python-mode/python-mode-4.63-r1.ebuild b/app-emacs/python-mode/python-mode-4.63-r1.ebuild
new file mode 100644
index 000000000000..6bda3c43cd86
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-4.63-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-4.63-r1.ebuild,v 1.1 2004/12/03 04:32:37 usata Exp $
+
+inherit distutils elisp
+
+IUSE=""
+
+MY_P="${PN}-1.0alpha"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Python Mode is a major editing mode for the XEmacs and FSF Emacs text editors."
+HOMEPAGE="http://sourceforge.net/projects/python-mode/"
+SRC_URI="mirror://sourceforge/python-mode/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc-macos"
+
+DEPEND="app-emacs/pymacs"
+
+SITEFILE="55python-mode-gentoo.el"
+
+src_compile() {
+ elisp-comp *.el || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ distutils_python_version
+ insinto /usr/lib/python${PYVER}/site-packages
+ doins pycomplete.py
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}