summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-03-29 21:35:23 +0000
committerUlrich Müller <ulm@gentoo.org>2009-03-29 21:35:23 +0000
commitcd5e9e08851285ac7de59c582a3f16994a3dced1 (patch)
treeed2a114f01d3dc1b370dc43bd5d539fbb1404e74 /app-emacs
parentAdding qt-svg:4 dependency. Fixes bug 264205 (diff)
downloadgentoo-2-cd5e9e08851285ac7de59c582a3f16994a3dced1.tar.gz
gentoo-2-cd5e9e08851285ac7de59c582a3f16994a3dced1.tar.bz2
gentoo-2-cd5e9e08851285ac7de59c582a3f16994a3dced1.zip
Use autopatch feature of elisp.eclass.
(Portage version: 2.2_rc27/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/htmlfontify/ChangeLog7
-rw-r--r--app-emacs/htmlfontify/files/51htmlfontify-gentoo.el1
-rw-r--r--app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild16
3 files changed, 11 insertions, 13 deletions
diff --git a/app-emacs/htmlfontify/ChangeLog b/app-emacs/htmlfontify/ChangeLog
index bf105ed7732c..aa5bcbe27eff 100644
--- a/app-emacs/htmlfontify/ChangeLog
+++ b/app-emacs/htmlfontify/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emacs/htmlfontify
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlfontify/ChangeLog,v 1.15 2007/11/07 11:48:26 ulm Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlfontify/ChangeLog,v 1.16 2009/03/29 21:35:22 ulm Exp $
+
+ 29 Mar 2009; Ulrich Mueller <ulm@gentoo.org> htmlfontify-0.20-r1.ebuild:
+ Use autopatch feature of elisp.eclass.
07 Nov 2007; Ulrich Mueller <ulm@gentoo.org>
-files/50htmlfontify-gentoo.el, -htmlfontify-0.20.ebuild:
diff --git a/app-emacs/htmlfontify/files/51htmlfontify-gentoo.el b/app-emacs/htmlfontify/files/51htmlfontify-gentoo.el
index f1209cedc260..d5cda291e0a4 100644
--- a/app-emacs/htmlfontify/files/51htmlfontify-gentoo.el
+++ b/app-emacs/htmlfontify/files/51htmlfontify-gentoo.el
@@ -1,5 +1,6 @@
;;; htmlfontify site-lisp configuration
+
(add-to-list 'load-path "@SITELISP@")
(autoload 'htmlfontify-buffer "htmlfontify" nil t)
(autoload 'htmlfontify-run-etags "htmlfontify" nil t)
diff --git a/app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild b/app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild
index 9c44f6a2e26f..37d736e4802f 100644
--- a/app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild
+++ b/app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild,v 1.2 2007/11/07 07:29:07 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild,v 1.3 2009/03/29 21:35:22 ulm Exp $
-inherit elisp eutils
+inherit elisp
MY_P=${PN}_${PV}+texinfo
DESCRIPTION="Turn an Emacs buffer into display-equivalent HTML"
@@ -15,14 +15,8 @@ KEYWORDS="amd64 ~ppc x86"
IUSE=""
S="${WORKDIR}/${MY_P/_/-}"
-
-SITEFILE=51${PN}-gentoo.el
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-emacs22.patch
-}
+ELISP_PATCHES="${P}-emacs22.patch"
+SITEFILE="51${PN}-gentoo.el"
src_compile() {
elisp-compile *.el || die "elisp-compile failed"