summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-04-17 19:21:45 +0000
committerUlrich Müller <ulm@gentoo.org>2007-04-17 19:21:45 +0000
commitc895afd3accdd3d3f984740327c73ce7d05793a0 (patch)
tree84004f9c2603c0ddeb63506048c997b0d7800781 /app-emacs
parentUpdate gtk icon cache after merge/unmerge (diff)
downloadgentoo-2-c895afd3accdd3d3f984740327c73ce7d05793a0.tar.gz
gentoo-2-c895afd3accdd3d3f984740327c73ce7d05793a0.tar.bz2
gentoo-2-c895afd3accdd3d3f984740327c73ce7d05793a0.zip
Fixed compilation. Use autoload.
(Portage version: 2.1.2.4)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/htmlfontify/ChangeLog10
-rw-r--r--app-emacs/htmlfontify/files/51htmlfontify-gentoo.el8
-rw-r--r--app-emacs/htmlfontify/files/digest-htmlfontify-0.20-r13
-rw-r--r--app-emacs/htmlfontify/files/htmlfontify-0.20-emacs22.patch19
-rw-r--r--app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild36
5 files changed, 75 insertions, 1 deletions
diff --git a/app-emacs/htmlfontify/ChangeLog b/app-emacs/htmlfontify/ChangeLog
index e188abc3164a..abd5860d0f54 100644
--- a/app-emacs/htmlfontify/ChangeLog
+++ b/app-emacs/htmlfontify/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emacs/htmlfontify
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlfontify/ChangeLog,v 1.12 2007/04/10 19:39:02 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlfontify/ChangeLog,v 1.13 2007/04/17 19:21:45 ulm Exp $
+
+*htmlfontify-0.20-r1 (17 Apr 2007)
+
+ 17 Apr 2007; Ulrich Mueller <ulm@gentoo.org>
+ +files/htmlfontify-0.20-emacs22.patch, +files/51htmlfontify-gentoo.el,
+ +htmlfontify-0.20-r1.ebuild:
+ Fixed compilation. Use "autoload" instead of "require". Don't install
+ LICENSE file.
10 Apr 2007; Christian Faulhammer <opfer@gentoo.org>
htmlfontify-0.20.ebuild:
diff --git a/app-emacs/htmlfontify/files/51htmlfontify-gentoo.el b/app-emacs/htmlfontify/files/51htmlfontify-gentoo.el
new file mode 100644
index 000000000000..f1209cedc260
--- /dev/null
+++ b/app-emacs/htmlfontify/files/51htmlfontify-gentoo.el
@@ -0,0 +1,8 @@
+
+;;; htmlfontify site-lisp configuration
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'htmlfontify-buffer "htmlfontify" nil t)
+(autoload 'htmlfontify-run-etags "htmlfontify" nil t)
+(autoload 'htmlfontify-copy-and-link-dir "htmlfontify" nil t)
+(autoload 'htmlfontify-load-rgb-file "hfy-cmap" nil t)
+(autoload 'htmlfontify-unload-rgb-file "hfy-cmap" nil t)
diff --git a/app-emacs/htmlfontify/files/digest-htmlfontify-0.20-r1 b/app-emacs/htmlfontify/files/digest-htmlfontify-0.20-r1
new file mode 100644
index 000000000000..aea5566ac084
--- /dev/null
+++ b/app-emacs/htmlfontify/files/digest-htmlfontify-0.20-r1
@@ -0,0 +1,3 @@
+MD5 551e196d63b07c2a75321d949731cdca htmlfontify_0.20+texinfo.tar.gz 61526
+RMD160 fff06bfc5a414a879c986c6f29930ff69f64b2d2 htmlfontify_0.20+texinfo.tar.gz 61526
+SHA256 68a1980130a593441c6ffd78f7c607b9290811c1046abd1098d64a90a37a3b9f htmlfontify_0.20+texinfo.tar.gz 61526
diff --git a/app-emacs/htmlfontify/files/htmlfontify-0.20-emacs22.patch b/app-emacs/htmlfontify/files/htmlfontify-0.20-emacs22.patch
new file mode 100644
index 000000000000..fb383952942a
--- /dev/null
+++ b/app-emacs/htmlfontify/files/htmlfontify-0.20-emacs22.patch
@@ -0,0 +1,19 @@
+--- htmlfontify.el~ 2003-03-09 17:57:01.000000000 +0100
++++ htmlfontify.el 2007-04-12 12:48:57.000000000 +0200
+@@ -70,7 +70,7 @@
+
+ ;; emacs 20 compatibility:
+ (if (<= 21 emacs-major-version) nil ;; already post emacs21, NOOP
+- (require 'hfy-emacs20))
++ (require 'hfy-emacs20)
+
+ ;; non-x-windows emacs20 duct tape...
+ ;; admittedly, we get no significant fontification here anyway
+@@ -78,6 +78,7 @@
+ (if window-system nil ;; NOOP
+ (defun x-color-defined-p (colour &optional frame)
+ (let ((window-system nil)) (if (hfy-colour-vals colour) t nil))))
++ )
+
+ ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
+ ;; I want these - can't be bothered requiring all of cl though.
diff --git a/app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild b/app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild
new file mode 100644
index 000000000000..dd071dbe2701
--- /dev/null
+++ b/app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/htmlfontify/htmlfontify-0.20-r1.ebuild,v 1.1 2007/04/17 19:21:45 ulm Exp $
+
+inherit elisp eutils
+
+MY_P=${PN}_${PV}+texinfo
+DESCRIPTION="Turn an Emacs buffer into display-equivalent HTML"
+HOMEPAGE="http://rtfm.etla.org/emacs/htmlfontify/"
+SRC_URI="http://rtfm.etla.org/emacs/htmlfontify/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P/_/-}"
+
+SITEFILE=51${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-emacs22.patch
+}
+
+src_compile() {
+ elisp-compile *.el || die "elisp-compile failed"
+ makeinfo htmlfontify.texi || die "makeinfo failed"
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo htmlfontify.info
+}