summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-04-18 06:26:29 +0000
committerUlrich Müller <ulm@gentoo.org>2008-04-18 06:26:29 +0000
commita54ad980d09275c37b43e2734b400e138672d338 (patch)
treec52f2409371eec93975a99b6fde49707e67443ec /app-emacs
parentRemove openoffice-2.3.1 for security bug #218080 (diff)
downloadgentoo-2-a54ad980d09275c37b43e2734b400e138672d338.tar.gz
gentoo-2-a54ad980d09275c37b43e2734b400e138672d338.tar.bz2
gentoo-2-a54ad980d09275c37b43e2734b400e138672d338.zip
Version bump. LICENSE changed to GPL-3.
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/gnus/ChangeLog9
-rw-r--r--app-emacs/gnus/gnus-5.10.10.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/app-emacs/gnus/ChangeLog b/app-emacs/gnus/ChangeLog
index 2008f348412a..fb9a8ab15af7 100644
--- a/app-emacs/gnus/ChangeLog
+++ b/app-emacs/gnus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/gnus
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnus/ChangeLog,v 1.30 2007/12/01 16:04:21 ulm Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnus/ChangeLog,v 1.31 2008/04/18 06:26:29 ulm Exp $
+
+*gnus-5.10.10 (18 Apr 2008)
+
+ 18 Apr 2008; Ulrich Mueller <ulm@gentoo.org> +gnus-5.10.10.ebuild:
+ Version bump. LICENSE changed to GPL-3.
01 Dec 2007; Ulrich Mueller <ulm@gentoo.org> gnus-5.10.8.ebuild:
Use SITEETC eclass variable.
diff --git a/app-emacs/gnus/gnus-5.10.10.ebuild b/app-emacs/gnus/gnus-5.10.10.ebuild
new file mode 100644
index 000000000000..ef906ff1c197
--- /dev/null
+++ b/app-emacs/gnus/gnus-5.10.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnus/gnus-5.10.10.ebuild,v 1.1 2008/04/18 06:26:29 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="The Gnus newsreader and mail-reader"
+HOMEPAGE="http://gnus.org/"
+SRC_URI="http://quimby.gnus.org/gnus/dist/${P}.tar.gz
+ http://theotp1.physik.uni-ulm.de/~ste/comp/emacs/gnus/release/${P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!app-emacs/gnus-cvs
+ !app-emacs/ngnus"
+
+SITEFILE=70${PN}-gentoo.el
+
+src_compile() {
+ econf \
+ --with-emacs --without-w3 --without-url \
+ --with-lispdir=${SITELISP}/${PN} \
+ --with-etcdir=${SITEETC} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall \
+ lispdir="${D}${SITELISP}/${PN}" \
+ etcdir="${D}${SITEETC}" \
+ || die "einstall failed"
+
+ # fix info documentation
+ for i in "${D}"/usr/share/info/*; do
+ mv "${i}" "${i}".info || die "mv info failed"
+ done
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+
+ dodoc ChangeLog GNUS-NEWS README todo || die "dodoc failed"
+}