summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-08-06 04:24:39 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-08-06 04:24:39 +0000
commit967a06d26d23dd7f30465f561fd8ca70d0f81e48 (patch)
tree9ec6db3275327d74eec5d6693ad6e611af2193a5 /app-emacs
parentSecurity punts for bug #140484. (diff)
downloadgentoo-2-967a06d26d23dd7f30465f561fd8ca70d0f81e48.tar.gz
gentoo-2-967a06d26d23dd7f30465f561fd8ca70d0f81e48.tar.bz2
gentoo-2-967a06d26d23dd7f30465f561fd8ca70d0f81e48.zip
New upstream version.
(Portage version: 2.1.1_pre4-r3)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/slime/ChangeLog10
-rw-r--r--app-emacs/slime/files/2.0.0.20060805/70slime-gentoo.el13
-rw-r--r--app-emacs/slime/files/2.0.0.20060805/README.Gentoo12
-rw-r--r--app-emacs/slime/files/2.0.0.20060805/swank-loader.lisp4
-rw-r--r--app-emacs/slime/files/2.0.0.20060805/swank.asd92
-rw-r--r--app-emacs/slime/files/digest-slime-2.0.0.200608053
-rw-r--r--app-emacs/slime/slime-2.0.0.20060805.ebuild62
7 files changed, 195 insertions, 1 deletions
diff --git a/app-emacs/slime/ChangeLog b/app-emacs/slime/ChangeLog
index 578b426c3fd7..0696611a4586 100644
--- a/app-emacs/slime/ChangeLog
+++ b/app-emacs/slime/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emacs/slime
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime/ChangeLog,v 1.26 2006/06/18 04:42:06 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime/ChangeLog,v 1.27 2006/08/06 04:24:39 mkennedy Exp $
+
+*slime-2.0.0.20060805 (06 Aug 2006)
+
+ 06 Aug 2006; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/2.0.0.20060805/70slime-gentoo.el,
+ +files/2.0.0.20060805/README.Gentoo, +files/2.0.0.20060805/swank.asd,
+ +files/2.0.0.20060805/swank-loader.lisp, +slime-2.0.0.20060805.ebuild:
+ New upstream version.
*slime-2.0.0.20060617 (18 Jun 2006)
diff --git a/app-emacs/slime/files/2.0.0.20060805/70slime-gentoo.el b/app-emacs/slime/files/2.0.0.20060805/70slime-gentoo.el
new file mode 100644
index 000000000000..2687bb5c4f14
--- /dev/null
+++ b/app-emacs/slime/files/2.0.0.20060805/70slime-gentoo.el
@@ -0,0 +1,13 @@
+
+;;; site-lisp configuration for slime-cvs
+
+(add-to-list 'load-path "@SITELISP@")
+(require 'slime)
+(slime-setup)
+
+;; this prevents us from requiring the user get dev-lisp/hyperspec
+;; (which is non-free) as a hard dependency
+
+(if (file-exists-p "/usr/share/doc/hyperspec/HyperSpec")
+ (setq common-lisp-hyperspec-root "file:///usr/share/doc/hyperspec/HyperSpec/")
+ (setq common-lisp-hyperspec-root "http://www.lispworks.com/reference/HyperSpec/"))
diff --git a/app-emacs/slime/files/2.0.0.20060805/README.Gentoo b/app-emacs/slime/files/2.0.0.20060805/README.Gentoo
new file mode 100644
index 000000000000..99353ee7aa29
--- /dev/null
+++ b/app-emacs/slime/files/2.0.0.20060805/README.Gentoo
@@ -0,0 +1,12 @@
+SLIME notes for Gentoo
+----------------------
+
+If you're interested in hacking this ebuild, Gentoo uses its own
+swank.asd system definition file and swank-loader.lisp.
+
+As always with CVS ebuilds, DO NOT report problems to upstream.
+Always report problems to the Gentoo Bugzilla at
+http://bugs.gentoo.org/.
+
+Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/app-emacs/slime/files/2.0.0.20060805/swank-loader.lisp b/app-emacs/slime/files/2.0.0.20060805/swank-loader.lisp
new file mode 100644
index 000000000000..4d9b157312e6
--- /dev/null
+++ b/app-emacs/slime/files/2.0.0.20060805/swank-loader.lisp
@@ -0,0 +1,4 @@
+
+;; This file is NOT part of SLIME
+
+(asdf:oos 'asdf:load-op :swank)
diff --git a/app-emacs/slime/files/2.0.0.20060805/swank.asd b/app-emacs/slime/files/2.0.0.20060805/swank.asd
new file mode 100644
index 000000000000..48b9335c5679
--- /dev/null
+++ b/app-emacs/slime/files/2.0.0.20060805/swank.asd
@@ -0,0 +1,92 @@
+;;; -*- mode: lisp; syntax: common-lisp; package: common-lisp -*-
+
+(defpackage #:swank-system
+ (:use #:common-lisp
+ #:asdf))
+
+(defpackage #:swank-loader
+ (:use #:common-lisp)
+ (:export #:*source-directory*
+ #:load-swank))
+
+(in-package #:swank-system)
+
+;; http://www.caddr.com/macho/archives/sbcl-devel/2004-3/3014.html
+
+(defclass unsafe-file (cl-source-file) ())
+
+(defmethod perform :around ((op compile-op) (c unsafe-file))
+ (setf (operation-on-warnings op) :ignore
+ (operation-on-failure op) :warn) ; adjust to taste
+ (call-next-method))
+
+(defmacro define-swank-system (&rest sysdep-components)
+ `(defsystem swank
+ :name "Swank is the Common Lips back-end to SLIME"
+ :serial t
+ :components ((:file "swank-backend")
+ (:file "nregex")
+ ,@(mapcar #'(lambda (component)
+ (if (atom component)
+ (list :file component)
+ component))
+ sysdep-components)
+ (:file "swank"))
+ :depends-on (#+sbcl sb-bsd-sockets)))
+
+#+sbcl (define-swank-system
+ "swank-sbcl"
+ "swank-source-path-parser"
+ "swank-source-file-cache"
+ "swank-gray")
+
+#+openmcl (define-swank-system
+ "metering"
+ "swank-openmcl"
+ "swank-gray")
+
+#+cmu (define-swank-system
+ "swank-source-path-parser"
+ "swank-source-file-cache"
+ "swank-cmucl")
+
+#+clisp (define-swank-system
+ "xref"
+ "metering"
+ "swank-clisp"
+ "swank-gray")
+
+#+armedbear (define-swank-system
+ "swank-abcl")
+
+#+ecl (define-swank-system
+ "swank-ecl" "swank-gray")
+
+(in-package #:swank-loader)
+
+(defvar *source-directory*
+ (make-pathname :name nil :type nil
+ :defaults (or *load-pathname* *default-pathname-defaults*))
+ "The directory where to look for the source.")
+
+
+(defun load-user-init-file ()
+ "Load the user init file, return NIL if it does not exist."
+ (load (merge-pathnames (user-homedir-pathname)
+ (make-pathname :name ".swank" :type "lisp"))
+ :if-does-not-exist nil))
+
+(defun load-site-init-file (directory)
+ (load (make-pathname :name "site-init" :type "lisp"
+ :defaults directory)
+ :if-does-not-exist nil))
+
+(defun load-swank (&key (source-directory *source-directory*))
+ (asdf:oos 'asdf:load-op :swank)
+ (funcall (intern (string :warn-unimplemented-interfaces) :swank-backend))
+ (load-site-init-file source-directory)
+ (load-user-init-file))
+
+(load-swank)
+
+;; swank.asd ends here
diff --git a/app-emacs/slime/files/digest-slime-2.0.0.20060805 b/app-emacs/slime/files/digest-slime-2.0.0.20060805
new file mode 100644
index 000000000000..73f0bdb3cd97
--- /dev/null
+++ b/app-emacs/slime/files/digest-slime-2.0.0.20060805
@@ -0,0 +1,3 @@
+MD5 68f2b0a712c9bf68f99d58c06584b73f slime-2.0.0.20060805.tar.gz 475257
+RMD160 10f7585ee41473cfa8eff8d72fa1a18cfb844617 slime-2.0.0.20060805.tar.gz 475257
+SHA256 d0fe439375fcc41cc2ff9954c21dcb705ccc3431e20b221af6098f7704b999a5 slime-2.0.0.20060805.tar.gz 475257
diff --git a/app-emacs/slime/slime-2.0.0.20060805.ebuild b/app-emacs/slime/slime-2.0.0.20060805.ebuild
new file mode 100644
index 000000000000..0a88d0c5f024
--- /dev/null
+++ b/app-emacs/slime/slime-2.0.0.20060805.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime/slime-2.0.0.20060805.ebuild,v 1.1 2006/08/06 04:24:39 mkennedy Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="SLIME, the Superior Lisp Interaction Mode (Extended)"
+HOMEPAGE="http://common-lisp.net/project/slime/"
+
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="virtual/emacs
+ dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ doc? ( sys-apps/texinfo )"
+
+CLPACKAGE=swank
+
+S=${WORKDIR}/slime/slime
+
+src_compile() {
+ elisp-comp *.el || die
+ use doc && make -C doc slime.info
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc} ${FILESDIR}/${PV}/swank-loader.lisp
+ elisp-site-file-install ${FILESDIR}/${PV}/70slime-gentoo.el
+ dodoc README* ChangeLog HACKING NEWS PROBLEMS
+ zcat ${D}/usr/share/doc/${PF}/ChangeLog.gz \
+ >${D}/usr/share/emacs/site-lisp/slime/ChangeLog
+ insinto /usr/share/common-lisp/source/swank
+ doins *.lisp ${FILESDIR}/${PV}/swank.asd
+ dodir /usr/share/common-lisp/systems
+ dosym /usr/share/common-lisp/source/swank/swank.asd \
+ /usr/share/common-lisp/systems
+ dodoc ${FILESDIR}/${PV}/README.Gentoo
+ if use doc; then
+ doinfo doc/slime.info
+ fi
+}
+
+pkg_preinst() {
+ unregister-common-lisp-source $CLPACKAGE || die
+}
+
+pkg_postrm() {
+ if ! [ -d /usr/share/common-lisp/source/$CLPACKAGE ]; then
+ unregister-common-lisp-source $CLPACKAGE || die
+ fi
+ elisp-site-regen || die
+}
+
+pkg_postinst() {
+ register-common-lisp-source $CLPACKAGE || die
+ elisp-site-regen || die
+ zcat /usr/share/doc/${PF}/README.Gentoo |while read line; do einfo "${line}"; done
+}