summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-06-24 21:33:58 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-06-24 21:33:58 +0000
commit87e9b4f398fba759f4232f24f09c969f97119085 (patch)
tree1d433453ee205534958d8a4bf89587fca69c27d7 /app-emacs
parentSecurity bumps for the CAN-2004-0495 and CAN-2004-0535 vulnerabilities. (Mani... (diff)
downloadgentoo-2-87e9b4f398fba759f4232f24f09c969f97119085.tar.gz
gentoo-2-87e9b4f398fba759f4232f24f09c969f97119085.tar.bz2
gentoo-2-87e9b4f398fba759f4232f24f09c969f97119085.zip
*** empty log message ***
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/slime-cvs/ChangeLog5
-rw-r--r--app-emacs/slime-cvs/files/swank.asd28
-rw-r--r--app-emacs/slime-cvs/slime-cvs-0-r1.ebuild22
3 files changed, 28 insertions, 27 deletions
diff --git a/app-emacs/slime-cvs/ChangeLog b/app-emacs/slime-cvs/ChangeLog
index 0c353bc3416c..c2fabf23aa47 100644
--- a/app-emacs/slime-cvs/ChangeLog
+++ b/app-emacs/slime-cvs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emacs/slime-cvs
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime-cvs/ChangeLog,v 1.6 2004/03/09 18:05:52 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime-cvs/ChangeLog,v 1.7 2004/06/24 21:33:58 mkennedy Exp $
+
+ 24 Jun 2004; <mkennedy@gentoo.org> files/swank.asd, slime-cvs-0-r1.ebuild:
+ Default to CVS HEAD.
09 Mar 2004; <mkennedy@gentoo.org> slime-cvs-0-r1.ebuild, files/swank.asd:
Correct for new GNU Emacs site-gentoo.el strategy; Add new upstream source,
diff --git a/app-emacs/slime-cvs/files/swank.asd b/app-emacs/slime-cvs/files/swank.asd
index 3bc4ddac2213..991c3822d637 100644
--- a/app-emacs/slime-cvs/files/swank.asd
+++ b/app-emacs/slime-cvs/files/swank.asd
@@ -6,25 +6,37 @@
(in-package #:swank-system)
+;; http://www.caddr.com/macho/archives/sbcl-devel/2004-3/3014.html
+
+(defclass unsafe-file (cl-source-file) ())
+
+(defmethod perform :around ((op compile-op) (c unsafe-file))
+ (setf (operation-on-warnings op) :ignore
+ (operation-on-failure op) :warn) ; adjust to taste
+ (call-next-method))
+
(defsystem #:swank
:name "Swank is the Common Lisp back-end to Slime"
:licence "GPL-2"
:components
#+cmu ((:file "swank-backend")
- (:file "swank")
+ (:file "nregex")
(:file "swank-source-path-parser")
- (:file "swank-cmucl"))
+ (:file "swank-cmucl")
+ (:file "swank"))
#+sbcl ((:file "swank-backend")
- (:file "swank")
+ (:file "swank-sbcl")
+ (:file "nregex")
(:file "swank-source-path-parser")
- (:file "swank-sbcl")
- (:file "swank-gray"))
+ (:file "swank-gray")
+ (:unsafe-file "swank"))
#+clisp ((:file "swank-backend")
- (:file "swank")
- (:file "xref")
+ (:file "nregex")
+ (:file "xref")
(:file "metering")
(:file "swank-clisp")
- (:file "swank-gray"))
+ (:file "swank-gray")
+ (:file "swank"))
#+sbcl :depends-on #+sbcl (:sb-bsd-sockets))
;; swank.asd ends here
diff --git a/app-emacs/slime-cvs/slime-cvs-0-r1.ebuild b/app-emacs/slime-cvs/slime-cvs-0-r1.ebuild
index 341d647f965b..b2c2773b3e1a 100644
--- a/app-emacs/slime-cvs/slime-cvs-0-r1.ebuild
+++ b/app-emacs/slime-cvs/slime-cvs-0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime-cvs/slime-cvs-0-r1.ebuild,v 1.3 2004/03/09 18:05:52 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/slime-cvs/slime-cvs-0-r1.ebuild,v 1.4 2004/06/24 21:33:58 mkennedy Exp $
ECVS_SERVER="common-lisp.net:/project/slime/cvsroot"
-if [ -z "${ECVS_BRANCH}" ]; then # user configurable
- ECVS_BRANCH="FAIRLY-STABLE"
+if [ -z "${ECVS_BRANCH}" ]; then
+ ECVS_BRANCH="HEAD"
fi
ECVS_MODULE="slime"
ECVS_USER="anonymous"
@@ -28,10 +28,6 @@ S="${WORKDIR}/slime"
CLPACKAGE=swank
-# TODO: ilisp and slime both provide a hyperspec.el. Erik Naggum's
-# hyperspec.el doesn't seem to be accessible anymore, but it would be
-# best to compare differences and provide app-emacs/hyperspec
-
src_compile() {
echo "(add-to-list 'load-path \".\")" >script
emacs --batch -q -l script -f batch-byte-compile hyperspec.el slime.el || die
@@ -42,8 +38,7 @@ src_install() {
elisp-site-file-install ${FILESDIR}/70slime-gentoo.el
dodoc README* ChangeLog
insinto /usr/share/common-lisp/source/swank
- # ChangeLog is needed at compile time!!
- doins *.lisp ${FILESDIR}/swank.asd ChangeLog
+ doins *.lisp ${FILESDIR}/swank.asd ChangeLog # required at runtime
dodir /usr/share/common-lisp/systems
dosym /usr/share/common-lisp/source/swank/swank.asd \
/usr/share/common-lisp/systems
@@ -66,15 +61,6 @@ pkg_postinst() {
SLIME notes for Gentoo
----------------------
-You can elect to set the ECVS_BRANCH environment variable when
-emerging slime-cvs. If unset, the default is to pull the
-FAIRLY-STABLE tag. eg.
-
- ECVS_BRANCH=HEAD emerge slime-cvs
-
-While this ebuild attempts to work for the FAIRLY-STABLE tag, it may
-not always work with CVS HEAD.
-
If you're interested in hacking this ebuild, slime-cvs uses its own
swank.asd system definition file and swank-loader.lisp.