summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-10-21 19:56:35 +0000
committerUlrich Müller <ulm@gentoo.org>2009-10-21 19:56:35 +0000
commit85e6785ecc9ba4a0302e994bc6647a188d476953 (patch)
tree5c55a7f119e396c9dc56c355e34069b553479a7e /app-emacs
parentadd use-deps for libsdl (diff)
downloadgentoo-2-85e6785ecc9ba4a0302e994bc6647a188d476953.tar.gz
gentoo-2-85e6785ecc9ba4a0302e994bc6647a188d476953.tar.bz2
gentoo-2-85e6785ecc9ba4a0302e994bc6647a188d476953.zip
Fix playing of sound. Install sound files under SITEETC.
(Portage version: 2.2_rc46/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/tnt/ChangeLog10
-rw-r--r--app-emacs/tnt/files/50tnt-gentoo.el5
-rw-r--r--app-emacs/tnt/files/tnt-2.6-sound.patch11
-rw-r--r--app-emacs/tnt/tnt-2.6-r2.ebuild28
4 files changed, 52 insertions, 2 deletions
diff --git a/app-emacs/tnt/ChangeLog b/app-emacs/tnt/ChangeLog
index bbe41dc08840..7027e7af2f5a 100644
--- a/app-emacs/tnt/ChangeLog
+++ b/app-emacs/tnt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/tnt
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/tnt/ChangeLog,v 1.14 2008/08/27 13:50:31 ulm Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/tnt/ChangeLog,v 1.15 2009/10/21 19:56:34 ulm Exp $
+
+*tnt-2.6-r2 (21 Oct 2009)
+
+ 21 Oct 2009; Ulrich Mueller <ulm@gentoo.org> +files/50tnt-gentoo.el,
+ +tnt-2.6-r2.ebuild, +files/tnt-2.6-sound.patch:
+ Fix playing of sound. Install sound files under SITEETC.
27 Aug 2008; Ulrich Mueller <ulm@gentoo.org> tnt-2.6-r1.ebuild:
Use eclass default instead of elisp-comp, bug 235442.
diff --git a/app-emacs/tnt/files/50tnt-gentoo.el b/app-emacs/tnt/files/50tnt-gentoo.el
new file mode 100644
index 000000000000..04eb0d16b7b4
--- /dev/null
+++ b/app-emacs/tnt/files/50tnt-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'tnt-open "tnt" "Start TNT" t)
+(autoload 'tnt-proxy-switch-servers "tnt" "Switch TNT proxy servers." t)
+(autoload 'tnt-proxy-toggle-proxy-use "tnt" "Toggle use of TNT proxy server." t)
+(autoload 'tnt-customize "tnt" "Customization of the group 'tnt'." t)
diff --git a/app-emacs/tnt/files/tnt-2.6-sound.patch b/app-emacs/tnt/files/tnt-2.6-sound.patch
new file mode 100644
index 000000000000..f8bd12df5a85
--- /dev/null
+++ b/app-emacs/tnt/files/tnt-2.6-sound.patch
@@ -0,0 +1,11 @@
+--- tnt-2.6-orig/tnt.el
++++ tnt-2.6/tnt.el
+@@ -4132,7 +4132,7 @@
+ (tnt-sound-exec
+ (with-output-to-string
+ (call-process shell-file-name nil t nil shell-command-switch (concat tnt-sound-exec " " tnt-sound-exec-args " " sound-file))))
+- (tnt-running-xemacs (play-sound-file sound-file))
++ ((fboundp 'play-sound-file) (play-sound-file sound-file))
+ (t (message "Warning: tnt-sound-exec is not set")))
+ (message "Warning: %s is not a readable file" sound-file)))
+
diff --git a/app-emacs/tnt/tnt-2.6-r2.ebuild b/app-emacs/tnt/tnt-2.6-r2.ebuild
new file mode 100644
index 000000000000..66794632c41c
--- /dev/null
+++ b/app-emacs/tnt/tnt-2.6-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/tnt/tnt-2.6-r2.ebuild,v 1.1 2009/10/21 19:56:34 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Client for the AOL Instant Messenging service using Emacs as its UI"
+HOMEPAGE="http://tnt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DOCS="ChangeLog PROTOCOL README"
+ELISP_PATCHES="${P}-sound.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins sounds/* || die
+
+ docinto procmail
+ dodoc procmail/* || die
+}