summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-10-21 18:11:13 +0000
committerUlrich Müller <ulm@gentoo.org>2009-10-21 18:11:13 +0000
commit8504a755682c6c502c28f983a3f1f3c2b3bfc149 (patch)
tree02f62809d1946e15f482c5ee3c416d16f55215fb /app-emacs
parentMarked stable on AMD64 as requested by Michael "Mr. Bones." Sterrett in bug #... (diff)
downloadgentoo-2-8504a755682c6c502c28f983a3f1f3c2b3bfc149.tar.gz
gentoo-2-8504a755682c6c502c28f983a3f1f3c2b3bfc149.tar.bz2
gentoo-2-8504a755682c6c502c28f983a3f1f3c2b3bfc149.zip
Version bump.
(Portage version: 2.2_rc46/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/rst/ChangeLog7
-rw-r--r--app-emacs/rst/rst-0.6.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/app-emacs/rst/ChangeLog b/app-emacs/rst/ChangeLog
index 9c70ac538649..52c62d73027f 100644
--- a/app-emacs/rst/ChangeLog
+++ b/app-emacs/rst/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/rst
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/rst/ChangeLog,v 1.29 2009/09/20 18:52:00 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/rst/ChangeLog,v 1.30 2009/10/21 18:11:13 ulm Exp $
+
+*rst-0.6 (21 Oct 2009)
+
+ 21 Oct 2009; Ulrich Mueller <ulm@gentoo.org> +rst-0.6.ebuild:
+ Version bump.
*rst-0.5-r1 (20 Sep 2009)
diff --git a/app-emacs/rst/rst-0.6.ebuild b/app-emacs/rst/rst-0.6.ebuild
new file mode 100644
index 000000000000..72b84386b170
--- /dev/null
+++ b/app-emacs/rst/rst-0.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/rst/rst-0.6.ebuild,v 1.1 2009/10/21 18:11:13 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="ReStructuredText support for Emacs"
+HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki/reStructuredText"
+SRC_URI="mirror://sourceforge/docutils/docutils-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/docutils-${PV}/tools/editors/emacs"
+DOCS="README.txt"
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_setup() {
+ local have_emacs=$(elisp-emacs-version)
+ if [ "${have_emacs%%.*}" -ge 23 ]; then
+ echo
+ elog "Please note that \"${PN}\" is already included with Emacs 23 or"
+ elog "later, so ${CATEGORY}/${PN} is only needed for lower versions."
+ elog "You may select the active Emacs version with \"eselect emacs\"."
+ fi
+}
+
+src_install() {
+ elisp_src_install
+ # prevent inclusion of package dir by subdirs.el
+ touch "${D}${SITELISP}/${PN}/.nosearch"
+}