summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-04-28 07:54:14 +0000
committerUlrich Müller <ulm@gentoo.org>2008-04-28 07:54:14 +0000
commit514a42e050c58a0ead9454090c22dba976753dd5 (patch)
treebc8d9fcb62a89c0b1b4c8b77a31faa64ff66821c /app-emacs
parentFix digest on gnustep-gui-0.12.0, bug #219429 (diff)
downloadgentoo-2-514a42e050c58a0ead9454090c22dba976753dd5.tar.gz
gentoo-2-514a42e050c58a0ead9454090c22dba976753dd5.tar.bz2
gentoo-2-514a42e050c58a0ead9454090c22dba976753dd5.zip
Also add snapshot recommended by upstream, bug 219449.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/navi2ch/ChangeLog8
-rw-r--r--app-emacs/navi2ch/navi2ch-1.7.5_p20070510.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/app-emacs/navi2ch/ChangeLog b/app-emacs/navi2ch/ChangeLog
index f7b7575fe739..a808e805e71d 100644
--- a/app-emacs/navi2ch/ChangeLog
+++ b/app-emacs/navi2ch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/navi2ch
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/ChangeLog,v 1.36 2008/04/27 17:56:54 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/ChangeLog,v 1.37 2008/04/28 07:54:14 ulm Exp $
+
+*navi2ch-1.7.5_p20070510 (28 Apr 2008)
+
+ 28 Apr 2008; Ulrich Mueller <ulm@gentoo.org>
+ +navi2ch-1.7.5_p20070510.ebuild:
+ Also add snapshot recommended by upstream, bug 219449.
*navi2ch-1.7.5_p20080325 (27 Apr 2008)
diff --git a/app-emacs/navi2ch/navi2ch-1.7.5_p20070510.ebuild b/app-emacs/navi2ch/navi2ch-1.7.5_p20070510.ebuild
new file mode 100644
index 000000000000..fb5e9e18aa4a
--- /dev/null
+++ b/app-emacs/navi2ch/navi2ch-1.7.5_p20070510.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/navi2ch-1.7.5_p20070510.ebuild,v 1.1 2008/04/28 07:54:14 ulm Exp $
+
+inherit elisp
+
+MY_PV=${PV#*_p}
+DESCRIPTION="A navigator for 2ch"
+HOMEPAGE="http://navi2ch.sourceforge.net/"
+SRC_URI="http://navi2ch.sourceforge.net/snapshot/${PN}-cvs_0.0.${MY_PV}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+SITEFILE=50${PN}-gentoo.el
+S="${WORKDIR}/${PN}-cvs-${MY_PV}"
+
+src_compile() {
+ econf \
+ --with-lispdir=${SITELISP}/${PN} \
+ --with-icondir=${SITEETC}/${PN} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ elisp-install ${PN} contrib/*.el || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ dodoc ChangeLog* NEWS README TODO
+ newdoc contrib/README README.contrib
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog
+ elog "Please add to your ~/.emacs"
+ elog "If you use mona-font,"
+ elog "\t(setq navi2ch-mona-enable t)"
+ elog "If you use izonmoji-mode,"
+ elog "\t(require 'izonmoji-mode)"
+ elog "\t(add-hook 'navi2ch-bm-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-article-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-popup-article-mode-hook 'izonmoji-mode-on)"
+ elog
+}