summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-11-21 18:01:23 +0000
committerUlrich Müller <ulm@gentoo.org>2011-11-21 18:01:23 +0000
commit4f87772a19be11b63b8b1ca4d28d8f2ac6dbf949 (patch)
tree7e0971a4d3d3f3f68b94971c14f5b16679ed1f11 /app-emacs
parentVersion bump, bug 391211. (diff)
downloadgentoo-2-4f87772a19be11b63b8b1ca4d28d8f2ac6dbf949.tar.gz
gentoo-2-4f87772a19be11b63b8b1ca4d28d8f2ac6dbf949.tar.bz2
gentoo-2-4f87772a19be11b63b8b1ca4d28d8f2ac6dbf949.zip
Version bump.
(Portage version: 2.1.10.36/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/python-mode/ChangeLog7
-rw-r--r--app-emacs/python-mode/python-mode-6.0.3.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/app-emacs/python-mode/ChangeLog b/app-emacs/python-mode/ChangeLog
index 54a060016ad4..4b3de490b7f5 100644
--- a/app-emacs/python-mode/ChangeLog
+++ b/app-emacs/python-mode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/python-mode
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.50 2011/02/20 13:48:07 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.51 2011/11/21 18:01:23 ulm Exp $
+
+*python-mode-6.0.3 (21 Nov 2011)
+
+ 21 Nov 2011; Ulrich Mueller <ulm@gentoo.org> +python-mode-6.0.3.ebuild:
+ Version bump.
*python-mode-5.2.0 (20 Feb 2011)
diff --git a/app-emacs/python-mode/python-mode-6.0.3.ebuild b/app-emacs/python-mode/python-mode-6.0.3.ebuild
new file mode 100644
index 000000000000..90da1a6150ff
--- /dev/null
+++ b/app-emacs/python-mode/python-mode-6.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-6.0.3.ebuild,v 1.1 2011/11/21 18:01:23 ulm Exp $
+
+EAPI=4
+
+inherit elisp
+
+MY_P="${PN}.el-${PV}"
+DESCRIPTION="An Emacs major mode for editing Python source"
+HOMEPAGE="https://launchpad.net/python-mode"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="NEWS"
+
+src_prepare() {
+ # remove XEmacs specific file
+ rm highlight-indentation.el || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Note that doctest support is split out to app-emacs/doctest-mode."
+}