summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2015-03-25 10:58:24 +0000
committerUlrich Müller <ulm@gentoo.org>2015-03-25 10:58:24 +0000
commit3b76a8aea4d06c47ead928fd99d5a0d77499b851 (patch)
treee89afd3fc9aae58d4a08eddbcc3c89a28ceb06e2 /app-emacs
parentbump; re-based patch for new version (diff)
downloadgentoo-2-3b76a8aea4d06c47ead928fd99d5a0d77499b851.tar.gz
gentoo-2-3b76a8aea4d06c47ead928fd99d5a0d77499b851.tar.bz2
gentoo-2-3b76a8aea4d06c47ead928fd99d5a0d77499b851.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/magit/ChangeLog9
-rw-r--r--app-emacs/magit/magit-1.2.2.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/app-emacs/magit/ChangeLog b/app-emacs/magit/ChangeLog
index 0d4e4912f723..ff39cfeae6ab 100644
--- a/app-emacs/magit/ChangeLog
+++ b/app-emacs/magit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/magit
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/magit/ChangeLog,v 1.15 2014/08/09 10:42:50 nimiux Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/magit/ChangeLog,v 1.16 2015/03/25 10:58:24 ulm Exp $
+
+*magit-1.2.2 (25 Mar 2015)
+
+ 25 Mar 2015; Ulrich Müller <ulm@gentoo.org> +magit-1.2.2.ebuild:
+ Version bump.
09 Aug 2014; Chema Alonso <nimiux@gentoo.org> magit-1.2.0-r1.ebuild:
Stable for amd64 wrt bug #509736
diff --git a/app-emacs/magit/magit-1.2.2.ebuild b/app-emacs/magit/magit-1.2.2.ebuild
new file mode 100644
index 000000000000..a5236e78e93b
--- /dev/null
+++ b/app-emacs/magit/magit-1.2.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/magit/magit-1.2.2.ebuild,v 1.1 2015/03/25 10:58:24 ulm Exp $
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="An Emacs mode for GIT"
+HOMEPAGE="http://magit.github.io/"
+SRC_URI="https://github.com/magit/magit/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="contrib"
+RESTRICT="test"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ # The upstream build system ignores errors during byte-compilation
+ # and happily installs broken files, causing errors at runtime.
+ # Call elisp-compile, in order to catch them here already.
+ elisp-compile *.el
+ emake core docs
+ use contrib && emake contrib
+ rm 50magit.el magit-pkg.el || die
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo magit.info
+ dodoc README.md
+
+ if use contrib; then
+ elisp-install ${PN} contrib/*.{el,elc}
+ dobin contrib/magit
+ fi
+}