summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-11-06 19:35:27 +0000
committerUlrich Müller <ulm@gentoo.org>2009-11-06 19:35:27 +0000
commit2fb34e7e9360fe9b237e59e75445785bb4acc5e2 (patch)
tree3fa00d1ac881239de2d0771aa9e952793a3afcff /app-emacs
parentMarking maksed qt4-qtruby for removal in 30 days, bug 224951 (diff)
downloadgentoo-2-2fb34e7e9360fe9b237e59e75445785bb4acc5e2.tar.gz
gentoo-2-2fb34e7e9360fe9b237e59e75445785bb4acc5e2.tar.bz2
gentoo-2-2fb34e7e9360fe9b237e59e75445785bb4acc5e2.zip
Version bump.
(Portage version: 2.2_rc46/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/haskell-mode/ChangeLog11
-rw-r--r--app-emacs/haskell-mode/haskell-mode-2.4_p20080826.ebuild29
-rw-r--r--app-emacs/haskell-mode/haskell-mode-2.5.1.ebuild10
-rw-r--r--app-emacs/haskell-mode/haskell-mode-2.6.2.ebuild32
4 files changed, 51 insertions, 31 deletions
diff --git a/app-emacs/haskell-mode/ChangeLog b/app-emacs/haskell-mode/ChangeLog
index c0e4e1a45f03..fa38df5f3d4b 100644
--- a/app-emacs/haskell-mode/ChangeLog
+++ b/app-emacs/haskell-mode/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-emacs/haskell-mode
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/ChangeLog,v 1.33 2009/10/27 06:31:27 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/ChangeLog,v 1.34 2009/11/06 19:35:27 ulm Exp $
+
+*haskell-mode-2.6.2 (06 Nov 2009)
+
+ 06 Nov 2009; Ulrich Mueller <ulm@gentoo.org>
+ -haskell-mode-2.4_p20080826.ebuild, haskell-mode-2.5.1.ebuild,
+ +haskell-mode-2.6.2.ebuild:
+ Version bump. Add elog message warning about the necessary reconfiguration.
+ Use our eclass functions in src_compile() because the Makefile sucks.
+ Remove intermediate version.
*haskell-mode-2.5.1 (27 Oct 2009)
diff --git a/app-emacs/haskell-mode/haskell-mode-2.4_p20080826.ebuild b/app-emacs/haskell-mode/haskell-mode-2.4_p20080826.ebuild
deleted file mode 100644
index 87956e334d83..000000000000
--- a/app-emacs/haskell-mode/haskell-mode-2.4_p20080826.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/haskell-mode-2.4_p20080826.ebuild,v 1.1 2008/10/06 16:10:58 ulm Exp $
-
-inherit elisp
-
-DESCRIPTION="Mode for editing (and running) Haskell programs in Emacs"
-HOMEPAGE="http://www.haskell.org/haskell-mode/
- http://www.iro.umontreal.ca/~monnier/elisp/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
-
-S="${WORKDIR}/${PN}"
-SITEFILE="51${PN}-gentoo.el"
-
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- elisp_src_install
- dodoc ChangeLog NEWS README
- insinto /usr/share/doc/${PF}
- doins *.hs
-}
diff --git a/app-emacs/haskell-mode/haskell-mode-2.5.1.ebuild b/app-emacs/haskell-mode/haskell-mode-2.5.1.ebuild
index 2f2c7bdd67cb..c7fe65a015fe 100644
--- a/app-emacs/haskell-mode/haskell-mode-2.5.1.ebuild
+++ b/app-emacs/haskell-mode/haskell-mode-2.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/haskell-mode-2.5.1.ebuild,v 1.1 2009/10/27 06:31:27 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/haskell-mode-2.5.1.ebuild,v 1.2 2009/11/06 19:35:27 ulm Exp $
inherit elisp
@@ -20,3 +20,11 @@ SITEFILE="50${PN}-gentoo.el"
src_compile() {
emake || die "emake failed"
}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "If you update from version 2.4 or earlier you must reconfigure,"
+ elog "or indentation will not work."
+ elog "Read the README file in /usr/share/doc/${PF}."
+}
diff --git a/app-emacs/haskell-mode/haskell-mode-2.6.2.ebuild b/app-emacs/haskell-mode/haskell-mode-2.6.2.ebuild
new file mode 100644
index 000000000000..fd2bb0697eb6
--- /dev/null
+++ b/app-emacs/haskell-mode/haskell-mode-2.6.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/haskell-mode-2.6.2.ebuild,v 1.1 2009/11/06 19:35:27 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Mode for editing (and running) Haskell programs in Emacs"
+HOMEPAGE="http://projects.haskell.org/haskellmode-emacs/
+ http://www.haskell.org/haskellwiki/Haskell_mode_for_Emacs"
+SRC_URI="http://projects.haskell.org/haskellmode-emacs/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DOCS="NEWS README *.hs" #ChangeLog
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ # the Makefile of 2.6.2 sucks, use eclass functions instead
+ elisp-make-autoload-file haskell-site-file.el || die
+ elisp-compile *.el || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "If you update from version 2.4 or earlier you must reconfigure,"
+ elog "or indentation will not work."
+ elog "Read the README file in /usr/share/doc/${PF}."
+}